Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Autofs .iso-Images mounten

Frage Linux

Mitglied: ChristianRehbein90

ChristianRehbein90 (Level 1) - Jetzt verbinden

20.10.2010 um 09:55 Uhr, 4798 Aufrufe, 3 Kommentare

Hallo und guten Morgen,

ich möchte meine install .iso-files dynamisch mounten. Dies funktioniert auch ohne weiteres mit autofs.

Ich habe folgende Zeile in meine auto.master angefügt:

/srv/www/htdocs/install /etc/auto.iso –timeout=60

Danach habe ich eine auto.iso Datei in /etc angelegt. und mit folgendem Inhalt gefüllt:


SLES11-SP1 -fstype=iso9660,ro,loop :/srv/www/htdocs/install/isos/SLES11-SP1.iso
RHEL5 -fstype=iso9660,ro,loop :/srv/www/htdocs/install/isos/RHEL-55.iso
OpenSuse11.3 -fstype=iso9660,ro,loop :/srv/www/htdocs/install/isos/OpenSuse113.iso

Jetzt musste ich nur noch den Dienst starten :

/etc/init.d/autofs start

und mein Automounter funktioniert.

Jetzt komme ich zu meine Frage meinem Problem!

In meinem iso Verzeichnis liegen mehr als 3 Isos herum und es werden stätig mehr. Ich möchte es wenn möglich umgehen jede einzelne .iso Datei in meine auto.iso Datei einzutragen. Gibt es eine möglichkeit dies automatisch zu machen. Sprich das mein autofs zu jeder bestimmten .iso-datei die im Iso Verzeichnis liegt einen automatischen Mountpoint erzeugt ohne das ein Eintrag in der auto.iso manuell hinzugefügt werden muss.

Vielen Dank für eure Hilfe im Voraus.

hewlett
Mitglied: micneu
31.10.2010 um 12:19 Uhr
schreib dir doch ein script was immer die verzeichnisse prüft in den du die entsprechende .iso dateien hast.
diese wird alle 5 minuten einmal ausgeführt und trägt dir die werte in deine konfig ein.
oder als ausführbares script das
z. b.:
1. prüfe verzeichnis /srv/www/htdocs/install/isos/ auf inhalt. (find /srv/www/htdocs/install/isos/ -name *.iso)
2. vergleiche alle name.iso mit /etc/auto.iso (z. b. mit grep)
3. ist name.iso nicht eingetragen,füge diesen eintrag zu (den namen kannst du von datei namen ableiten (. z. b. (namen.iso das .iso mit sed vom dateinamen abziehen)
diese werte sind ja statisch:
-fstype=iso9660,ro,loop
:/srv/www/htdocs/install/isos/

da würde ich mit variablen arbeiten

am ende des scripts kannst du den dienst autofs neustarten oder mit killall -HUP autofs den diens veranlassen die konfig neu einzulesen.


jetzt habe ich noch fragen, warum hast du die iso dateine in deinem www verzeichnis?
was hast du damit genau vor?
willst du den inhalt der iso dateien auf eurem webserver bereitstellen?

gruß michael
Bitte warten ..
Mitglied: micneu
31.10.2010 um 14:42 Uhr
hier habe ich eben mal kurz gemacht,
etwas anpassung musst du noch machen

01.
#!/bin/bash 
02.
03.
## Prueft verzeichnis und fuegt den eintrag des .iso der /etc/auto.iso zu 
04.
## (C) M. Neumann 31.10.2010 
05.
## 
06.
## 
07.
ZAEHLER=1 
08.
ISO=/daten/tftpboot/ 
09.
TYPE="-fstype=iso9660,ro,loop" 
10.
for i in $(find $ISO -name *.iso); do 
11.
#   echo $ZAEHLER - $i 
12.
    ZAEHLER=$((ZAEHLER+1)) 
13.
    b=`echo $i | sed -e "s/\/.*\///"` 
14.
    c=`echo $b | sed -e "s/.iso//"` 
15.
    if grep "$b" /etc/auto.iso >/dev/null 2>&1 ; then 
16.
        echo "datei ist eingetragen" 
17.
    else 
18.
        echo "Datei ist nicht eingetragen" 
19.
        echo "$c $TYPE $i" >> /etc/auto.iso 
20.
    fi 
21.
done
Bitte warten ..
Mitglied: micneu
26.04.2011 um 15:56 Uhr
und wie ist der stand?
klappt das so mit dem script?

gruß michael
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
SAN, NAS, DAS
QNAP Virtualization Station - CD ISO mounten (5)

Frage von emeriks zum Thema SAN, NAS, DAS ...

Windows Server
gelöst Suche Windows Server 2003 Enterprise ISO (8)

Frage von Herbrich19 zum Thema Windows Server ...

Windows Server
WIM Images anpassen für WDS Server (5)

Frage von IT-Biene zum Thema Windows Server ...

Windows 7
Reines ISO File auf Windows 7 installieren (9)

Frage von LukeKauf zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...