Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

automatisch erstelle Netzwerkverknuepfungen langsam, warum ?

Frage Microsoft

Mitglied: funcry

funcry (Level 1) - Jetzt verbinden

06.06.2008, aktualisiert 10.06.2008, 3793 Aufrufe, 5 Kommentare

Szenario: w2k3 Domäne mit drei DC und zwei Nameservern. Der dritte DC ist ein w2k3 Fileserver (Core 2 Duo Prozessor) ohne Nameserver. Clients alle mit XP prof. Alle Server + Clients feste IP-Adressen.

Ich habe festgestellt dass der Fileserver teilweise eine hohe CPU-Last bei Netzwerkzugriffen vom Client (beliebig) auf eine Netzwerkfreigabe (auf dem Fileserver) hat.

Nach eine schier endlosen Suche und der Überprüfung unzähliger Einstellungen habe ich das Performance-Problem einkreisen können.

So stellt sich das Performance-Problem dar:
lsass.exe sowie dfssvc.exe verursachen zusammen bis zu 50% CPU-Last auf dem Fileserver beim Zugriff auf die Freigabe.

Bisher gecheckt: dcdiag, netdiag, Virenscanner, Namservereinstellungen, SMB-Signing. Alles korrekt eingestellt nach meinem Kentnisstand.

Dann habe ich festgestellt dass die langsame Performance nur dann auftritt, wenn man am Client (beliebiger Client) über die von Winodws selbst erstellte Verknüpfung in der Netzwerkumgebung auf den Server zugreift.


Beispiel:

Wenn ich den langen Weg am Client gehe:
Netzwerkumgebung->Microsoft Windows Netzwerk->File1-hn\Freigabename
ist die Performance schnell und der Server erzeugt keine erkennbare CPU Last beim Zugriff.

Wenn ich den Weg über die von Windows automatisch erstellte Netzwerkverknüpfung gehe:
Netzwerkumgebung->Freigamename an File1-hn
Ist die Performance langsam und der Fileserver erzeugt die genannte CPU Last.


Jetzt habe ich mir vom schnellen Weg und vom Lagnsamen Weg jeweils eine Verknüpfung der Freigabe am Client auf den Desktop gezogen. Die Verknüpfungen sind scheinbar identisch, es werden keinerleid Unterschiede unter Eigenschaften angezeigt. Kopiere ich die Verknüpfung jedoch in eine TXT-Datei und sehe diese an, stelle ich fest dass die beiden Dateien nicht identisch sind...

Es gibt zwar Tools die eine .lnk-Datei auslesen können, aber die Argumente sind stets die gleichen. Ich vermute, dass bei der Langsamen Verknüpfung zusätzliche DNS-Abfragen stattfinden, aber warum ? Hängt das möglicherweise damit zusammen, dass eine nicht sichtbare Information in der Verknüpfung enthalten ist welche irgendwie etwas mit dem "Microsoft Windows Netzwerk" zu tun hat ?

Ich habe den Inhalt der beiden LNK-Datein diesem Posting hinzugefügt (s. Anhang).
Mitglied: StrongOne
06.06.2008 um 10:04 Uhr
Servus...

... spontan fällt mir dazu erst mal nix ein, da ich das prob noch nie hatte bzw. ich mach das nie so... ich gebe die freigaben per script immer gleich meinen clients mit.

Aber zu deinem prob... ist bei den Clients und Servern Netbios noch konfiguriert?

da du keine Win9x bzw. NT system mehr hast, kannst du das getrost abschalten. Wenn du LTP zu Ethernet Druckserver nutzt, musst du dann gegebenfalls noch DNS etc. anpassen danach.

Sonst würde ich allg. nur sagen.. Verteile die Freigaben über script. aber ich bastel mal deine umgebung bei mir virtuell hin... vielleicht kriege ich ja auch das prob... und dann dir dann mehr mitteilen.

die Server win2k3 standard oder enterprise?
Bitte warten ..
Mitglied: funcry
06.06.2008 um 10:27 Uhr
Danke für deine Bemühungen. Der Fileserver (DC) ist w2k3 Standard R2. Die beiden anderen DC sind w2k3 Standard.
Bitte warten ..
Mitglied: 60730
06.06.2008 um 10:55 Uhr
servus,

auch ich kann dir nur raten, lass die Finger vom "Klickbunti" Weg und mache es "in der schwarzen Dosbox Hölle"
Das kannst du zentral steuern und es läuft nicht nur deswegen "besser".

Das beste Tool (in meinen Augen) dafür ist Kixtart. Dazu gibt es sehr viele Howtos und auch einen Abschnitt in diesem Forum.
Bitte warten ..
Mitglied: funcry
06.06.2008 um 11:51 Uhr
Danke für den Hinweis, das werde ich als Step 2 druchführen. Ein entsprechendes Script hat mir ein Kollege zukommen lassen - was ich bald prüfen werde.

Derzeit gehe ich noch davon aus, dass trotz allem Suchens, Fehler in der AD Konfiguration sind. Es könnte zwar eine falsche Fährte zu diesem Problem sein, aber vielleicht hängt es doch damit zusammen:

Wenn ich einen Client neu einrichte, wird normalerweise in der Netzwerkumgebung nichts angezeigt. Das hat mich bisher nicht weiter gestört, da ich hier einfach die Verknüpfung "Microsoft Windows Netzwerk" welche z.b. angezeigt wird wenn man "Netzlaufwerk Verbinden" auswählt, herübergezogen habe. Vielleicht ist hier der Hund begraben.

Bei genauerem Nachforschen fällt auf, auf allen DC sind die Reg.-Keys gesetzt:
HKLM\System\CurrentControlSet\Services\Browser\Parameters\IsDomainMaster = FALSE
HKLM\System\CurrentControlSet\Services\Browser\Parameters\MaintainServerList = yes
Bitte warten ..
Mitglied: funcry
10.06.2008 um 10:42 Uhr
Intensive Nachforschungen inklusive einer Analyse des Netzwerktraffics haben das Problem nochmals verdeutlicht.

Zusammenfassen kann ich sagen:

Die langsame Verknüpfung erzeugt erheblichen Traffic - etwa Faktor 100 - im Vergleich zur schnellen Verknüpfung. Allein ein F5 verursacht 180000 Pakete. Die langsame Verknüpfung nutzt _immer_ $IPC. Die schnelle Verknüpfung kommte ohne $IPC aus.

Zahlreiche andere Nutzer haben exact (!!) das gleiche Problem (s. Google). Tatsächlich haben viele die das Problem haben ebenfalls eine Traffic-Analyse durchgeführt, konnten aber keine Lösung finden, ausser dem Workaround über Laufwerksverknüpfungen.

Aber jetzt gibt es endlich eine (trotzdem unbefriedigende) Lösung:
Das XP SP3 behebt genau dieses Problem.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
Server sehr langsam bei vielen kleinen Dateien (5)

Frage von MichiBLNN zum Thema Windows Server ...

Festplatten, SSD, Raid
Samsung SSD zu langsam (20)

Frage von Protected zum Thema Festplatten, SSD, Raid ...

Microsoft Office
Registerkarte in Excel automatisch färben (12)

Frage von ralfkausk zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...