Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Automatische Deinstallation Office 2003 und Installation Office 2010

Frage Microsoft Microsoft Office

Mitglied: HarryK

HarryK (Level 1) - Jetzt verbinden

14.10.2013 um 11:10 Uhr, 4269 Aufrufe, 26 Kommentare, 4 Danke

Hallo Zusammen,

bei uns in der Firma soll ein Upgrade von MS Office 2003 auf Office 2010 stattfinden.
Damit ich nicht zu jedem Rechner laufen muss, würde ich dies gerne über Gruppenrichtlinien verteilen.

Es handelt sich um ca. 120 Clients
Windows7 32 und 64 bit
Windows XP 32 und 64 bit
Alle Rechner in einer Domäne
Domaincontroller: Win Server 2008R2


Am Besten wäre es, wenn ich die Deinstallation von Office 2003 bei der Abmeldung eines Users bzw. Herunterfahren eines Clients starten könnte. Bei der nächsten Anmeldung bzw. starten des Clients sollte die Installation von Office 2010 gesartet werden.
Alles natürlich im Silent-Modus und ohne Benutzereingabe.
Evtl. ist auch eine einfachere oder "schönere" Methode möglich.

Ich bin für jeden Ratschlag dankbar.

Gruß

Harry
Mitglied: Ravers
14.10.2013 um 11:24 Uhr
Hi,

hatte ähnliches vor, aber unser (sehr großes) Systemhaus hat mir davon abgeraten, da die Probleme die auftauchen meist recht groß sind, so deren Erfahrung.
Rücksprache mit 2 weiteren Systemhäusern: die haben dies bestätigt.
Es geht, aber ich bin dann auch den manuellen Weg gegangen. Man sieht auch gleich deren Probleme beim De- und Installieren und kann reagieren. M.E. besser als hunderte von Logs zu durchsuchen und nach Fehlern Ausschau zu halten.

Hier gab es mal ein Script (vermutlich VON einer anderen Officeversion) - such mal -> wenn du meinen Empfehlungen nicht nachkommen willst (was ich ja auch verstehen könnte )

greetz
Ravers
Bitte warten ..
Mitglied: HarryK
14.10.2013 um 11:43 Uhr
Hey Ravers,

danke für deine Antwort und deinen Erfahrungen.
In meinem Fall ist die manuelle Installation natürlich auch möglich, da sich alle Clients in einem Gebäude aufhalten und ich zu allen Zugang habe. Bei den mobilen Endgeräten, sprich Laptops wird es allerdings auch schon wieder schwieriger. Hier muss ich dann erst einmal Termine mit den betroffenen Mitarbeitern vereinbaren und schauen wann sich diese wieder innerhalb der Firma befinden um die Installation durchführen zu können.

Bei größeren Firmen mit vielen Aussenstandorten ist dies wohl keine Option. Gut, die haben dann auch sicherlich professionelle Systeme zur Softwareverteilung im Einsatz.

Es ist auch nicht zwingend notwendig dies per GPO zu verteilen. Wenn es die Mögklichkeit gibt ein Script zu basteln, welches der Mitarbeiter ausführen soll um die Deinstallation und anschließende Installation zu starten, dann bin ich auch zufrieden ;).

Noch irgendwelche Ideen?
Bitte warten ..
Mitglied: Rudbert
14.10.2013, aktualisiert um 12:42 Uhr
Hallo,


wir haben auch etwa die selbe Anzahl Clients und setzen seit letztem Jahr ein Client-Management-System (Baramundi) ein, nachdem wir auch ewig mit GPO-Softwareverteilung gearbeitet und rumgeärgert haben; meiner Meinung nach macht dies auch bei dieser Anzahl Systemen schon Sinn, da die Zeitersparnis durch die automatische Software- und Updateverteilung enorm ist.

Wäre das keine Option für dich? Gibt auch OpenSource-Tools (opsi, wpkg, local update publisher für wsus).

Ansonsten entweder manuelle Installation aber mit vorkonfiguriertem Paket über das MS-Tool (http://technet.microsoft.com/de-de/library/cc982159(v=office.14).aspx#B ...) oder Verteilung per GPO/Loginskript.

EDIT: diese Frage könnte auch Interessantes für dich enthalten:

http://www.administrator.de/forum/psexec-cmd-per-bat-ausf%C3%BChren-219 ...


Mit freundlichen Grüßen
Bitte warten ..
Mitglied: DerWoWusste
14.10.2013 um 13:29 Uhr
Hi.

Die Deinstallation von 2003 entweder per MSIexec /x ProductID oder per GPO (falls es per GPO ausgerollt wurde). Die Installation von O2010: siehe http://wpkg.org/MS_Office_2010
Bitte warten ..
Mitglied: HarryK
14.10.2013 um 14:18 Uhr
Danke Rudbert für deine Antwort.

So ein Client-Management-System wird zwar irgendwann eine Rolle spielen, steht aber im Moment noch nicht zur Debatte;).

Ich schau mir die Funktionsweise zur Deinstallation mithilfe von MSIExec genauer an - hört sich aber simpel an. Den wiki Artikel lese ich mir auch noch durch.

Danke @derwowusste.

Gruß

Harry
Bitte warten ..
Mitglied: HarryK
14.10.2013, aktualisiert um 15:31 Uhr
Die Deinstallation von Office2003 funktioniert mithilfe des Befehls "msiexec.exe /x {90110407-6000-11D3-8CFE-0150048383C9}" ganz gut, was mach ich jedoch wenn der User keine administrativen Rechte besitzt? Wie kann ich das in das Script mit einbauen ohne dass das Passwort eines Admin-Users im klartext angezeigt wird?

Gruß

Harry
Bitte warten ..
Mitglied: Mantigul
14.10.2013 um 15:35 Uhr
Kann baramundi auch nur empfehlen. schau es dir an. Einfach, nicht allzu teuer und hat extrem viele Vorteile!
Bitte warten ..
Mitglied: DerWoWusste
14.10.2013 um 17:00 Uhr
Wie kann ich das in das Script mit einbauen ohne dass das Passwort eines Admin-Users im klartext angezeigt wird?
Man nimmt dazu ein Startskript, das arbeitet nämlich per se schon mit höchsten Rechten und braucht kein Kennwort.
Bitte warten ..
Mitglied: HarryK
19.11.2013 um 11:50 Uhr
Hallo nochmal,

also am Ende dieser Woche wird die Installation von Office2010 auf den Clients stattfinden. Ich habe jetzt beschlossen das ganze manuell durchzuführen und eben zu allen Geräten zu laufen. Per GPO oder Login-Script ist mir zu riskant, da ich auch schon schlechte Erfahrungen darüber gelesen habe.
Ich würde trotzdem gerne ein Script ausführen dass für mich folgendes erledigt:
- deinstallation Kompatibilitätspack
- deinstallation Office 2003
- löschen des Verzeichnisses (bzw. den Inhalt) C:\Program Files\Microsoft Office

Ist es möglich ein Script zu basteln, dass folgende Befehle nacheinander abarbeitet?

MsiExec.exe /X{90120000-0020-0407-0000-0000000FF1CE} --> Deinstallation Comp Pack
MsiExec.exe /X{90110407-6000-11D3-8CFE-0150048383C9} --> Deinstallation Office 2003
del C:\Program Files\Microsoft Office\*.* /s /q
del C:\Program Files (x86)\Microsoft Office\*.* /s /q

Danke schonmal.

Gruß Harry
Bitte warten ..
Mitglied: DerWoWusste
19.11.2013, aktualisiert um 11:57 Uhr
Moin.

Wie Du meinst, ich hätte es auf jeden Fall automatisiert.
Klar geht es mit Deinen Zeilen, statt del nimm aber rd "C:\Program Files\Microsoft Office" /s /q
Du solltest unbedingt auch noch zwei Dinge sicherstellen:
1. das SP2 in den Ordner "Updates" extrahieren, damit es gleich mit installiert wird. Das Directory des Ordners wäre dann so:
accessde-de-de.msp
accessde-de-de.xml
clientshared64mui-de-de.msp
clientshared64mui-de-de.xml
clientshared64ww-x-none.msp
clientshared64ww-x-none.xml
clientsharedmui-de-de.msp
clientsharedmui-de-de.xml
imeww-x-none.msp
imeww-x-none.xml
officesuitemui-de-de.msp
officesuitemui-de-de.xml
officesuiteww-x-none.msp
officesuiteww-x-none.xml
osamui-de-de.msp
osamui-de-de.xml
proof-ar-sa.msp
...

2. Unbedingt dafür zu sorgen, dass sämtliche Office-Viewer vorher deinstalliert werden (auch Visio-Viewer!), sonst wirst Du erhebliche Probleme bei Installationen von Servicepacks bekommen. Nachträglich kann man diese, falls noch benötigt, wieder installieren.
Bitte warten ..
Mitglied: HarryK
19.11.2013 um 12:01 Uhr
Hey DerWoWusste,

du bist aber fix. Danke für deine schnelle Antwort.

Das mit dem Servicepack schaue ich mir gleich nach Mittag an und das mit den Viewern werde ich auch noch überprüfen.;)

Ich gebe dann nochmal bescheid!
Bitte warten ..
Mitglied: HarryK
19.11.2013, aktualisiert um 15:06 Uhr
So, Ich habe das Deinstallationsscript erweitert, sodass auch die installierten Viewer deinstalliert werden.

Im Moment sieht es so aus:

rem Deinstallation Kompatibilitätspack
MsiExec.exe /X{90120000-0020-0407-0000-0000000FF1CE} /passive

rem Deinstallation MS Office 2003
MsiExec.exe /X{90110407-6000-11D3-8CFE-0150048383C9} /passive

rem Deinstallation MS Excel Viewer
MsiExec.exe /X{95120000-003F-0407-0000-0000000FF1CE} /passive

rem Deinstallation MS Visio Viwer2003
MsiExec.exe /X{90520407-6000-11D3-8CFE-0150048383C9} /passive

rem Deinstallation Office Validation File In
MsiExec.exe /X{90140000-2005-0000-0000-0000000FF1CE} /passive

rd "C:\Program Files\Microsoft Office" /s /q
rd "C:\Program Files (x86)\Microsoft Office" /s /q
rd "C:\programme\Microsoft Office" /s /q

Ich glaube das haut schonmal ganz gut hin. Jetzt mach ich mich dann an die Erstellung des Installationssetups bei dem auch das SP2 schon integriert ist.
Bitte warten ..
Mitglied: HarryK
20.11.2013 um 14:40 Uhr
Nachdem ich jetzt das Installationspaket für Office 2010 mit integrierten Servicepacks erstellt habe, ist mir aufgefallen dass sich durch das Servicepack auch der Sharepoint Workspace mitinstalliert (bzw. wieder aktiviert wird), obwohl ich diese Option im Installationssetup deaktiviert habe.
Muss ich das Servicepack jetzt weg lassen oder gibts eine andere (einfache) Möglichkeit?

Danke
Bitte warten ..
Mitglied: DerWoWusste
20.11.2013 um 15:02 Uhr
Hi.

Bin mir sicher, dass der nicht durch das SP installiert wird... aber nur "sicher", nicht todsicher". Kann es einen anderen Grund haben?
Bitte warten ..
Mitglied: HarryK
20.11.2013 um 15:12 Uhr
Servus DerWoWusste,

ich bin gerade noch bei der Überprüfung wo das Ding herkommt... Es nervt nämlich, dass im Explorer ein Button mit "Ordnersynchronisierung" hinzugekommen ist.
Bitte warten ..
Mitglied: DerWoWusste
20.11.2013 um 15:35 Uhr
Habe O2010, habe SP2, habe keinen solchen Button. Wo soll der sein?
Bitte warten ..
Mitglied: HarryK
20.11.2013, aktualisiert um 15:44 Uhr
Im Windows Explorer unter der Menüleiste. Neben den Standardschaltflächen wie z.B.: Suchen, Ordner etc. da ist ein Button mit "Ordnersynchronisation".
Deinstallier ich das Office wieder, ist der Button auch wieder weg...
Bei meinem Test-Client handelt es sich noch um einen Windows XP x64 Client, falls das weiterhilft.
Bitte warten ..
Mitglied: DerWoWusste
20.11.2013 um 15:59 Uhr
Habe ich nicht. Kommt nicht durch's SP. Denn bei mir ist sogar die "Unterstützung für MS SharePoint Foundation" mit installiert, dennoch ist der Button nicht vorhanden.
Bitte warten ..
Mitglied: HarryK
21.11.2013, aktualisiert um 10:30 Uhr
Guten Morgen,

Ich habe dazu einen Artikel gefunden:

http://social.technet.microsoft.com/Forums/office/de-DE/685b730d-33ce-4 ...

Scheint so als würde das am SP1 liegen?

EDIT:

Hmm, das gleiche Setup an einem Windows 7 Client installiert den "Button" nicht mit...
Vielleich ist es ein bereits installiertes Windows Update? Ich bin noch am Suchen.
Bitte warten ..
Mitglied: HarryK
21.11.2013 um 12:37 Uhr
Also, Ich habe ein bereits vorhandenes Setup von uns verwendet, und nach der Installation von diesem habe ich den betroffenen Button nicht.

Der einzige Unterschied zwischen den beiden Paketen ist, dass ich bei dem von mir erstellten Setups, unter "Tools" die Unterstützung für Microsoft Sharepoint Foundation deaktiviert habe, und beim vorhandenen Setup die Option aktiviert war.

Ich versteh's zwar nicht, aber hauptsache es funktioniert einmal;).

Danke an alle für die Hilfe.
Bitte warten ..
Mitglied: HarryK
25.11.2013, aktualisiert um 11:56 Uhr
Hallo Zusammen,

nachdem ich am Wochenende die Installation von Office2010 vorgenommen habe treten bei einigen jetzt folgende Probleme/Fehler auf:

1. Client (WinXp 64bit)
Excel und Word funltionieren einwandfrei, beim Start von Outlook kommt immer die Meldung:
Warten sie während microsoft office 2010 von windows konfiguriert wird --> starten Sie den PC erneut... Nach dem Neustart kommt die Meldung wieder usw.
Ich habe bereits Office neu installiert sowie das Outlook Profil des Users gelöscht und neu erstellt - gleiche Fehlermeldung
Im Abgesicherten Modus kann ich Outlook starten

2. (betrifft mehrere Clients Windows7 sowie XP)
gespeicherte Schnellbausteine die in Outlook verwendet wurden, sind nicht mehr auffindbar. Ich habe bereits herausgefunden dass diese Schnellbausteine in einem Word-Dokument vorhanden sind. In Outlook werden diese aber nicht angezeigt.

3. Client (Windows7 64 bit)
Es werden teilweise Meldungen mit "Erkennung interaktiver Dienst" angezeigt. Welche Auswirkungen das hat, kann ich noch nicht sagen.

4. Client allgemein
Suchfunktion in Outlook durchsucht keine Anhänge mehr? Konkretes Beispiel:
User durchsucht das gesendete Objekte Postfach nach einem bestimmten Dateinamen. Die Email bei der der betroffene Anhang dabei ist, wird aber nicht gefunden.

Ich hoffe ihr könnt mir weiterhelfen!

Danke
Bitte warten ..
Mitglied: DerWoWusste
25.11.2013, aktualisiert um 18:25 Uhr
Hi.

Leider trat bei unserer Migration keiner der genannten Effekte auf.
Bitte warten ..
Mitglied: HarryK
28.11.2013 um 07:41 Uhr
So, für alle die es interessiert:

zu 1.
Nach der Installation von Windows Search KB940157 konnte Outlook ganz normal gestartet werden (Hat bei drei Clients funktioniert) - Muss ich nicht verstehen?

zu.2.
Die Speicherbausteine in Outlook werden ab Office 2010 in einer NormalEmail.dot gespeichert. Da diese Datei in den vorherigen Versionen noch nix existiert greift Outlook auf die neu erstellte NormalEmail.dot zu, bei der natürlich noch keine Einträge vorhanden sind.

zu 3.
Ich habe den Dienst "Erkennung interaktiver Dienste" einfach deaktiviert. Wird scheinbar nur selten gebraucht und konnte keine Probleme feststellen.

zu 4.
Das Problem saß mal wieder vorm PC ;). Wählt man "Alle Email Elemente durchsuchen" wird auch das gefunden was gesucht wird.

Vielleicht hilft es ja dem ein oder anderen weiter.

Gruß

Harry
Bitte warten ..
Mitglied: DerWoWusste
28.11.2013 um 10:16 Uhr
Ich habe den Dienst "Erkennung interaktiver Dienste" einfach deaktiviert. Wird scheinbar nur selten gebraucht und konnte keine Probleme feststellen.
Du weißt gar nicht, wofür der ist, deaktivierst ihn aber? Klick doch mal auf die Meldung, bestätige die Abfragen des interaktiven Dienstes einmal, vielleicht hat es sich damit schon erledigt. Den Dienst nicht deaktivieren.
Bitte warten ..
Mitglied: HarryK
28.11.2013 um 10:39 Uhr
Ich weiss aber dass der Dienst von keiner Anwendung, die wir benutzen, zwingend gebraucht wird... Sollte es einmal Probleme damit geben kann man ihr immer noch aktivieren - sehe da kein Problem darin.

Die Meldung kam scheinbar im Zusammenhang mit den Netzwerkdruckern, da ich irgendetwas mit "spool" herauslesen konnte.
Bitte warten ..
Mitglied: DerWoWusste
28.11.2013 um 10:53 Uhr
Das Problem ist, dass Du ohne diesen Dienst nicht mitbekommst, wenn Dir ein Programm in einer anderen Session etwas mitteilen will. Du wirst also auch nie merken, dass der Dienst gebraucht wird ;-(

Meiner Ansicht nach ist diese Einstellung untragbar.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
Office 2013 - Exchange 2010 - Probleme mit Anhängen (3)

Frage von Coscos zum Thema Exchange Server ...

Windows Server
gelöst Gruppenrichtlinien-Vorlage Office 2013 auf einem DC 2003 (5)

Frage von bluepython zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...