Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

BATCH Skript Problem mit IF-Abfrage

Frage Entwicklung Batch & Shell

Mitglied: 93983

93983 (Level 1)

25.09.2010, aktualisiert 10:34 Uhr, 4077 Aufrufe, 2 Kommentare

Hallo !

Ich schreibe zur Zeit ein größeres Skript für die Steuerung einer Backupanwendung und Windows Server 2003 R2 bzw. 2008. Das funktioniert soweit auch alles. Für die Rückgabe von verschiedenen Errorleveln wollte ich verschiedene Variablen nutzen. Es gab jedoch immer Fehler bzw. es wurde ein falscher Wert angenommen. Für die Fehleranalyse habe ich das einmal zerlegt:

... und festgestellt, dass bereits das folgende Skript nicht nach meinem Wunsch funktioniert:

set testvar=0
if testvar == 0 (
echo WAHR
) else (
echo FALSCH)

Das Ergebnis ist immer FALSCH. Und genau, dass ist mein Problem. Ich verstehe einfach nicht warum ! Ich habe schon diverses ausprobiert, aber irgendwo scheint sich eine Denkblockade bei mir eingeschlichen zu haben. Ich hoffe, dass jemand von Euch mir auf die Sprünge helfen kann.

Gruß

Dennis
Mitglied: em-pie
25.09.2010 um 10:49 Uhr
Hi,

Probier mal

01.
 @echo off 
02.
set testvar=0 
03.
if %testvar% == 0 ( 
04.
echo WAHR 
05.
) else ( 
06.
echo FALSCH) 
07.
 
08.
Pause
Wenn du mit Variablen arbeiten willst (statt die Werte zu setzen) musst du die Variable in "%" setzen ;)
Bitte warten ..
Mitglied: 93983
25.09.2010 um 10:55 Uhr
Super! Vielen Dank für deine Hilfe. Manchmal sieht man den Wald vor lauter Bäumen nicht !

Gruß

Dennis
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Powershell IF Abfrage Vergleichsoperatoren (4)

Frage von Peterz zum Thema Batch & Shell ...

C und C++
gelöst IF Abfrage funktioniert nicht mehr (2)

Frage von pablovic zum Thema C und C ...

Batch & Shell
Wo ist der Fehler in diesem Batch Skript? (11)

Frage von gabrixl zum Thema Batch & Shell ...

Windows 7
gelöst Batch-Skript oder VBS Skript zum Sichern von Office Vorlagen (2)

Frage von Ceejaay zum Thema Windows 7 ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...

Entwicklung
gelöst Tipp für Anfänger- Wie würdet ihr automatischen Mailversand umsetzen? (12)

Frage von Cloudyme zum Thema Entwicklung ...