Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

BATCH Skript Problem mit IF-Abfrage

Frage Entwicklung Batch & Shell

Mitglied: 93983

93983 (Level 1)

25.09.2010, aktualisiert 10:34 Uhr, 4071 Aufrufe, 2 Kommentare

Hallo !

Ich schreibe zur Zeit ein größeres Skript für die Steuerung einer Backupanwendung und Windows Server 2003 R2 bzw. 2008. Das funktioniert soweit auch alles. Für die Rückgabe von verschiedenen Errorleveln wollte ich verschiedene Variablen nutzen. Es gab jedoch immer Fehler bzw. es wurde ein falscher Wert angenommen. Für die Fehleranalyse habe ich das einmal zerlegt:

... und festgestellt, dass bereits das folgende Skript nicht nach meinem Wunsch funktioniert:

set testvar=0
if testvar == 0 (
echo WAHR
) else (
echo FALSCH)

Das Ergebnis ist immer FALSCH. Und genau, dass ist mein Problem. Ich verstehe einfach nicht warum ! Ich habe schon diverses ausprobiert, aber irgendwo scheint sich eine Denkblockade bei mir eingeschlichen zu haben. Ich hoffe, dass jemand von Euch mir auf die Sprünge helfen kann.

Gruß

Dennis
Mitglied: em-pie
25.09.2010 um 10:49 Uhr
Hi,

Probier mal

01.
 @echo off 
02.
set testvar=0 
03.
if %testvar% == 0 ( 
04.
echo WAHR 
05.
) else ( 
06.
echo FALSCH) 
07.
 
08.
Pause
Wenn du mit Variablen arbeiten willst (statt die Werte zu setzen) musst du die Variable in "%" setzen ;)
Bitte warten ..
Mitglied: 93983
25.09.2010 um 10:55 Uhr
Super! Vielen Dank für deine Hilfe. Manchmal sieht man den Wald vor lauter Bäumen nicht !

Gruß

Dennis
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (50)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...