Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bekomme auth-user-pass-verify mit OpenVPN nicht zum laufen

Frage Netzwerke LAN, WAN, Wireless

Mitglied: bigzorro

bigzorro (Level 1) - Jetzt verbinden

17.12.2013, aktualisiert 20.12.2013, 1742 Aufrufe, 1 Kommentar

Hallo Kollegen,

bin in Linux neu, daher seht es mir bitte nach falls ich was evtl. selbstverständliches übersehen haben sollte.

Folgendes Problem:

Ich habe zwischen einem PC (virtuelles XP) und einem Raspberry Pi über das Internet mit OpenVPN über TCP/443 eine Verbindung bekommen, das Einwählen klappt soweit wie gewünscht.

Nun möchte ich dass vor dem Verbinden Benutzername und Passwort abgefragt werden, was am Client mit dem Eintrag "auth-user-pass" in der *.ovpn ja auch einfach zu bewerkstelligen ist, von Clientseite also abgehakt.

Nun fehlt mir noch die richtige Config auf Serverseite.

Hier zunächst mal die ohne Passwortabfrage funktionierende openvpn.conf :

01.
dev tun 
02.
proto tcp 
03.
port 443 
04.
ca /etc/openvpn/easy-rsa/keys/ca.crt 
05.
cert /etc/openvpn/easy-rsa/keys/server.crt 
06.
key /etc/openvpn/easy-rsa/keys/server.key 
07.
dh /etc/openvpn/easy-rsa/keys/dh1024.pem 
08.
user nobody 
09.
group nogroup 
10.
server 10.8.0.0 255.255.255.0 
11.
persist-key 
12.
persist-tun 
13.
status /var/log/openvpn-status.log 
14.
verb 3 
15.
client-to-client 
16.
push "redirect-gateway def1" 
17.
#set the dns servers 
18.
push "dhcp-option DNS 8.8.8.8" 
19.
push "dhcp-option DNS 8.8.4.4" 
20.
log-append /var/log/openvpn 
21.
comp-lzo 
22.
duplicate-cn 
23.
keepalive 10 120
Nun hatte ich folgendes bereits ausprobiert:

01.
auth-user-pass-verify /etc/openvpn/auth.sh via-env 
Die Datei auth.sh sah dann so aus:

01.
#!/bin/sh 
02.
ALLOWED_USER="meinUsername" 
03.
ALLOWED_PASS="meinPasswort" 
04.
 
05.
if [ '$username' == '$ALLOWED_USER' ] && [ '$password' == '$ALLOWED_PASS' ] 
06.
 then exit 0 
07.
fi 
08.
 
09.
exit 1
Hab dann auch noch scriptsecuritylevel 2 & 3 eingetragen und getestet, bin aber dauernd auf Authentizierungsfehler gestoßen.

Der OpenVPN Dämon wurde jedesmal korrekt neu gestartet.

Sobald ich ohne diese Einträge arbeite baut sich die Verbindung wieder korrekt auf.

Habe ich noch was vergessen oder nicht beachtet?

Danke für hilfreiche Tipps.

Falls noch Angaben benötigt werden, gern.

Danke, Gruß, big
Mitglied: bigzorro
20.12.2013 um 09:03 Uhr
Habs mal von Linux nach Netzwerk verschoben, evtl. weiß ja doch jemand nen Ansatz?!
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
gelöst OpenVPN Verbindung funktioniert. LAN dahinter ist nicht erreichbar (5)

Frage von istike2 zum Thema Netzwerkmanagement ...

Router & Routing
VPN Verbindung via OpenWRT OpenVPN Client nicht möglich (4)

Frage von bfschmlan zum Thema Router & Routing ...

Virtualisierung
Bekomme W10-VHD(x) erstellt mit Disk2vhd nicht zum Laufen (24)

Frage von brutzler zum Thema Virtualisierung ...

Router & Routing
gelöst OpenVPN Zertifikat abgelaufen - Verbindung nicht möglich (31)

Frage von intane zum Thema Router & Routing ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (31)

Frage von McLion zum Thema Router & Routing ...

Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail (24)

Frage von ahstax zum Thema Visual Studio ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Windows Netzwerk
Netzwerk Neustrukturierung (15)

Frage von IT-Dreamer zum Thema Windows Netzwerk ...