Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bzgl WDS und WIM Dateien

Frage Entwicklung Installation

Mitglied: Wiskat

Wiskat (Level 1) - Jetzt verbinden

10.02.2010 um 11:07 Uhr, 13186 Aufrufe, 9 Kommentare

Ich sitze gerade an meinem Zwischenprojekt für die Ausbildung zum FiSi.
Mein Projekt ist die automatische Imageverteilung über einen Win Server 08 mit Hilfe von WDS!
Server ist installiert, Domäne, DHCP und DNS Server habe ich installiert und konfiguriert.

Allerdings ist mir noch nicht ganz genau klar, wie das mit den *.wim Abbildern funktioniert!
Ich hoffe er könnt mir dabei helfen. Google hilft mir nicht so wirklich weiter...

Als Beispiel habe ich ein Win7.iso Image. Wenn ich nun mit einem Virtuellen Laufwerk auf die Dateien zugreife finde ich unter "Source" die Dateien "boot.wim" und "install.wim". Boot.wim habe ich nun bei Startabbild hinzugefügt, soweit bin ich!

Kann ich die "install.wim" für das Installationsabbild verwenden? Oder wofür wird die gebraucht? Oder muss ich mit Hilfe von XImage erst ein *.wim Image eines Systems erstellen, dass ich dann einbinden kann?

Die Notwendigkeit von WAIK und VLite ist mir in diesem Zusammenhang auch noch nicht bewusst.

Für schnelle Antworten wäre ich dankbar

Danke !!!
Mitglied: KaiserFranz
10.02.2010 um 11:48 Uhr
Mahlzeit,

die "install.wim" ist ein Image womit du eine Basisinstallation von Windows 7 installieren kannst (gleiche Installation wie mit CD). Das heißt, dass du die "install.wim" als Installationsabbild verwenden kannst. Jegliche Anpassungen musst du später aber entweder händisch oder bei der Installation mit einer Antwortdatei machen.

Mit ImageX kannst du eine .wim-Datei von einem Referenzcomputer erstellen (vorher mit Sysprep vorbereiten!). Alternativ gibt es auch die Möglichkeit von der Basis "install.wim" ein Aufzeichnungsabbild zu erstellen, dieses Abbild zu den Startabbilder zu packen, den Referenzcomputer mit Sysprep vorzubereiten und per PXE-boot das Aufzeichnungsabbild zu starten. Der Rest ist selbsterklärend und per GUI zu erstellen.
Mit dieser Alternative brauchst du dir keine WinPE-CD mit ImageX zu erstellen.

Hier nochmal ein paar Links wo eigentlich alles geklärt ist:

http://www.winpage.info/pages/Vista/unattend.php

http://wiki.winboard.org/index.php/Windows_7_verteilen

Das WAIK stellt dir die Bereitstellungskonsole sowie den System Image Manager (für die Erstellung der XML-Dateien zur automatischen Installation) zur Verfügung.

Gruß
KaiserFranz
Bitte warten ..
Mitglied: Wiskat
11.02.2010 um 13:39 Uhr
Ah super!

Danke für die schnelle Hilfe

Habe jetzt aber bereits eine neue Frage!
Ich bin jetzt soweit, dass der Client mein Win7 Image vom Server installieren möchte. Allerdings habe ich grooße Probleme beim erstellen der XML Datei über WAIK.

Ich erstelle ohne Probleme !eine! XML Datei nach der Anleitung verschiedener Seiten. In der ich dann die Sprache auf Deutsch stelle und weitere Einstellungen vornehme.
Diese XML Datei füge ich in den Eigenschaften des Servers unter "Bereitstellungsdienste" -> "Servername" -> "Win7" hinzu.
Und unter "Installionsabbilder" in den Eigenschaften meines Abbilds "Win7".
Bei beiden existieren ja die Eigenschaftspunkte "Datei für die unbeaufsichtigte Installation".
Wenn ich nun meinen Client installieren möchte, startet die Installation normal, aber er geht nicht automatisch vor. Ich muss nach wie vor auf "Weiter" o.ä. klicken.

Meine Frage nun:
Welche Angaben innerhalb der XML Datei ist bei der Win7 Installation zwingend notwendig? (z.B. Sprache, Partitionen etc.)
Eventuell habt ihr auch einen einfacheren Vorschlag für mich?

Ich hoffe ihr könnt mir noch folgen und mir eventuell wieder so schnell helfen!

Dankeschön
Bitte warten ..
Mitglied: KaiserFranz
11.02.2010 um 17:27 Uhr
Also ich habe die XML-Datei nur dem Installationsabbild hinzugefügt. Allerdings hatte ich das gleiche Problem wie du. Trotz allen Einstellungen hat er trotzdem mein Eingreifen verlangt (Benutzer, Netzwerk, PC-Name, etc.).

Vielleicht kann uns beiden ja einer helfen?!?!

So ganz warm werd ich mit dem WDS in Verbindung mit Windows 7 noch nicht. Mit XP-Images lief alles einwandfrei. Sysprep, Image erstellen und auf den neuen Rechner installieren. Fertig.
Bei Windows 7 deinstalliert er mir auch jedesmal den Grafikkartentreiber sowie wird die Auflösung auf 800 x 600 zurück gestellt.

Muss das WAIK für Windows 7 unbedingt auf einen Server 2008 laufen (betreibe es zurzeit auf einen Windows 2K3)?

Gruß
KaiserFranz
Bitte warten ..
Mitglied: Wiskat
11.02.2010 um 18:39 Uhr
Ich vermute genau da liegt das Problem! Mit dem Windows Server 2008 R2, wäre es vielleicht kein Problem mehr.
Leider habe ich nur die R1 Version die mit Vista zusammen erschienen ist.

Eventuell hat jemand anders hier ja noch andere Erfahrungsberichte?
Bitte warten ..
Mitglied: frettchen
19.02.2010 um 12:30 Uhr
hallo,

ich habe schon das Problem, wenn ich eine *.wim Datei in Windows (sim) lade. Bei mir tritt folgender Fehler auf: Beim Generieren einer Katalogdatei für Abbild vista (x86) in der wim-datei C:... ist ein Fehler aufgetreten. Kann mir jem. weiterhelfen?
Bitte warten ..
Mitglied: KaiserFranz
19.02.2010 um 14:10 Uhr
Mahlzeit,

@ frettchen

Ich hatte lange Zeit auch das Problem, dass er keine Katalogdatei erstellen konnte. Das SIM war auf einem W2k3 Server installiert (auf dem gleichen Server liefen auch die Bereitstellungsdienste).

Als ich den SIM auf meinen Client (XP Pro SP3) instaliert habe konnte ich eine Katalog- und die anschließende Antwortdatei problemlos erstellen. Warum? das wüsste ich auch gerne. Ich habe lange gesucht aber konnte nicht herausfinden, warum er es auf dem Client aber nicht auf dem Server erstellen konnte.

Schönes WE!

Gruß
KaiserFranz
Bitte warten ..
Mitglied: frettchen
19.02.2010 um 14:34 Uhr
ich nutze den win 2k8 r2 x64 Server und als Client win 7 x64 und es klappt auf beiden nicht. Ich habe es auch schon auf nem win xp x86 versucht, da es eine x86 wim datei ist, Klappt auch nicht! Aber die Installation über den WDS funktioniert, nur ich kann keine Antwortdatei (.xml) erstellen.

INFO: Es handelt sich um eine Win vista boot x86 .wim datei. habe ich iwo einen fehler gemacht?
Bitte warten ..
Mitglied: flachzange83
27.04.2010 um 11:09 Uhr
Möchte hier auch mal meine Erfahrungen preisgeben:

Habe viele Erfahrungen über Imaging per imagex gesammelt und bin gerade am testen mit nem WinSRV2008R2 und WDS.

Bzgl. der *.xml-Datei. Möchte man Win7 zB unattend installieren, erstellt man sich mittels WAIK eine autounattend.xml und kopiert diese auf einen USB-Stick. Damit will ich sagen, dass die Datei unbedingt autounattend.xml heißen muss. Ob der WDS genau diese Namenskonvention braucht, weiß ich nicht. Könnte aber sein.
Habe ne unattend.xml (name bei sysprep ist egal) immer mittels sysprep eingesetzt und nie damit Probleme gehabt.

Auf folgende Probleme bin ich beim Imagen mittels imagex gestoßen:

1. Ohne Abschalten des Dienstes "Windows Media Player Netzwerkfreigabedienst" über msconfig konnte ich das Image nie zurückspielen. Bekam immer einer Fehlermeldung. Nach Deaktivierung ging es dann.

2. Je nach Installation von Win7 (entweder auf nur einer Partition oder aber auf 2). Win7 erstellt bei der Standardinstallation automatisch eine 100mb Systempartition die im Explorer unsichtbar ist. Diese benötigt Win7 für Bitlocker. Hat man nun also Win7 genau so installiert, erstellt dann ein Image von seinem C:\ und spielt das zurück, dann bekommt man beim starten auch eine Fehlermeldung. Die weißt zwar nicht darauf hin, dass ihm die "unsichtbare" Systempartition fehlt, aber es liegt genau daran. In diesem Fall muss man also beide Partitionen imagen, diskpart einsetzen und dann beide zurückspielen.


Hier mal ein Auszug aus meiner Anleitung:

=> Image capturen
o \Imagex.exe /compress fast /capture C: C:\MyimageC.wim "my Vista Install" /verify
o \Imagex.exe /compress fast /capture D: C:\MyimageD.wim "my Vista Install" /verify

=> Image verteilen
o diskpart
o select disk 0
o clean
o create partition primary size=100
o select partition 1
o active
o format fs=ntfs quick
o assign letter=c
o create partition primary
o select partition 2
o format fs=ntfs quick
o assign letter=d
o exit

Image.exe /apply c:\myimageC.wim 1 c:
Image.exe /apply c:\myimageD.wim 1 d:



Hoffe ich konnte evtl. etwas helfen oder eben einfach nur den Horizont erweitern
Bitte warten ..
Mitglied: Cinema4d
07.09.2010 um 19:45 Uhr
Hallo Flachzange
Ich habe mir ein image Abbild mit gimagex erstellt und möchte dieses jetzt mit einer bootfähigen (offline ohne WDS ) DVD auf einen Rechner zurückspielen, allerdings hätte ich gerne ein automatisches Script was dieses erledigt.

Kann ich das Textfile ab >image verteilen
Irgendwie als Autorun script in der bootfähigen DVD verwenden ?
Meine Hoffnung ist: DVD einlegen >Booten von DVD unddas diskpart und imagex Script läuft ab und nach ca.20min fertig!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
WIM Images anpassen für WDS Server (5)

Frage von IT-Biene zum Thema Windows Server ...

Windows Server
gelöst WDS Aufzeichnungsabbild - Wim-Image (3)

Frage von rheingauner zum Thema Windows Server ...

Batch & Shell
Dateien mit vorgegebener Größe erstellbar? (2)

Frage von Stefan007 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...