Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco 1700 Router VLan-Routing-Konfiguration

Frage Netzwerke Router & Routing

Mitglied: crisan

crisan (Level 1) - Jetzt verbinden

11.04.2011, aktualisiert 20:04 Uhr, 4947 Aufrufe, 2 Kommentare

Moin,

ich habe ein Problem bei der Routerkonfiguration.

Ich habe vor 2 Subnetze auf einem Cisco 1700 Router mit einander zu verbinden.

Subnetz 1 10.1.2.0 255.255.255.252
Subnetz 2 10.1.3.0 255.255.255.0

Dazu haben ich 2 Vlans erstellt.

Meine Konfig schaut bis her so aus:
Router>enable
Router#vlan database

Router(vlan)#
Router(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
Router(vlan)#vlan 3
VLAN 3 added:
Name: VLAN0003
Router(vlan)#exit
APPLY completed.
Exiting....
Router#configure terminal
Router(config)#interface vlan 2
%LINK-5-CHANGED: Interface Vlan2, changed state to up
Router(config-if)#ip address 10.1.2.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface vlan 3
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Router(config-if)#ip address 10.1.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 1
Router(config-if)#switchport access vlan 2
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 2
Router(config-if)#switchport access vlan 3
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 10.1.2.0 255.255.255.252 fastEthernet 2
Router(config)#ip route 10.1.3.0 255.255.255.0 fastEthernet 1
Router(config)#end

Wenn ich jetzt mit show ip route nach den routen gucke, übernimmt er die routen einfach nicht.
Anscheinend fehlt da ein default gateway, das steht zumindestens immer nach der show ip route abfrage.
Ich hatte es auch schon mit "ip classless" probiert, hat aber nichts gebracht.

Weiß da jemand eine Lösung?
Mitglied: dog
11.04.2011 um 20:49 Uhr
Router(config)#ip route 10.1.2.0 255.255.255.252 fastEthernet 2
Router(config)#ip route 10.1.3.0 255.255.255.0 fastEthernet 1

Das kannst du gleich mal streichen.
Der Router sitzt in beiden Subnetzen drin und braucht keine Routen dahin.

ip classless

Das gehört immer in die Router-Konfiguration.

Wenn du jeweils die IPs des Routers bei den Clients einträgst sollten die schon kommunizieren können.
Bitte warten ..
Mitglied: crisan
11.04.2011 um 21:09 Uhr
ah okay,

schon mal vielen Dank. Werde das morgen gleich mal testen.

EDIT:

Also ich habe die Konfiguration jetzt einmal so gelassen und die Clients an die Ports angeschlossen. Ich Kann jetzt mit dem ping befehlt den jeweiligen Port des eigenen und des anderen clients anpingen. Den anderen Client erreiche ich aber nicht. hat das evtl. mit den Vlan-Tags zu tun?

Client 1
ip 10.1.3.2
sub 255.255.255.0
GW 10.1.3.1

Client 2
10.1.2.2
255.255.255.252
GW 10.1.2.1
Bitte warten ..
Ähnliche Inhalte
Netzwerke
gelöst Switch Cisco SG550XG und 2960X L3 und L2 VLAN Routing Problem (6)

Frage von Jimmysozinho zum Thema Netzwerke ...

Netzwerkgrundlagen
gelöst VLAN routing - mit oder ohne NAT? (6)

Frage von Alex29 zum Thema Netzwerkgrundlagen ...

UMTS, EDGE & GPRS
gelöst Benötige LTE Router der Routing unterstützt (22)

Frage von semper zum Thema UMTS, EDGE & GPRS ...

Router & Routing
gelöst HP2920 Inter VLAN Routing (7)

Frage von westberliner zum Thema Router & Routing ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Webbrowser
Windows 7 unbeliebte Internetseite sperren (13)

Frage von Daoudi1973 zum Thema Webbrowser ...

ISDN & Analoganschlüsse
gelöst Splitter - RJ45 zu RJ11? (13)

Frage von Waishon zum Thema ISDN & Analoganschlüsse ...

LAN, WAN, Wireless
gelöst Suche Firmware Image für Cisco Aironet 1252 (10)

Frage von Herbrich19 zum Thema LAN, WAN, Wireless ...

Webbrowser
Internet Explorer schliesst direkt bei Start (10)

Frage von gabeBU zum Thema Webbrowser ...