Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco 1700 Router VLan-Routing-Konfiguration

Frage Netzwerke Router & Routing

Mitglied: crisan

crisan (Level 1) - Jetzt verbinden

11.04.2011, aktualisiert 20:04 Uhr, 4966 Aufrufe, 2 Kommentare

Moin,

ich habe ein Problem bei der Routerkonfiguration.

Ich habe vor 2 Subnetze auf einem Cisco 1700 Router mit einander zu verbinden.

Subnetz 1 10.1.2.0 255.255.255.252
Subnetz 2 10.1.3.0 255.255.255.0

Dazu haben ich 2 Vlans erstellt.

Meine Konfig schaut bis her so aus:
Router>enable
Router#vlan database

Router(vlan)#
Router(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
Router(vlan)#vlan 3
VLAN 3 added:
Name: VLAN0003
Router(vlan)#exit
APPLY completed.
Exiting....
Router#configure terminal
Router(config)#interface vlan 2
%LINK-5-CHANGED: Interface Vlan2, changed state to up
Router(config-if)#ip address 10.1.2.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface vlan 3
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Router(config-if)#ip address 10.1.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 1
Router(config-if)#switchport access vlan 2
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 2
Router(config-if)#switchport access vlan 3
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 10.1.2.0 255.255.255.252 fastEthernet 2
Router(config)#ip route 10.1.3.0 255.255.255.0 fastEthernet 1
Router(config)#end

Wenn ich jetzt mit show ip route nach den routen gucke, übernimmt er die routen einfach nicht.
Anscheinend fehlt da ein default gateway, das steht zumindestens immer nach der show ip route abfrage.
Ich hatte es auch schon mit "ip classless" probiert, hat aber nichts gebracht.

Weiß da jemand eine Lösung?
Mitglied: dog
11.04.2011 um 20:49 Uhr
Router(config)#ip route 10.1.2.0 255.255.255.252 fastEthernet 2
Router(config)#ip route 10.1.3.0 255.255.255.0 fastEthernet 1

Das kannst du gleich mal streichen.
Der Router sitzt in beiden Subnetzen drin und braucht keine Routen dahin.

ip classless

Das gehört immer in die Router-Konfiguration.

Wenn du jeweils die IPs des Routers bei den Clients einträgst sollten die schon kommunizieren können.
Bitte warten ..
Mitglied: crisan
11.04.2011 um 21:09 Uhr
ah okay,

schon mal vielen Dank. Werde das morgen gleich mal testen.

EDIT:

Also ich habe die Konfiguration jetzt einmal so gelassen und die Clients an die Ports angeschlossen. Ich Kann jetzt mit dem ping befehlt den jeweiligen Port des eigenen und des anderen clients anpingen. Den anderen Client erreiche ich aber nicht. hat das evtl. mit den Vlan-Tags zu tun?

Client 1
ip 10.1.3.2
sub 255.255.255.0
GW 10.1.3.1

Client 2
10.1.2.2
255.255.255.252
GW 10.1.2.1
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing zwischen VLAN mit Cisco RV320
gelöst Frage von Reini82Router & Routing7 Kommentare

Hallo allerseits, wir haben uns den Cisco RV320 Dual-WAN Router zugelegt damit wir zum einen unsere beiden DSL-Anschlüsse zusammenlegen ...

Router & Routing
Problem mit Cisco VLAN-Konfiguration
gelöst Frage von ef8619Router & Routing4 Kommentare

Hallo liebe Leute, wir haben 2 Cisco SGE2000 und SGE2000P im Stacking Mode laufen, dazu einen Cisco ISR 1921 ...

Router & Routing
Cisco SG300 - Kein Routing ins VLAN
gelöst Frage von Fluxx1337Router & Routing4 Kommentare

Hallo zusammen, Was ich möchte sieht man gut auf der Skizze. PC1 soll sich im dhcp Netz der Fritzbox ...

Switche und Hubs
Zwischen VLANs routen (Cisco)
gelöst Frage von teret4242Switche und Hubs15 Kommentare

Hallo zusammen, habe zwei Switches (Cisco 3560-PS) via Trunkport verbunden. Auf den beiden Switches sind jeweils die gleichen VLANs ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 9 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 9 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 12 StundenAdministrator.de Feedback9 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 17 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...