Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco 2900XL untagged Trunkport

Frage Hardware Switche und Hubs

Mitglied: marolli1983

marolli1983 (Level 1) - Jetzt verbinden

07.06.2013 um 12:17 Uhr, 2378 Aufrufe, 5 Kommentare, 2 Danke

Hallo,
Hab momentan ein Projekt für die Schule, soll einen cisco catalyst 2900 XL konfigurieren, klappt auch soweit bis auf meinen trunk port.
Bin zu Hause am ausprobieren und habe den switch an meinem Router hängen und meinen Laptop an einem vlan. Jetzt soll der trunk port aber untagged sein, und da Hänge ich. Ich weiß nicht wie ich es hinbekomme das alle vlans auf diesem trunk port untagged übertragen werden. Wenn ich es native mit dem vlan mache wo mein Lappi dran hängt geht es, aber so kann man ja nur ein vlan übertragen. Bräuche bitte Hilfe.
Mitglied: MrNetman
07.06.2013 um 13:49 Uhr
Das geht so nicht.

Ein Trunkport stellt
entweder die Verbindung zwischen zwei Switchen her
oder die Verbindung zu einem VLAN fähigen Router oder eine VLAN-fähigen Firewall.

Wenn du diesen Port untagged setzt, dann werden ja alle Trennung im Switch an dieser Stelle aufgehoben und eingehende Pakete dort gehen wohin? ins Nirwana oder an alle.
Also keine gute Option.

Wenn dein Home-Router keine VLANs unterstützt hast du hier schlechte Karten. Möglich ist noch ein PC mit Linux-OS, der mit getaggten Ports umgehen kann und dann auch das Routen übernimmt. Könnte auch eine VMWare Installation sein.

Gruß
Netman
Bitte warten ..
Mitglied: marolli1983
07.06.2013 um 15:21 Uhr
Laut Lehrer soll eine Firewall daran kommen aber er hat gesagt das der Trunk untagged sein soll. Warum auch immer.
Bitte warten ..
Mitglied: aqui
07.06.2013, aktualisiert um 19:12 Uhr
So sieht dein Trunkport (Cisco Sprech) aus:

interface GigabitEthernet 0/0
description Trunk Uplink zur Firewall
switchport mode trunk
switchport trunk allow vlan all
(switchport trunk encapsulation dot1q)
(switchport trunk native vlan 1)

Fertig ist der Lack !
Beachte das dort Spanning Tree rennt und der Cisco ca. 35 Sekunden benötigt den Port in den Forwarding Modus zu schalten. Hast du kein redundantes Netzwerk kannst du das auch mit dem Interface Kommando "spanning-tree portfast" beschleunigen.

Hier findest du im Kapitel "VLAN Setup Switch" und "Praxisbeispiel" eine lauffähige Konfig für so ein Umfeld mit Firewall und Cisco Catalyst:
http://www.administrator.de/contentid/110259

Trunk "untagged" ist natürlich technischer Blödsinn, das kannst du deinem Lehrer auch so sagen !
Es ist aber zu vermuten das er ggf. der speziellen Cisco Nomenklatur auf den Leim gegangen ist. Dann hat er wieder Recht:

Tagged VLAN Uplink = "Trunk" in Cisco Sprech = "Tagged Uplink" für den Rest der Switchwelt !
Link Aggregation = Bündelung von mehreren Links zu einem logischen = "Trunk" im Rest der Switchwelt = "Ether Channel" in der Cisco Welt !

Sag also dem Lehrer er soll wenigstens präzise Ansagen machen damit du das ausführen kannst was er will !

Meint er dennoch Link Aggregation also das Bündeln mehrerer Ports sieht das dann so aus auf dem Cisco wenn die beiden Interfaces Fast Ethernet 1 und 2 einen Trunk / Etherchannel bilden:
Switch# configure terminal
Switch(config)# interface range fastethernet0/1-2
Switch(config-if-range)# channel-group 1 mode active
Switch(config-if-range)# end

Switch(config)# interface port-channel 1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 1
Switch(config-if)# end

Bzw. falls der LAG auch ein tagged Uplink sein soll dann so:
Switch(config)# interface port-channel 1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allow vlan all

So, nun hast du alle Möglichkeiten durch, die der Lehrer meinen könnte !
Bitte warten ..
Mitglied: marolli1983
07.06.2013 um 19:35 Uhr
Super,
Vielen vielen dank für eure Hilfe!
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
Nativ Vlan per Trunkport?
gelöst Frage von MikePostNetzwerkgrundlagen10 Kommentare

Hallo zusammen Ich dachte bis letzter Woche das man pro Switch/Trunkport nur ein Native Vlan haben kann. Per default ...

Switche und Hubs
Verschiedene Vlans Tagged und untagged
gelöst Frage von roeggiSwitche und Hubs4 Kommentare

Hallo Zusammen Ich bin gerade an einer Wlan Installation mit Gästenetzwerk am einrichten. Folgende Komponenten sind im Einsatz: Draytek ...

Netzwerkgrundlagen
VLAN Tagged, Untagged klappt leider nicht so
gelöst Frage von rastalNetzwerkgrundlagen6 Kommentare

Hallo zusammen, ich habe noch ein Problem mit einem Tagged VLAN über 2 Switche. Beides HP Switch. Switch 1 ...

Switche und Hubs
VLAN erstellen - Tagged-Untagged-Excluded
Frage von SchauerSwitche und Hubs13 Kommentare

Guten Tag. Ich habe einen HP ProCurve 1810G. Ich möchte gern ein VLAN einrichten. Wobei das erstellen ja einfach ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Necur-Botnet soll Erpressungstrojaner Scarab massenhaft verbreiten

Information von BassFishFox vor 6 StundenErkennung und -Abwehr

12,5 Millionen Spam-Mails aus einem Bot-Netz mit 6 Millionen Computern? Eigentlich eine schwache Leistung. Die Erpresser setzen dabei auf ...

Microsoft

Nadeldrucker-Problem unter Windows - Microsoft liefert Updates

Information von BassFishFox vor 7 StundenMicrosoft

Hat ja nicht lange gedauert. Nachdem die November-Updates für Windows 7, 8.1 und 10 zahlreiche Nadeldrucker lahmgelegt hatten, stellt ...

Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 14 StundenLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Heiß diskutierte Inhalte
Windows Server
Kann man im KMS nachschauen , wieviele Clients den Key in Anspruch genommen haben
gelöst Frage von rainergugusWindows Server15 Kommentare

Hallo, wir haben einen KMS Windows 10 Key. Dieser ist ja W7 kompatibel. Aber unser Windows 7 Pool registriert ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...