Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco SG 200 VLAN

Frage Hardware Switche und Hubs

Mitglied: tmoser

tmoser (Level 1) - Jetzt verbinden

15.08.2014, aktualisiert 13:22 Uhr, 2938 Aufrufe, 13 Kommentare

Hallo zusammen,

ich habe 2 Switche (Cisco SG200-08 und SG200-26) mit einem LAG auf Port 1&2 sowie Port 25&26 verbunden.

ich möchte nun meine Fritzbox an Port 8 des SG200-08 in einem VLAN 80 auf dem SG200-26 auf Port 11,12&23,24 verfügbar machen. IP der Fritzbox 10.0.0.x; IP der Switche 172.27.x.x

Konfig der SG200-08

!Current Configuration:
!
!System Description "8-Port Gigabit Smart Switch"
!System Software Version "1.0.7.4"
!System Up Time "0 days 0 hrs 5 mins 15 secs"
!Additional Packages FASTPATH QOS
!Current SNTP Synchronized Time: Aug 15 10:41:19 201 UTC
!
vlan database
vlan 80
vlan name 80 "WAN"
exit
configure
sntp client mode unicast
sntp server 172.27.60.31 enable
clock timezone 2 minutes 0
username "yyy" password xxxxxxxxxxxxxxxxx
encrypted override-complexity-check
authentication dot1x none
spanning-tree configuration name "84-78-AC-A5-82-4A"
port-channel name ch1 UPLINK
port-channel load-balance 1 ch1
interface g1
addport ch1
exit
interface g2
addport ch1
exit
set hostname "switch-EG"
!
interface g3
switchport mode general
exit
interface g4
switchport mode general
exit
interface g5
switchport mode general
exit
interface g6
switchport mode general
exit
interface g7
switchport mode general
exit
interface g8
switchport mode general
switchport general pvid 80
switchport general allowed vlan add 80 tagged
switchport general allowed vlan remove 1
exit
interface ch1
port-channel static
switchport trunk allowed vlan add 80
exit
exit

Konfig der SG200-26
config-file-header
switch-keller
v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0
set system
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 80
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
hostname switch-keller
username xxx password encrypted yyyyyyyyy privilege 15
ip ssh-client server authentication
clock timezone " " 2
clock source sntp
clock source browser
sntp unicast client enable
sntp unicast client poll
sntp server 172.27.60.31
clock dhcp timezone
!
interface vlan 80
name WAN
!
interface gigabitethernet1
flowcontrol auto
description NAS
channel-group 1 mode auto
switchport mode general
!
interface gigabitethernet2
switchport mode general
!
interface gigabitethernet3
description ESXi
switchport mode general
!
interface gigabitethernet4
switchport mode general
!
interface gigabitethernet5
switchport mode general
!
interface gigabitethernet6
description "ASG220 - LAN"
switchport mode general
!
interface gigabitethernet7
switchport mode general
!
interface gigabitethernet8
switchport mode general
!
interface gigabitethernet9
switchport mode general
!
interface gigabitethernet10
switchport mode general
switchport general allowed vlan add 80 untagged
switchport general pvid 80
!
interface gigabitethernet11
switchport mode general
switchport general allowed vlan add 80 untagged
switchport general pvid 80
!
interface gigabitethernet12
channel-group 3 mode on
!
interface gigabitethernet13
flowcontrol auto
description NAS
channel-group 1 mode auto
switchport mode general
!
interface gigabitethernet14
switchport mode general
!
interface gigabitethernet15
switchport mode general
!
interface gigabitethernet16
switchport mode general
!
interface gigabitethernet17
switchport mode general
!
interface gigabitethernet18
switchport mode general
!
interface gigabitethernet19
switchport mode general
!
interface gigabitethernet20
switchport mode general
!
interface gigabitethernet21
switchport mode general
!
interface gigabitethernet22
switchport mode general
switchport general allowed vlan add 80 untagged
switchport general pvid 80
!
interface gigabitethernet23
switchport mode general
switchport general allowed vlan add 80 untagged
switchport general pvid 80
!
interface gigabitethernet24
shutdown
channel-group 3 mode on
!
interface gigabitethernet25
spanning-tree link-type point-to-point
channel-group 2 mode auto
macro description "switch "
!
interface gigabitethernet26
channel-group 2 mode auto
!
interface Port-channel1
description NAS
switchport mode general
switchport general allowed vlan add 80 tagged
!
interface Port-channel2
description "UPLINK DG"
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 80
macro description switch
macro auto smartport type switch $native_vlan 1
!
interface Port-channel3
description "UPLINK EG"
switchport trunk allowed vlan add 80
!
interface Port-channel4
switchport trunk allowed vlan add 80
!
exit
banner login 
KELLER KELLER

encrypted ip ssh-client key rsa key-pair


Innerhalb der SG200-26 ist das VLAN 80 verfügbar... jedoch nicht über die Switchgrenzen hinweg...

Hat jemand eine Idee was falsch ist? Ich denke ein Layer 2 Switch muss die Aufgabe lösen können...

Vielen Dank für die Unterstützung!!

Mitglied: keksdieb
15.08.2014 um 15:11 Uhr
Moin moin,

Räumen wir erstmal auf:

du willst eine Verbindung über ein LAG vom Keller zum EG machen, im Keller ist der 24 Port Switch und im EG der 8 Port Switch.
Für den LAG verwendest du die Ports 23/24 im Keller und 1/2 im EG und möchtest zudem auf dem Port-Channel das VLan 80 nutzen.

Den Port-Channel hast du ja bereits erstellt und ich gehe mal davon aus, dass er ohne Vlan Konfiguration funktioniert!
Jetzt musst du dem Interface des Port-Channels sagen, in welchem VLan er jetzt mitspielen darf:

Ich bin mir nicht sicher, ob die Syntax bei den SG Switchen analog zu der Syntax der Catalyst Switchen sind, aber fürs Verständnis sollte es reichen.
01.
interface Port-Channel 3 
02.
description Uplink EG 
03.
switchport mode access 
04.
switchport access vlan 80
Diese Konfig muss auf beiden Seiten gleich sein (EG und Keller).

Genau die gleiche Konfiguration nimmst du jetzt an den jeweiligen Switchports vor, die du ebenfalls Geren im VLan haben möchtest (11/12) und kannst mit einem Client an den konfigurierten Ports innerhalb des Vlans netzwerkeln.

Obwohl du nur ein Vlan angelegt hast, sagt mit meine Glaskugel, dass du mehrere betreiben möchtest (sonst könntest du einfach das Vlan 1 nutzen )
Jetzt wird es ein wenig kniffeliger, denn die Fritzbox soll ja mehrere Netze bedienen und benötigt deshalb einen Trunk auf dem Switch:

01.
interface <deiner Wahl> 
02.
description Uplink-zum-Fritz 
03.
switchport mode trunk 
04.
switchport trunk allowed vlan 80, und die vielen Anderen Vlan´s, die ins Internet sollen
So, zum Schluß muss ich aqui zitieren:
Debug und Logfiles sind dein Freund!

Ob der gute alte Fritz Vlan Settings und Trunking kann, kann ich dir leider nicht beantworten, da gibt es aber mit Sicherheit beim Vater von Fritz (www.avm.de) Information...

bis denne

der den keks diebte
Bitte warten ..
Mitglied: Dobby
15.08.2014 um 15:44 Uhr
Hallo Du alter Schokoladenkeks Dieb,

Ob der gute alte Fritz Vlan Settings
Nein, nur rudimentär und dann auch nur die VLAN Taks von einigen ISPs am WAN Port.
Mehr geht da nicht!

und Trunking kann, kann ich dir leider nicht beantworten,
Nein!

da gibt es aber mit Sicherheit beim Vater von Fritz (www.avm.de) Information...
Das Handbuch gibt einem da immer Auskunft zu, oder aber die "Troubadoure" auf YouTube.


Gruß
Dobby
Bitte warten ..
Mitglied: keksdieb
15.08.2014 um 15:54 Uhr
Moin Dobby,

Wenn ich zu Hause Muse und Zeit hätte für so ein VLan Konstrukt, dann würde ich das nicht mir einer Fritzbox machen ;).

Zum Fred:
Die Konfig ist ja wahrscheinlich über ein Webinterface zusammengeklickt (macht zumindestens den Anschein)...
Meiner Meinung nach sollte man aber bei einer Konfigurationsebene bleiben, also entweder CLI oder Webinterface (in diesem Falle).

Gruß Keksdieb
Bitte warten ..
Mitglied: tmoser
15.08.2014 um 16:21 Uhr
Hallo Keksdieb,

wie gerne ich doch etwas anderes als die Fritzbox einsetzten würde... leider ist der einzig sinnvolle isp die Kabel-Deutschland .. und die will einfach nur mit der AVM Fritzbox (Internet+VoIP)....

Danke für die Hinweise.. mal sehen was ich morgen daraus machen kann.

Ach ja, leider kann die SG200 kein CLI bzw. hat kein 100% COS. Ich muss die mit dem WebInterface bearbeiten...

Gruß
Thomas
Bitte warten ..
Mitglied: Dobby
15.08.2014 um 16:30 Uhr
Wenn ich zu Hause Muse und Zeit hätte für so ein VLan Konstrukt, dann würde ich das
nicht mir einer Fritzbox machen ;).
Naja das kann man so oder so sehen, denn die AVM FB kann das nicht wirklich, aber
es sieht so aus als wenn es da einen so genannten "Work around"gibt, man setzte ein
Transfernetz bzw. Transfer VLAN auf und packt dort die AVM FB alleine rein.

Muss man mal die Suchfunktion benutzen, erklärt wurde das hier schon oft.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
15.08.2014 um 18:49 Uhr
Und wie man das grundlegend macht mit dem SG-200 erklärt dir dieses Tutorial:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Bitte warten ..
Mitglied: keksdieb
17.08.2014 um 21:57 Uhr
Da gibt es nicht mehr viel zu zu sagen, außer das der Thread bei Beantwortung bitte als gelöst markiert wird!
Bitte warten ..
Mitglied: tmoser
18.08.2014 um 09:18 Uhr
vielen dank für die Unterstützung... na, wenn das Problem gelöst ist, dann kann ich selbstverständlich den Thread auf "gelöst" setzten... derzeit ist das aber noch nicht der Fall!
Bitte warten ..
Mitglied: aqui
18.08.2014 um 10:55 Uhr
Was genau ist denn noch nicht gelöst ??
Bitte warten ..
Mitglied: tmoser
18.08.2014 um 10:58 Uhr
sobald ich 5 min zeit habe kann ich es umsetzen und dann testen... es dauert einfach ein wenig ;)

danke für die Geduld!
Bitte warten ..
Mitglied: aqui
18.08.2014 um 11:01 Uhr
Ahhh, OK. Die Geduld haben wir naürlich. Positive Feedbacks lesen wir ja auch gern
Bitte warten ..
Mitglied: tmoser
21.08.2014 um 09:34 Uhr
So, nun hab ich es mal versucht....

ich habe ein Transfernetz eingerichtet und mit einer Sophos UTM das Routing realisiert. Auf den Layer 2 Switchen dann nur noch die VLAN's auf Portebene eingerichtet und schon hats funktioniert.

Danke für die Unterstützung!
Bitte warten ..
Mitglied: aqui
21.08.2014 um 13:05 Uhr
Immer gerne wieder...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Switche und Hubs
gelöst Frage zu SFP+ Einschub für Cisco SG-500X Switches (4)

Frage von the-datzl zum Thema Switche und Hubs ...

Router & Routing
gelöst Cisco SG300-10: VLAN und Routing (4)

Frage von niko123 zum Thema Router & Routing ...

Monitoring
Cisco SG300-20 - VLAN traffic monitoring (10)

Frage von fiech93 zum Thema Monitoring ...

Schulung & Training
Zertifizierung 200-125 Cisco (5)

Frage von Data61 zum Thema Schulung & Training ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...