Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco switch als dhcp server braucht lange um ip zu vergeben

Frage Netzwerke LAN, WAN, Wireless

Mitglied: homermg

homermg (Level 2) - Jetzt verbinden

21.02.2013 um 08:39 Uhr, 3303 Aufrufe, 7 Kommentare

Hey Leute,

ich richte hier gerade einen cisco 3750 switch als dhcp server ein.
Nach dieser Anleitung hab ich es gemacht: http://blog.router-switch.com/2012/04/tutorial-how-to-add-a-dhcp-range- ...

Das Problem ist nun das es fast 2 Minuten braucht bis der angeschlossene Client eine IP bekommt.
Hat jemand eine Idee was ich falsch gemacht habe?

hier sind die Portkonfigs:

switchport access vlan 10
spanning-tree portfast

und ich habe noch folgendes probiert leider auch ohne Erfolg

switchport access vlan 10
switchport trunk encapsulation dot1q
spanning-tree portfast trunk

ps der Switch ist im moment nicht am Netzwerk angeschlossen, sollte ich denke ich aber kein Problem sein. Ich schließe immer nur einen Client zu testen an.

VG
Mitglied: brammer
21.02.2013 um 09:14 Uhr
Hallo,

kannst du bitte mal die ganze config posten?

Da du nichts zur dhcp config schreibst ist das nur Rätselraten...

brammer
Bitte warten ..
Mitglied: homermg
21.02.2013, aktualisiert um 11:19 Uhr
HI
so sieht meine config aus:
ip dhcp pool 10.117.65.1
network 10.117.64.0. 255.255.252.0
default-router 10.117.64.1
domain-name firma.de
dns-server 10.117.64.100
lease 7

ip dhcp excluded-address 10.117.64.1-10.117.64.255

und zwei exclusions:
es sollen nur leases im 10.117.65.1-10.117.65.255 vergeben werden

ich weiß nicht warum der router zwar bei der eingabe von "netwrok" 10.117.65.1 diese annimmt aber später unter show running-c immer die 10.117.64.0 schreibt so wie oben


VG
Bitte warten ..
Mitglied: killtec
21.02.2013 um 11:44 Uhr
Hi,
ohne das Gerät zu kennen, müsste das hier:

ip dhcp excluded-address 10.117.64.1-10.117.64.255

nicht so sein, dass das die excluded (Ausgeschlossenen) Adressen stehen? Evtl. ist das schon der Fehler.

Gruß
Bitte warten ..
Mitglied: homermg
21.02.2013 um 11:51 Uhr
sorry habe micht vertippt

10.117.64.0 10.117.64.255 ist richtig
Bitte warten ..
Mitglied: aqui
21.02.2013 um 14:53 Uhr
Die Trunk Konfig ist Blödsinn, denn die wäre nur für tagged Ports, was Endgeräteports ja niemals sind. Vergiss den Unsinn also...
Es reicht folgendes:
ip dhcp excluded-address 192.168.100.1 192.168.100.149
ip dhcp excluded-address 192.168.100.170 192.168.100.254
!
ip dhcp pool local
network 192.168.100.0
default-router 192.168.100.254
dns-server 192.168.100.254
domain-name soho.intern
!
ip dhcp pool Server
host 192.168.100.170 255.255.255.0
client-identifier 0ab0.0c6c.01c4.d2
default-router 192.168.100.254
dns-server 192.168.100.254
client-name server
domain-name soho.intern
!

Wobei das letztere Beispiel einen fest vergebene IP auf Mac Basis ist !!
Die Switchports brauchen nur noch:
interface fastethernet 0/1
switchport access vlan x
spanntree-portfast


Mehr ist de facto nicht zu machen. 2960er, 3550er und alles anderen IOS basierten Switches vergeben dann eine IP nach max. 10 Sekunden !!
Bitte warten ..
Mitglied: MrNetman
21.02.2013 um 15:45 Uhr
Zitat von homermg:
ip dhcp pool 10.117.65.1
network 10.117.64.0. 255.255.252.0
gibt es nicht! => 10.117.64.0
ip dhcp excluded-address 10.117.64.1-10.117.64.255

und zwei exclusions:
es sollen nur leases im 10.117.65.1-10.117.65.255 vergeben werden
Du schreibst von zwei und sagst eins! oder gehört die 10.117.64.1 dazu. Könnte man wohl zusammen schreiben.

Gruß
Netman
Bitte warten ..
Mitglied: aqui
23.02.2013 um 14:06 Uhr
@MrNetman
Doch das IP Netz gibt es in der Masken Konstellation ! Netz: 10.117.64.0 /22 ,also 10.117.64.1 bis 10.117.67.254
Seine Nomenklatur ist nur etwas unsinnig denn er benennt seinen IP Adresspool mit einer Hostadresse in dem Netzwerk, was natürlich konfigtechnisch totaler Unsinn ist und auch verwirrend !
Korrekt sähe die DHCP Konfig also so aus:
ip dhcp pool vlan10
network 10.117.64.0. 255.255.252.0
default-router 10.117.64.1
domain-name firma.intern
dns-server 10.117.64.100


Sehr wichtig ist auf den VLAN-10 Ports die Konfig:
switchport mode access
switchport access vlan 10
spanntree-portfast

Wobei das "portfast" das wichtigste ist, denn ohne das Portfast Kommando benötigt der Port dann ca. 45 Sekunden um durch den Spanning Tree Learning Prozess zu gehen !!
Das Portfast sollte man also nur und ausschliesslich auf Endgeräte Ports anwenden niemals auf Uplink Ports !!
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Cisco Switch SG300-20 als DHCP Server
Frage von carbo1Router & Routing7 Kommentare

Hallo liebe Gemeinde, ich habe mich hier angemeldet um meine Kenntnisse zu verbessern. Ich habe auch gleich ein Problem, ...

Netzwerkgrundlagen
Korrekte IP-Einstellungen im Switch und im DHCP Server
gelöst Frage von Bobo2014Netzwerkgrundlagen12 Kommentare

Hallo liebe Administratoren, ich mach hier gerade einen Ferienjob und habe vom Administrator hier ein nettes kleines Übungsnetzwerk zur ...

Batch & Shell
Über DHCP vergebene IP mit Powershell als Statische festsetzen
gelöst Frage von ZellsiorBatch & Shell3 Kommentare

Moin allerseits, wir haben ab und zu Probleme mit einzelnen PC's. Diese können sich dann nicht an der Domäne ...

Windows Server
DHCP Server switchen
Frage von M.MarzWindows Server25 Kommentare

Hallo zusammen, ich habe 2 DC´s im Netzwerkstehen die beide Parallel mit DNS Funktion laufen. Auf dem DC1 habe ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 2 StundenInternet1 Kommentar

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 9 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 20 StundenWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 22 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless15 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...