Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco UDLD Probleme mit LWL

Frage Netzwerke

Mitglied: apranet

apranet (Level 1) - Jetzt verbinden

19.06.2017 um 21:43 Uhr, 266 Aufrufe, 6 Kommentare, 1 Danke

Guten Tag Netzwerkfreunde,

ich komme mit einer Sache einfach nicht weiter und bitte um eure Unterstützung.

Wir haben 3 Switche:
A:3750X
B:2960X
C:3850

A und B sind miteinander über LWL SFPs verbunden (1GB, 1310NM, SM)
Jetzt habe ich B mit C getauscht (wird Endzustand).
Die Verbindung zwischen A und C kommt nicht zur Stande, weil A den Port runterfährt mit
einer Fehlermeldung "..udld error detected..".
Resete ich den udld, dann ist der Port kurz up und sofort wieder down.
Wenn ich mir von allen drei Switche die udld Konfiguration anschaue z.B. so,
sh run I include udld
udld aggressive
err disable recovery cause udld
Kommt das bei allen drei das Gleiche raus.
Wenn ich sh udld am A mache, erkennt er natürlich das die Verbindung unidirektional ist.

Mein Natives VLAN ist die 01, hab auch versucht dem Switch A unter Switchport Trunk native VLAN 01 zu setzten.
hilft auch nicht.
Wie gesagt, ich habe nur den Switch getauscht SFPs, Patchkabel usw. nicht, da es bei Switch B funktioniert.

Ich weiß das meine Infos etwas wenig ist, da ich in Moment nicht vor Ort bin, aber ich hoffe jemand kann mir einen Tip geben.

Danke
Mitglied: catachan
20.06.2017 um 06:43 Uhr
Hi

UDLD kümmert sich darum um eine Netzwerkschleife zu verhindern. Bei LWL hast du ja eine Empangs und eine Sendefaser. Sollte die Empfangsfaser bei einem Switch ein Problem haben dann können auch keine Spanning Tree BPDUs empfangen werden und der Port geht von blocking auf forwarding.

Wenn mann nun UDLD aktiviert werden Pakete zwischen den Switches getauscht. Sollte wine gewisse Anzahl der Pakete nicht reflektiert werden so wird der Port disabled.

In deinem Fall heisst das, dass du ein Problem mit der LWL hast. Kontrolliere nochmal alle Steckverbindubgen und tausche ggf das LWL Patch

LG
Bitte warten ..
Mitglied: apranet
20.06.2017 um 07:07 Uhr
Wie schon beschrieben.
Sobald ich Switch B wieder einbaue geht es.
Ich habe Switch C auch an einen anderen Switch angebuden und es bewirkt das Gleiche.
Ich denke die Konfig von Switch C ist fehlerhaft, aber ich finde nichts.
Bitte warten ..
Mitglied: catachan
20.06.2017 um 07:14 Uhr
Hi

Bei UDLD gibt es ausser dem Aktivieren und dem Modus keine Konfiguration. Natürlich kann es auch ein Hardware oder Firmware Problem sein. Versuch mal einen anderen SFP

Theoretisch könnte man UDLD ausschalten, würde ich wegen der Loop Problematik aber eher nicht

LG
Bitte warten ..
Mitglied: apranet
20.06.2017 um 08:27 Uhr
Die SFPs habe ich auch getauscht.
Komisch, wenn ich udld am Switch A abschalte geht es dann, also Trunk Port bleibt up und ich kann die Netzwerkteilnehmer vom Switch A (über B) anpingen.
Bitte warten ..
Mitglied: catachan
20.06.2017 um 08:39 Uhr
Hi

Wie gesagt. Wenn da eine Faser einmal ein Problem hat dann hast du eventuell einen L2 Loop.

LG
Bitte warten ..
Mitglied: apranet
20.06.2017 um 16:14 Uhr
Problem gefunden !
Der Funkelnagelneuer 3850 ist Schuld !
Firmware hat einen bug (16.3.3)
Hab ein downgrade gemacht und jetzr gehts.

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCva55550/?referring_site ...
Bitte warten ..
Ähnliche Inhalte
DSL, VDSL
gelöst VPN-Probleme (CISCO AnyConnect) in Zusammenhang mit Router "Vodafone EasyBox" (7)

Frage von donnyS73lb zum Thema DSL, VDSL ...

Windows Systemdateien
Windows Defender Probleme (mal wieder) lassen sich um keinen Preis beheben (2)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

Router & Routing
gelöst Cisco-887V - BNG Anschluss Telekom via Allnet ADSL2+ Modem (5)

Frage von Serial90 zum Thema Router & Routing ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
NTFS und die Defragmentierung (26)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Zwei Subnetze mit je eigenem Router und Internetzugang verbinden (18)

Frage von hannsgmaulwurf zum Thema LAN, WAN, Wireless ...

Windows Server
WIndows Server 2016 core auf dem Intel NUC NUC5i5RYK i5 5250U (17)

Frage von IxxZett zum Thema Windows Server ...