Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Citrix und ein Comport Problem...

Frage Microsoft Windows Server

Mitglied: Eldarsarius

Eldarsarius (Level 1) - Jetzt verbinden

11.10.2011 um 14:04 Uhr, 4269 Aufrufe, 3 Kommentare

Citrix und ein Comport einer lokalen Maschine...

Hallo Zusammen,

ich habe derzeit folgendes Problem und kann mir derzeit nicht weiterhelfen. Aber voerst beschreibe ich die Ausgangslage.

Unser Netzwerk erstreckt sich über zwei Standorte die ca. 60 KM auseinander liegen. Beide Standorte sind mit einer Standleitung der Telecom (Company Connect)
ausgestattet. Die Verbindung wird über einen ständigen überwachten VPN Tunnel betrieben. Auf der Seite der Zentrale (Standort 1) existiert eine Windows 2003er Domäne mit
einer kleinen Citrix Farm (XenApp 4,5) in der 2 Citrix Servern betrieben werden. Standort 2 ist ein externes Lager indem ca. 20 Clients (Windows 7) mit dem Citrix Online Plugin
betrieben werden. Die gesamte Umgebung läuft seit einiger Zeit stabil bis auf diverse Kleinigkeiten. Jedoch existieren zwei Clients mit etwas spezielleren Anforderungen
vor Ort die Probleme machen.

Diese Systeme sind angeschlossen an einem Handscanner, Netzwerkdrucker, Zebradrucker für Etiketten und einem Waagesystem (über COMport) für die über das Band laufenden Pakete. Über Citrix wird
die Published Applikation Dynamics NAV 2009 betrieben. Aufgabe der beiden Systeme ist es das Picklisten (Kommissionierlisten) per Handscanner über einen Barcode an unser Warenwirtschaft
system übermittelt werden. Dabei wird das Gewicht des entsprechenden Paketes per Abfrage der Waage automatisch übermittelt. Daraufhin werden ein Lieferettikett und der Lieferschein gedruckt.
Ziel der beiden Systeme ist es eine schnelle und einfache Abarbeitung von Paketen zu gewährleisten.

Nun zu meinem eigentlichen Problem.
Die beiden "Waage" Systeme wurde vor kurzen durch neue Standarthardware ersetzt. Dabei hat sich folgendes geändert.

Änderungen
- BS: Windows XP zu Windows 7
- keinen Comport on Bord sondern durch zusätzliche Karte gelöst.

Tests:
- Abfrage der Waage lokal über Hyperterminal möglich.
- Abfrage der Waage über Citrix Desktop mit entsprechender Anmeldung ebenfalls möglich
- Abfrage der Waage über Publishe App. Dynamics Nav 2009 2 - 3 möglich danach kein Input mehr....

Fazit:

Nach einigen Tests scheint sich kein Signal mehr von der angeschlossenen Waage über das System zu kommen, weder lokal, über den Citrix Desktop noch
über Navision. Die Citrix Session muss abgemeldet werden und das lokale System muss neu gestartet werden um wieder betriebsbereit zu sein. Danach wiederholt
sich der Vorgang und wir mussten auf manuelle Eingabe des Gewichts umstellen. Eine automatische Erfassung ist nicht mehr möglich.

Das Kuriose daran ist... das passiert nur auf einem der beiden System das andere läuft ohne Probleme durch. Es sei denn beide Systeme arbeiten gleichzeitig kurzfristig
zusammen, dann entstehen auf dem zweiten System ebenfalls diese Fehler und die Geschichte geht von vorne los. Selbst eine Trennung beider System seitens der Anmeldung
auf jeweilig einen Citrix Server bringen kein Ergebnis.

Ich hoffe hier jemand zu finden der ähnliche Problematiken kennt und mir einen Tipp geben kann wo ich weiter suchen soll.

Vielen Dank
Gruß
Eldarsarius
Mitglied: brammer
11.10.2011 um 16:21 Uhr
Hallo,

sind auf beiden Rechnern die COM Port korrekt eingestellt?
Welche Parameter benötigen die Waagen?
Manchmal macht es Sinn nicht die Höchstmögliche Baudrate einzustellen sondern ein oder zwei Stufen niedriger.

Was für Karten werden für den COM Ports eingesetzt?
Oder sind das USB auf COM Port Adapter Karten?

brammer
Bitte warten ..
Mitglied: Eldarsarius
11.10.2011 um 17:48 Uhr
Die COM Ports sind auf beiden Rechner lokal entsprechend eingestellt.

Die Waagen benötigen folgende Parameter:
Bits pro Sekunden: 2400
Datenbits: 7
Parität: Gerade
Stoppbits: 1
Flusssteuerung: kein

Ich finde die Baudrate schon relativ niedrig mit höheren funktioniert es eh nicht. Mit niedrigeren hab ich es
noch nicht getestet. Die Karten für die COM Ports sind Standartware(PCI Express.. oder sowas) und funtionieren mit
Windows eigenen Treibern. Die Karten sind im Rechner eingebaut und werden nicht durch USB emuliert.

Zudem sind die COM Port in den jeweiligen Session entsprechend dauerhaft gemappt. Die Ansteuerung der
Ports wird aus unserem Warenwirtschaftssystem initialisiert.

Gruß
Eldarsarius

EDIT: Nur zu Testzwecken baue ich eine Hyperterminal Verbindung auf um zu schauen ob überhaupt ein Ergebnis zurück kommt.
Bitte warten ..
Mitglied: brammer
11.10.2011 um 20:44 Uhr
Hallo,

wenn die Baudrate schon so niedrig ist wirst du mir weniger kaum hinkommen, wobei du 1200 ruhig testen kannst nur mit 300 oder wneiger bringt es wohl kaum was.

7 Datenbits sind allerdings eher ungewöhnlich
Hast du ausprobiert was passiert wenn du no parity einstellst?

brammer
Bitte warten ..
Ähnliche Inhalte
UMTS, EDGE & GPRS
NPort SMS Gateway SMSPasscode Problem mit Comport
gelöst Frage von pablovicUMTS, EDGE & GPRS3 Kommentare

Hallo liebe Admins Wir brauchen für SMSPasscode ein NPort 5110 SMS Gateway. Der Nport ist über ein Serial2IP (Nport ...

Virtualisierung
Citrix Remote Acces Problem
Frage von KEFHVDIVirtualisierung

Hallo, wir testen gerade die im Titel genannte Funktion. Wir haben auf bereits 3 Office Rechnern den VDA installiert ...

Windows Netzwerk
Citrix Anmeldung Problem
Frage von DaHuberWindows Netzwerk

Tag zusammen, haben bei uns ein Problem, finden keine Lösung. Wenn sich manche User bei TS 2008 R2 Citrix ...

Xenserver
Excel-Problem in Citrix-Umgebung
Frage von reksierpXenserver4 Kommentare

Hallo, Ich bin Ausbilder bei Industriekaufleuten, und um meinen Schülern die Funktion in Excel "Daten/Externe Daten abrufen/aus dem Web" ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 4 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 4 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 7 StundenAdministrator.de Feedback6 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 11 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...