Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Clients erscheinen bei OpenVPN Verbindung nicht unter dem Netzwerk-Knoten

Frage Netzwerke Netzwerkmanagement

Mitglied: istike2

istike2 (Level 2) - Jetzt verbinden

27.10.2014 um 23:32 Uhr, 1045 Aufrufe, 3 Kommentare

Hallo,

wir möchten bei uns ELO einrichten. Die Dateien würde dabei auf unserem NAS im Büro liegen, worauf die Kollegen durch OpenVPN zugreifen möchten.
Das Problem ist, dass ELO nur Geräte auswählen kann, die im Windows Explorer unter "Netzwerk" erscheinen. Normale Netzwerkfreigabe mit Laufwerkbuchstabe usw. funktioniert aus welchem Grund auch immer nicht.

Weiss jemand warum diese Infos durch OpenVPN nicht vermittelt werden? Sollen wir einfach länger warten oder etwas am OVPN Server anders einrichten?

Danke sehr für die Ideen.

Gr. I.
Mitglied: Chris-75
28.10.2014 um 08:00 Uhr
Moin,

Broadcast-Suchen werden nicht geroutet, darum siehst du in der Netzwerkumgebung nichts.
Was überhaupt ist ELO?

lg
Chris
Bitte warten ..
Mitglied: aqui
28.10.2014 um 09:18 Uhr
Was auch immer das geheimnisvolle "ELO" ist...das weisst vermutlich auch nur du...aber egal !
Damit solche Dienste dort auftauchen braucht es den Name Service Broadcast via UDP Broadcast dieser Dienste wie es Windows und auch das unixoide Samba machen um solche Shares oder Dienste zu announcen.
Wie jeder netzwerker weiss und in der Grundschule lernt werden bei TCP/IP generell keine UDP Broadcasts über Router Interfaces übertragen. Ist ja auch sinnig um in gerouteten Umgebungen die Broadcasts Domains klein zu halten (Performance).
Da OVPN ja auch ein geroutetes VPN Netz ist werden diese UDP Naming Broadcasts also nicht übertragen ohne einen Forwarder.
Fazit: Geht so nicht wenn du routest mit OVPN

Lösung: Man sollte es zwar niemals, kann OVPN aber auch in den Bridging Mode versetzen.
https://openvpn.net/index.php/open-source/documentation/miscellaneous/76 ...
und
http://www.heise.de/netze/artikel/Bridge-Modus-224072.html
Damit machst du dann ein ganz simples Layer 2 Bridging zwischen den OVPN Knoten und et voila..... schon werden die Broadcasts übertragen und du "siehst" wieder naming Broadcasts bzw. deren Einträge.
Der Nachteil ist das hier sämtlicher Broad- und Multicast Traffic der verbundenen Netzwerke transparent über den Tunnel übertragen werden und so zu einem gravierenden Performance verlust im VPN Umfeld führen der bis zum Stillstand des Tunnels gehen kann bei geringer Bandbreite.
Das ist der Hauptgrund warum man generell KEIN Bridging im VPN Umfeld machen sollte.
Wenn es aber mit deiner "was auch immer ELO ist" Anforderung nicht anders geht musst du in den sauren Apfel beissen.
Bitte warten ..
Mitglied: colinardo
28.10.2014, aktualisiert um 09:30 Uhr
Moin,
dafür müsstest du deine OpenVPN-Verbindung im Bridge-Mode mit TAP anstatt TUN betreiben damit Broadcasts und NDP an die Clients übermittelt werden. Sollte man aber wenn möglich immer vermeiden, da die Broadcasts einiges an Bandbreite der VPN-Verbindung kosten, je nachdem wie viele Devices im Netzwerk sind.

Für die die nicht wissen was ELO ist
http://www.elo-office.de/home

Grüße Uwe
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Router & Routing
OpenVpn Verbindung Synology NAS hinter Zywall USG 40 (2)

Frage von Tirgel zum Thema Router & Routing ...

Firewall
gelöst PFSense Squid Proxy über OpenVpn Verbindung nutzen (4)

Frage von horstvogel zum Thema Firewall ...

Router & Routing
gelöst OpenVPN Zertifikat abgelaufen - Verbindung nicht möglich (31)

Frage von intane zum Thema Router & Routing ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (24)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Netzwerke
Abisolierwerkzeug (11)

Frage von SarekHL zum Thema Netzwerke ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (11)

Frage von Akcent zum Thema Hyper-V ...

Windows Server
Server 2016 - Kuriositäten (8)

Frage von certifiedit.net zum Thema Windows Server ...