Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Welche CMD- oder Rechnereinstellungen sind fehlerhaft?

Frage Entwicklung Batch & Shell

Mitglied: Ruebezahl

Ruebezahl (Level 1) - Jetzt verbinden

08.02.2008, aktualisiert 09.02.2008, 3785 Aufrufe, 3 Kommentare

Liebe Leute,



die folgende Programmzeile stammt aus Bibers Programm "GetAllSystemDateTimeInfos_3.bat" (siehe "Workshop Batch for Runaways Part III Datums- und Zeitvariablen im Batch"):

01.
FOR /F "tokens=1* delims==" %%i IN ('Type %RegFile% ^| FIND /I "iDate"') DO SET iDate=%%j
Diese Zeile wie auch das ganze Programm funktioniert unter Windows 2000 / XP / 2003 vollkommen einwandfrei.
Nur an einem Windows 2000 - Rechner funktioniert es nicht.
Dort erscheint die Meldung

"iDate"="1"

auf dem Bildschirm.
Die Zeile mit "sDate" funktioniert übrigens auch nicht und bringt eine ebensolche Meldung auf den Bildschirm.

Vermutlich sind eine oder vielleicht mehrere Einstellungen des Rechners fehlerhaft.

Hat irgendjemand eine Idee?


Vielen Dank für Eure Mühe und Eure Zeit.
Herzliche Grüße

Ruebezahl


[EDIT]


Liebe Leute,


hier zum besseren Verständnis des Problems die wesentlichen Zeilen des Programms (Quelle: Bibers Workshop)


01.
::--------snapp GetAllSystemDateTimeInfos_3.bat 
02.
@ECHO OFF 
03.
:: (c) Biberware 2005 Placed in the Public Domain Oct 2005 for Educational Purposes 
04.
:: Ermittelt ein paar Datumsvariablen aus dem CMD-Environment (Systemdatum) <b>MIT </b>REG-Abfragen 
05.
 
06.
 
07.
 
08.
Set RegFile=%temp%\%random%.reg 
09.
START /W REGEDIT /E %Regfile% "HKEY_CURRENT_USER\Control Panel\International" 
10.
 
11.
 
12.
 
13.
FOR /F "tokens=1* delims==" %%i IN ('Type %RegFile% ^| FIND /I "iDate"') DO SET iDate=%%j 
14.
FOR /F "tokens=1* delims==" %%i IN ('Type %RegFile% ^| FIND /I "sDate"') DO SET sDate=%%j 
15.
DEL %RegFile%

Die beiden FOR-Schleifen arbeiten fehlerhaft - und das, wie bereits weiter oben beschrieben, nur an einem einzigen Windows 2000 - Rechner.


Vielen Dank für Eure Mühe und Eure Zeit.
Herzliche Grüße

Ruebezahl
Mitglied: Dani
08.02.2008 um 11:28 Uhr
Hallo Ruebezahl,
kannst du bitte deine ganze Batchfile posten + Nebendateien wie "%RegFile%?! Im Moment wird es schwer, genau zu definieren wo der Fehler sitzt. Mein Glaskugel kram ich ungern raus... *g*


Grüße
Dani
Bitte warten ..
Mitglied: Biber
08.02.2008 um 17:01 Uhr
Moin Rübezahl,

den Fehler selbst kann ich momentan auch nicht rekonstruieren.

wie das Regfile aussehen sollte bei richtig (bzw. normalerweise) gesetzten Werten, kannst Du Dir an einer der Maschinen ansehen, wo das Skript läuft.

In dem Tut habe ich aber auch einen Komplettausdruck dieses Reg-Hives gepostet.
Da auch die Anzeige "iDate"="1" auf dem Bildschirm erscheint, scheint zudem auch der Wert von "idate" in dem Regedit-Export vorzuliegen.
01.
Windows Registry Editor Version 5.00 
02.
 
03.
[HKEY_CURRENT_USER\Control Panel\International] 
04.
"iCountry"="49" 
05.
"iCurrDigits"="2" 
06.
"iCurrency"="3" 
07.
"iDate"="1"           <---------------------------und zwar hier 
08.
"iDigits"="2" 
09.
"iLZero"="1" 
10.
"iMeasure"="0" 
11.
"iNegCurr"="8" 
12.
"iTime"="1" 
13.
"iTLZero"="1" 
14.
....
Du kannst ja mal an diesem Rechner ein
01.
START /W REGEDIT /E test.reg "HKEY_CURRENT_USER\Control Panel\International"
...abfeuern oder alternativ am CMD-Prompt zur Sichtkontrolle ein..
01.
reg query "HKCU\Control Panel\International"
Für mich hört es sich eher so an, als hätte dieser Rechner eventuell eine Montags-Kopie des Skriptchens bekommen - ersetz diese doch bitte mal durch eine andere Kopie.

Grüße
Biber
Bitte warten ..
Mitglied: Ruebezahl
09.02.2008 um 15:24 Uhr
Hallo Biber,


Deine Vermutung mit der Montagskopie hatte ich auch schon und habe mir deshalb heute, an einem Sonnabend, eine neue Kope gezogen. Sie läuft anderswo klaglos - nur aus dem besagten Rechner nicht. Damit hätten wir den Wochentag als Fehlerursache ausgeschlossen.

Die Ausgabedatei "%RegFile%" der Registry weisst keinerlei Besonderheiten auf:

01.
Windows Registry Editor Version 5.00 
02.
 
03.
[HKEY_CURRENT_USER\Control Panel\International] 
04.
 
05.
06.
07.
08.
"iDate"="1" 
09.
10.
11.
12.
"sDate"="." 
13.
14.
15.
.
Auch Ausgabedatei der Registry fällt damit damit als Fehler aus dem Rennen.


Herzliche Grüße
Ruebezahl
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Taskkill für bestimmtes cmd Fenster (6)

Frage von n0cturne zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Installation
gelöst Java Switches für die .cmd (12)

Frage von Todybear zum Thema Windows Installation ...

Batch & Shell
Iso einlegen und cmd ausführen (4)

Frage von Morslupatus zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (21)

Frage von zorlayan zum Thema Windows 10 ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
Pro Contra "echtes Subnetting" VLSM (12)

Frage von killing.Apfelkuchen zum Thema Netzwerkgrundlagen ...

Voice over IP
Über Fritzfax over IP gehen nur einige Faxe (11)

Frage von shearer9 zum Thema Voice over IP ...