Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CRS-125 trunk mit Linux

Frage Sonstige Systeme MikroTik RouterOS

Mitglied: tinti1234

tinti1234 (Level 1) - Jetzt verbinden

14.07.2014 um 09:46 Uhr, 1741 Aufrufe, 6 Kommentare

Hallo,

wer weiß wie ich auf dem Mikrotik CRS125 einen Trunk einrichten kann um auf einem Linux mehrer VLAN's zu haben.
Linux Seite kenne ich mich ausreichend gut aus, also modul 8021q laden, mit vconfig die VLAN's hinzufügen und mit ifconfig das jeweilige VLAN hochfahren und IP vergeben.
Doch wie kann ich auf Mikrotik Seite ein solchen Port hinzufügen? Ich habe mal etwas herum experimentiert mit ether3 ohne master port und in /interface ethernet switch vlan habe ich ether3 in drei verschiedene VLAN's gelegt. Das scheint aber so nicht zu funktionieren?

Vielen Dank im Voraus für eure Hilfe.
tinti
Mitglied: brammer
14.07.2014 um 11:18 Uhr
Hallo,

http://forum.mikrotik.com/viewtopic.php?f=13&t=85290

Steht durchgängig erklärt, auf der Mikrotik Forumsseite...

brammer
Bitte warten ..
Mitglied: tinti1234
14.07.2014 um 11:57 Uhr
Das ist eigentlich das was ich bereits konfiguriert habe:

01.
/interface ethernet switch egress-vlan-tag 
02.
add tagged-ports=ether3,ether4,ether5 vlan-id=1301 
03.
add tagged-ports=ether3,ether4,ether5 vlan-id=1302 
04.
 
05.
/interface ethernet switch vlan 
06.
add ports=ether3,ether4,ether5 vlan-id=1301 
07.
add ports=ether3,ether4,ether5 vlan-id=1302 
08.
 
09.
/interface ethernet switch 
10.
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether3,ether4,ether5
Das funktioniert aber leider nicht. Hier noch die weiteren relevanten Settings:

01.
/interface vlan 
02.
add interface=ether1 l2mtu=1584 name=Guest vlan-id=1302 
03.
add interface=ether1 l2mtu=1584 name=WLAN vlan-id=1301 
04.
 
05.
/interface bridge 
06.
add comment=WLAN l2mtu=1584 name=br-VLAN_1301 protocol-mode=stp 
07.
add comment=Guest l2mtu=1584 name=br-VLAN_1302 protocol-mode=stp 
08.
 
09.
/interface bridge port 
10.
add bridge=br-VLAN_1301 interface=WLAN 
11.
add bridge=br-VLAN_1302 interface=Guest 
12.
 
13.
/interface bridge settings 
14.
set use-ip-firewall=yes use-ip-firewall-for-vlan=yes 
15.
 
16.
/ip address 
17.
add address=172.18.178.1/24 interface=WLAN network=172.18.178.0 
18.
add address=172.17.21.1/24 interface=Guest network=172.17.21.0 
19.
 
20.
/ip dhcp-server 
21.
add address-pool=WLAN disabled=no interface=br-VLAN_1301 lease-time=1w name=WLAN 
22.
add address-pool=Guest disabled=no interface=br-VLAN_1302 lease-time=1w name=Guest 
23.
 
24.
/ip dhcp-server network 
25.
add address=172.17.21.0/24 gateway=172.17.21.1 netmask=24 
26.
add address=172.18.178.0/24 gateway=172.18.178.1 netmask=24 
27.
 
Vielleicht hilft das etwas weiter?

Danke!
Bitte warten ..
Mitglied: aqui
15.07.2014, aktualisiert um 09:42 Uhr
Der Begriff "Trunk" ist leider sehr irreführend, denn er wird doppelt genutzt im Netzwerkbereich:
Trunk = Link Aggregation / Teaming also das Bündeln mehrerer Netzwerk Links zu einem logischen zur Bandbreitenerhöhung
Trunk = Tagged VLAN Uplink zum Übertragen mehrerer VLAN mit 802.1q Tagging auf einem Link
Du solltest deshalb nochmal genau definieren WAS du jetzt meinst !

Linux seitig kannst du hier nochmal nachlesen:
Thema VLAN Tagging und Einrichtung bei Linux:
http://www.administrator.de/wissen/netzwerk-management-server-mit-raspb ...

Thema Link Aggregation und Teaming und dessen Einrichtung bei Linux:
http://www.administrator.de/wissen/netzwerk-management-server-mit-raspb ...

Was den Mikrotik anbetrifft kannst du das korrekte einrichten von VLAN (Tagged) Uplinks hier nachlesen inkl. Konfig zum Abtippen:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
bzw.
http://www.administrator.de/contentid/233966

Damit kommt das sofort zum Fliegen...
Bitte warten ..
Mitglied: tinti1234
15.07.2014 um 10:02 Uhr
Also es handelt sich um Tagged VLAN Uplink zum Übertragen mehrerer VLAN mit 802.1q Tagging auf einem Link!
Danke für die Links wie es unter Linux und Raspi eingerichtet wird, dies entspriecht definitiv meiner Konfiguration und das ist auch eine Konfiguration die ich in Verbindung mit Cisco Switches schon am laufen hatte.

Bei den Mikrotik Links finde ich aber leider keine Konfig die zum Abtippen bereit steht oder habe ich Tomaten auf den Augen?
Bitte warten ..
Mitglied: aqui
15.07.2014 um 10:08 Uhr
Nein das sind Screensots des WinBox Tools mit dem Mikrotiks grafisch konfiguriert werden oder das WebGUI was identisch dazu ist.
Die CLI Alternative ist in diesem Forum nicht mit aufgeführt da es das Gros der Leser eh nicht versteht und eher grafisch orientiert ist.
Wir können dir die CLI Kommandos aber gerne nochmal posten hier wenn du möchtest ?!
Ansonsten nimm die WinBox:
http://www.mikrotik.com/download
Bitte warten ..
Mitglied: tinti1234
15.07.2014 um 10:10 Uhr
Ja, würde mich sicherer fühlen mit den Kommandos, da ich genau das was ich auf den Screenshots sehe gemacht habe.
Bitte warten ..
Ähnliche Inhalte
Schulung & Training
Zertifizierung 200-125 Cisco
Frage von Data61Schulung & Training5 Kommentare

Guten Morgen zusammen, ich möchte die Zertifizierung 200-125 von Cisco machen, würde mich gerne vorab Informieren auf welche Fragen ...

Netzwerkmanagement
Ungetaggte Pakete an Trunk-Ports
gelöst Frage von diemilzNetzwerkmanagement4 Kommentare

Hallo zusammen, ich habe eine kleine Verständnisfrage: Stimmt es, dass man in Netzen mit mehreren VLANs an Trunkports (VLAN-Ports ...

Switche und Hubs
Cisco trunk einstellen
gelöst Frage von homermgSwitche und Hubs11 Kommentare

Hey Leute, ich arbeite relativ selten mit unseren switchen und bin mir nun bei einer Sache nicht ganz sicher. ...

Netzwerkgrundlagen
Vlan Trunk bereitet Probleme
Frage von KampfwurstNetzwerkgrundlagen3 Kommentare

Hallo Ich würde gerne um mich weiterzubilden das Netzwerk zuhause gerne einwenig umbauen. ;-) Auf Routerboard Hardware Jetzt benötige ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 3 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...