Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Darstellungsfehler von Website

Frage Entwicklung CSS

Mitglied: m.reeger

m.reeger (Level 2) - Jetzt verbinden

28.11.2013, aktualisiert 14:11 Uhr, 1718 Aufrufe, 5 Kommentare

Hallo liebe Admins & Webdesigner,

ich bin zur Zeit dabei mir eine eigene Website zu erstellen, doch leider komme ich gerade nicht weiter!

In Google Chrome wird die Website richtig dargestellt in Firefox, Internet Explorer und Safari wird die Navigation etwas versetzt dargestellt.

Hier mal der Link zur Website: https://www.reeger.net/

Vielleicht kann mir ja jemand helfen das Problem zu lösen oder hat Verbesserungsvorschläge.
Ich bin Ratlos und befreundete Webdesigner wissen auch nicht weiter.

Schöne Grüße!


Edit:
So sollte es aussehen:
bd6963e303d8ca2fa72879c24e4a3611 - Klicke auf das Bild, um es zu vergrößern

So sieht es im Firefox / IE aus:
dac603369502ecaeb012fc02ddeb645d - Klicke auf das Bild, um es zu vergrößern
Mitglied: firefly
28.11.2013, aktualisiert um 14:00 Uhr
Hi,

lass Deine Seite doch mal gegen den W3C HTML/XHTML Validator: http://validator.w3.org und dem W3C CSS Validator http://jigsaw.w3.org/css-validator/ laufen. Evtl. erkennst du dann schon ein paar Fehler auf Deiner Seite.

Bei mir sieht es unter dem Safari (Mac Version 7) übrigens richtig aus. Füge doch mal zwei Screenshot hinzu (einen wie es sein soll und einen wie es falsch ist).

Gruß
firefly
Bitte warten ..
Mitglied: m.reeger
28.11.2013 um 14:13 Uhr
Besten Dank schonmal für die Antwort.
Habe im Firefox Plugins wie Firebug etc. drinne leider wird kein Fehler ausgegeben.

Werde es mal mit den Validatoren versuchen.
Bitte warten ..
Mitglied: Xaero1982
28.11.2013, aktualisiert um 14:19 Uhr
Moin,

01.
@charset "utf-8"; 
02.
/* CSS Document */ 
03.
 
04.
 
05.
body { 
06.
	width: 960px; 
07.
	height: auto; 
08.
	margin-left: auto; 
09.
	margin-right: auto; 
10.
11.
#site { 
12.
	width: 960px; 
13.
	height: auto; 
14.
	margin-left:auto; 
15.
	margin-right:auto; 
16.
17.
 
18.
header { 
19.
	width: 100%; 
20.
	margin: 0; 
21.
	padding: 0; 
22.
23.
 
24.
header ul { 
25.
	 
26.
27.
header li  { 
28.
	 
29.
30.
#logo { 
31.
	width:960px; 
32.
	height:70px; 
33.
	margin: auto;	} 
34.
 
35.
nav { 
36.
	width: 960px; 
37.
	height: 70px; 
38.
	margin: auto auto 20px auto; 
39.
	display: table; 
40.
41.
 
42.
nav ul { 
43.
	display: table-row; 
44.
45.
 
46.
nav li { 
47.
	display: table-cell; 
48.
49.
 
50.
nav a { 
51.
	float: left; 
52.
	width: 190px; 
53.
	height: 60px; 
54.
	line-height: 60px; 
55.
	text-align: center; 
56.
	text-decoration: none; 
57.
	color: #333; 
58.
	border: 1px solid #CCC; 
59.
	border-radius: 15px; 
60.
61.
 
Ersetze das mal und versuchs im Chrome noch mal. Im Opera, IE, FF gehts

Gruß
Bitte warten ..
Mitglied: m.reeger
28.11.2013 um 14:29 Uhr
@Xaero1982
Daumen Hoch!
Tausend Dank!!!!!
Endlich passt es ^^


Wie immer einmal schnell eine Lösung gefunden
Bitte warten ..
Mitglied: Xaero1982
28.11.2013, aktualisiert um 14:34 Uhr
Schön, habs gesehen

Na dann frohes Basteln noch.

Ums kurz zu erklären: Opera&Co. beachten da wohl eine gewisse Hierarchie - deswegen im ersten: Table dann table-row und dann table-cell.

Gruß
Bitte warten ..
Ähnliche Inhalte
Apple
gelöst Eigene website (32)

Frage von Maralind zum Thema Apple ...

SEO
Falscher Website Titel bei Google (4)

Frage von Yanmai zum Thema SEO ...

Webentwicklung
Suche Website für Fotogalerien! (5)

Frage von Interception zum Thema Webentwicklung ...

Netzwerke
gelöst Manche Websites nicht erreichbar (9)

Frage von cyber40014 zum Thema Netzwerke ...

Neue Wissensbeiträge
Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(8)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

Information von BassFishFox zum Thema Datenschutz ...

Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Utilities

CCleaner 5.33 mit Malware infiziert

(27)

Information von SeaStorm zum Thema Utilities ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (27)

Information von SeaStorm zum Thema Utilities ...

Festplatten, SSD, Raid
gelöst Problem mit DELL 815R Server und Windows Bluescreen (24)

Frage von Leo-le zum Thema Festplatten, SSD, Raid ...

Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

Windows Netzwerk
Dateien mit Intelligenz per GPO ins Programmverzeichnis (14)

Frage von erwin.t zum Thema Windows Netzwerk ...