Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Dateizugriff nach Migration sehr langsam

Frage Microsoft Windows Server

Mitglied: Badger

Badger (Level 2) - Jetzt verbinden

10.07.2012 um 11:25 Uhr, 6676 Aufrufe, 11 Kommentare

Hallo Leute,

ich bräuchte bitte wieder eure Hilfe.

Und zwar habe ich einen Windows SBS 2003 auf SBS 2011 (2008 R2) migriert. Das ganze ging auch relativ problemlos.
Nachdem nun alles auf dem neuen Server ist, habe ich den "Alten" abgedreht.
Nun habe ich aber das Problem, dass sämtliche Dateizugriffe sehr, sehr langsam gehen. So dauert z.B. das öffnen eines Word-Dokumentes einige Minuten.
Sobald ich den Alten wieder einschalte läuft alles problemlos.

Ich habe mir nun schon die DNS-Einträge angeschaut. Hier konnte ich keine Verweise mehr auf den alten Server finden. Auch der DHCP-Server verteilt die richtige IP-Adresse des DNS-Servers.
Die Dateien die ich öffne sind auch alle auf die IP des neuen Servers verknüpft.
Der Best Practicies Analyzer findet auch keinen Fehler.
Und leider werde ich bei Google auch nicht wirklich schlauer.


Hat wer noch eine Idee für mich, wo der Hund begraben sein könnte?
Bin für jede Hilfe dankbar!


Zur Info: Die Migration erfolgte exakt nach der Anleitung von Microsoft.


Mit freundlichen Grüßen
Patrick
Mitglied: MrNetman
10.07.2012 um 11:36 Uhr
Hi Badger,

schau in den Vorlagen der Word-Dokumente nach. Word speichert in den Dokumenten auch die Servernamen und wenn es den Server nicht gibt, dann wartet es eben auf ein Timeout des DNS und das geht nach allen korrekten Regeln eben etwas länger.

Gruß
Netman
Bitte warten ..
Mitglied: Badger
10.07.2012 um 11:54 Uhr
Hallo Netman,

danke für deine Antwort.
Habe im Word unter Vorlagen nachgeschaut. Da ist zwar bei einigen eine alte Vorlage hinterlegt. Dies behebt aber leider das Problem nicht.

Betroffen sind davon auch alle Dateiformate. Ich habe das Word-Dokument hier nur als Beispiel angegeben.


Mit freundlichen Grüßen
Patrick
Bitte warten ..
Mitglied: MrNetman
10.07.2012 um 12:13 Uhr
Alle Office-Applikationen speichern in ihrem jeweiligen Endergebniss den kompletten Pfad der Vorlage mit ab. Selbst welche, die nur aus einem andern Dokument mit Veränderungen entstanden sind.
Bitte warten ..
Mitglied: Badger
10.07.2012 um 12:45 Uhr
Also bei mir siehts unter Vorlagen so aus:
http://www.file-upload.net/download-4534176/Vorlage.PNG.html

Das sollte doch passen, oder?

Aber es betrifft nicht nur Office-Datein sonden auch pdf, txt, exe,...


Mit freundlichen Grüßen
Bitte warten ..
Mitglied: MrNetman
10.07.2012 um 13:23 Uhr
ok, in den Dokumenten steht so was, in txt definitiv nicht.
Dann lass beim Dateiaufruf mal den Wireshark mitlaufen. (lokal auf dem PC)
Dann kannst du erkennen welche Server angefragt werden.

Gruß
Netman
Bitte warten ..
Mitglied: Badger
10.07.2012 um 18:22 Uhr
Danke für den Tipp.
Hab den Wireshark jetzt auf ein paar Clients laufen lassen. Als Destination scheint nirgends die IP des alten Servers auf.
Folgendes ist aber auffällig:
Bei XP-Maschinen scheint so gut wie bei fast jedem Serverzugriff folgender Fehler auf:
>Transmission Control Protocol, Src Port: mpnjsocl (2685), Dst Port: netbios-ssn (139), Seq: 1160794, Ack: 23985642, Len: 80
>Checksum: 0xa028 [incorrect, should be 0xf019 (maybe caused by "TCP checksum offload"?)]

Bei Win7-Maschinen nicht (Auch wenn wenn sie am gleichen Port am Switch hängen wie zuvor die XP-Maschine!).


Prinzipiell ist mir nun auch noch aufgefallen, dass Win7 Clients vom langsamen Zugriff nicht betroffen sind. Es scheint als wären es "nur" die Win XP Clients (bin da etwas spät drauf gekommen, da wir nur wenige Win7 Clients haben).
Bitte warten ..
Mitglied: Cthluhu
10.07.2012 um 19:20 Uhr
Hi,

Schau mal in der Netzwerkumgebung bei den XP-Clients nach ob da noch Verknüpfungen zu alten freigaben am alten Server aufscheinen. XP legt die Verknüpfungen automatisch an. Bei Operationen wie "Datei-Öffnen" oder "Speichern-Unter" werden diese Verknüpfungen des öfteren gepollt, ob die noch da sind. Wenn nicht, gibts timeouts im Minutenbereich.

Abhilfe: alle alten Verknüpfungen aus der Netzwerkumgebung raus. Hat zumindest bei mir schon des öfteren geholfen.

Mit freundlichen Grüßen

Cthluhu
Bitte warten ..
Mitglied: Badger
10.07.2012 um 19:39 Uhr
Hallo Cthluhu,

Danke für deinen Tipp. Es waren einige alte Verknüpfungen vorhanden. Habe diese gelöscht. Leider brachte dies aber nicht gewünschten Erfolg.
Es ist schön langsam etwas komisch das ganze. Mittlerweile dauert ein Rechtsklick auf eine Datei eine halbe Ewigkeit.

Kann sich wer die Fehler vom Wireshark erklären? Bzw. hat wer diesbezüglich eine Abhilfe für mich?


Danke
Patrick
Bitte warten ..
Mitglied: MrNetman
10.07.2012 um 23:29 Uhr
"TCP checksum offload" ist eine Einstellung im Treiber von NICs.
Wird verwendet um die CPU, respektive den TCP-Stack zu entlasten.
Wird die Meldung bei Paketen vom Server generiert?
Dann ist dort diese Funktion wieder zu aktivieren.
Manche Beschleunigungsfunktionen der Hardware vertragen sich nicht untereinander und sollten nur mit bestimmten Gegenstellen genutzt werden.
Wobei das Zitat oben eine Mutmaßung ist. Der Fehler lautet Checksum incorrect.
Solche Pakete werden am Empfänger direk geerdet, respektive verworfen.
Der XP-und der W7-Stack unterscheiden sich stark. W7 mit den aktuellen Servern kann theoretisch schneller als XP mit 2003.

Außerdem kann man mit follow TCP-Stream ein schnelles Filter auf eines der Dokumente machen und dann sehen, wie lange es von der ersten Anforderung bis zum Abschluß des Dokumentes dauert und wie viele verworfene Pakete dabei mit im Spiel sind.

Gruß
Netman
Bitte warten ..
Mitglied: Badger
11.07.2012 um 08:44 Uhr
Guten Morgen,

nach einer kurzen Nacht kann ich nun sagen, dass das Problem behoben ist!

Aber mal von Anfang an:
Habe aufgrund des Fehlers vom Wireshark die Konfigs der Switches angeschaut. Da war bei einem ein falscher Gateway eingetragen. Habe daraufhin bei den XP-Clients die neueste Version vom Wireshark installiert (auf den Win7 war bereits eine Neue). Seither sind die Checksum-Erros weg. An was es da genau gelegen hat weiß ich nicht.

Habe dann bei laufenden alten Server und laufenden Wireshark ein paar Datein vom Server abgerufen. Habe da dann gesehen, dass hier immer wieder einige Zugriffe zum alten Server sind. U.A. zum alten Userhome. Nachdem dies aber nirgends mehr eingetragen war habe ich daraufhin den Userprofil-Ordner am Client gelöscht. Und siehe da: alles geht!

Bin jetzt gerade dabei auf allen Clients die Profilordner zu löschen. Bei den Clients wo ich es schon gemacht habe funktioniert es daraufhin überall.

Ein großes, großes DANKE an alle! Mein Urlaubsantritt morgen ist gerettet


Was anderes noch (passt zwar nicht zum Thema aber vlt. hat trotzdem wer eine Idee):
Kann es sein das nach der Installation vom Microsoft File Validation es Probleme mit Excel-Datein mit vielen Makros gibt? Diese brauchen nämlich tlw. sehr lange zum öffnen. Bei Datein ohne Makros geht alles super.


Mit freundlichen Grüßen
Patrick
Bitte warten ..
Mitglied: eazy-isi
12.07.2012 um 06:41 Uhr
Guten Morgen Patrick,

zu Thema "File Validation Tool" und Perfomance beim öffnen Sollte dir die Suche im Forum massenhaft Ergebnisse liefern.

Ich würde es einfach deinstallieren und fertig:

//Uninstall File Validation Tool MsiExec.exe /x {90140000-2005-0000-0000-0000000FF1CE}



Gruß
eazy_isi
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
Server sehr langsam bei vielen kleinen Dateien (5)

Frage von MichiBLNN zum Thema Windows Server ...

Exchange Server
Migration auf Exchange 2016 wegen Firmenübernahme (5)

Frage von IT666IT zum Thema Exchange Server ...

Festplatten, SSD, Raid
Samsung SSD zu langsam (20)

Frage von Protected zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (29)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...