Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Datenabgleich in Excel

Frage Microsoft Microsoft Office

Mitglied: TerenceHill1987

TerenceHill1987 (Level 1) - Jetzt verbinden

03.12.2008, aktualisiert 12:47 Uhr, 7546 Aufrufe, 3 Kommentare

Daten aus zwei Spalten abgleichen

Hallo Freunde,

ich hoffe mir kann einer helfen.

Ich habe folgendes Problem.

Ich habe zwei Spalten in Excel voll über 1000 Daten. Nun soll ich einen Abgleich starten, wobei der ersten Spalte die identischen Datensätze aus der zweiten Spalte dahinter zugeordnet werden. Wo es keine Zuordnung gibt, hätte ich gerne "Nicht vorhanden" in die Zelle geschrieben gehabt.

Ich würde mich freuen, wenn ich möglichst schnell eine Lösung

von einem von euch bekäme.

Mit freundlichen Grüßen

TerenceHill1987
Mitglied: user217
03.12.2008 um 10:00 Uhr
moin,
kannst du das bitte genauer formulieren?
Bitte warten ..
Mitglied: 25510
03.12.2008 um 10:20 Uhr
Hi,

maybe an alternative: diff file1 file2 > nicht.vorhanden.txt
wobei file1 = spalte1 und file2 = spalte2

mfg Tz
Bitte warten ..
Mitglied: bastla
03.12.2008 um 12:47 Uhr
Hallo TerenceHill1987!

Das sollte etwa so gehen (Annahme: Daten in A2:A1100 bzw B2:B1100, Formel in Spalte C ab C2 nach unten ausfüllen):
=WENN(ISTFEHLER(SVERWEIS(A2;$B$2:$B$1100;1;0));"Nicht vorhanden";"Ist da")
Wenn Du danach die Spalten A bis C markierst und nach Spalte C sortierst, werden alle Einträge in A, zu denen es in B keinen gleichen Eintrag gibt, am Ende der Liste gesammelt.

Da Du nicht näher beschreibst, was das eigentliche Ziel der ganzen Aktion ist, noch die vereinfachte Version:
=SVERWEIS(A2;$B$2:$B$1100;1;0)
Du erhältst so anstelle des Textes "Nicht vorhanden" die Excel-Fehlermeldung "#NV" und kannst dann ebenfalls sortieren.

Grüße
bastla
Bitte warten ..
Neuester Wissensbeitrag
Microsoft Office

MS Office Excel - Formel wird angezeigt, aber nicht berechneter Wert!

Tipp von holli.zimmi zum Thema Microsoft Office ...

Ähnliche Inhalte
VB for Applications
gelöst Zelle in Excel per Klick einfärben (5)

Frage von C.Mue83 zum Thema VB for Applications ...

Microsoft Office
gelöst 3 Excel Dateien, gleich umkodieren? (10)

Frage von Akeipra zum Thema Microsoft Office ...

Outlook & Mail
Outlook 2016 Excel Preview

Frage von ilsinger zum Thema Outlook & Mail ...

Heiß diskutierte Inhalte
Off Topic
Handy in Raten kauifen oder nicht? (19)

Frage von mirko123 zum Thema Off Topic ...

Exchange Server
gelöst MS Exchange 2016 - Basicconfig Fragen (16)

Frage von maddig zum Thema Exchange Server ...

Windows Server
gelöst Rechte als Admin vergeben - Zugriff verweigert (14)

Frage von Ghost108 zum Thema Windows Server ...