Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Datenbankprobleme nach Netzwerkumstellung...

Frage Microsoft

Mitglied: waldi26

waldi26 (Level 1) - Jetzt verbinden

25.05.2011 um 14:22 Uhr, 3395 Aufrufe, 8 Kommentare

Hallo,

vielleicht kann mir ja hier jemand helfen.

Folgende Situation: Bei einem Kunden wurde von Win2000 und XP Clients und einem "Win2000-Pro"- Server auf Win7 Pro 32bit und Win2008 R2 Server umgestellt. Auf dem Server sind nur die Dokumente und Dateien gespeichert, die Datenbank eines Handwerksprogramms liegt drauf und Tobit David.fx läuft drauf. Im Prinzip läuft alles relativ gut, nur das Handwerksprogramm macht Sorgen.

Lt. Hersteller wird eine ADS-Datenbank von Delphi / Sybase verwendet. Auf diese Datenbank wird von den 4 Clients über ein Netzlaufwerk zugegriffen.

1. Problem: Es kam nun schon mehrmals vor, daß ein Mitarbeiter ein Angebot o.ä. erfasst hat und dieses dann nachdem es geschlossen wurde entweder ganz weg war oder nur noch teilweise vorhanden war. Ein Angebot mit der gleichen Nummer lässt sich dann aber nicht mehr erstellen, da dann eine Fehlermeldung erscheint. Erst nach einer Datenbankreorganisation kann man das Angebot wieder neu erstellen.

2. Problem: Man möchte ein Angebot, Teillieferschein o.ä. z.B. ausdrucken oder abändern. Man klickt auf die entsprechende Schaltfläche. Nun erscheint der Windows 7 "Kringel" (ehemals Sanduhr) und nichts passiert. Am Server im Taskmananger sieht man, daß dann eine konstante Netzwerkauslastung von 3%. Schießt man dann den Prozess am Client ab, verschwindet diese "Auslastung" wieder.

3. Man erstellt z.B. ein Angebot und druckt dieses aus. Bereits in der Voransicht sieht man anstatt einer Artikelbeschreibung nur irgendwelchen Datenmüll (z.B. {\rtf1\ansi\ansicpg1252\deff0.....). Auch auf dem Ausdruck ist dies so. Geht man dann in das Angebot steht alles korrekt drin. Manchmal hilft es, wenn man den Artikel nur etwas abändert, manchmal muss man aber auch den Artikel löschen und neu erfassen.

4. Seit der Umstellung ist die Performance deutlich langsamer. Solange nur ein Benutzer das Programm offen hat, läuft es einigermaßen. Sobald ein zweiter User nur das Programm startet sonst aber noch nichts macht, dauert alles deutlich länger (mit 1 User dauert das Kopieren eines 5 Seiten Angebots etwa 10 Sekunden, mit einem zweiten User schon über eine Minute). Dies scheint aber ein Programmproblem zu sein, da ich die Datenbank testweise mal auf einem WinXP-Testrechner eingespielt habe (ohne


Ich weiß nicht mehr weiter. Der Hersteller sagt, es liegt nicht an seinem Programm. Er hat seine Datenbanken überprüft und keine Fehler gefunden. Ich hab inzwischen alle Rechner auf den aktuellsten Stand gebracht (Treiber, Windows), Netzwerkgeschwindigkeit gemessen (bei 100Mbit-Netz komme ich auf 75-85 Mbit bei der Messung). Auch den Switch hab ich testweise ersetzt. Testweise hab ich auch mal den Virenscanner deinstalliert und durch einen anderen ersetzt. Das SMB-Signing hab ich per GPO auf die vielfach genannte "Best-Practice" gesetzt. Wie gesagt, sonst passiert nichts auffälliges. Die Netzwerkkarten in den Rechnern sind onboard Karten mit Intel Chip.



Der Kunde wird veständlicherweise inzwischen etwas sauer. Hat jemand eine Idee was ich noch machen könnte? Kann es sein, daß bei Windows 7 die Netzwerkverbindung mit der Zeit "einschläft" und dadurch diese Probleme auftreten?


Ich freue mich auf eure Tipps und Antworten!


Grüße
waldi26
Mitglied: 100192
25.05.2011 um 14:27 Uhr
was ist wenn du die Firewall auf dem Server und Clients Ausschaltest ?
Bitte warten ..
Mitglied: waldi26
25.05.2011 um 14:37 Uhr
Hallo,

Firewall und UAC sowohl am Server und den Clients ist aus.


Grüße
Bitte warten ..
Mitglied: 100192
25.05.2011 um 14:53 Uhr
in welchen Ordner ist das Programm unter Windows 7 Installiert?

versuche mal, wenn’s geht das Programm Client seitig direkt unter c:\xxx zu Installieren.

so wie es ausschaut ist es ein Kommunikationsproblem zwischen Datenbank und Client.
Unter win7 sind die Ordner " Programme und Programme x86 besonders geschützt - ich kann mir vorstellen das es dort zu Kommunikationsschwierigkeit kommt.

Hat der Software Hersteller freigebe für win 7 ?
Bitte warten ..
Mitglied: Arch-Stanton
25.05.2011 um 14:58 Uhr
Habt Ihr die Systemaktualisierung in Absprache mit dem Softwarehersteller durchgeführt? Vielfach ist Branchensoftware auf das Zusammenspiel zwischen Betriebssystem und Softwarestand optimiert, d. h. eine aktuelles Windows unterstützt evtl. die Datenbanktreiber nicht mehr, etc.

Gruß, Arch Stanton
Bitte warten ..
Mitglied: kegel1965
25.05.2011 um 15:07 Uhr
Hallo waldi26,

wie ist denn der Name des Handwerksprogramm? Möglicherweise hat der eine oder andere das schon mal gesehen.

"Kann es sein, daß bei Windows 7 die Netzwerkverbindung mit der Zeit "einschläft" und dadurch diese Probleme auftreten?"

Es gab da mal den Parameter "autodisconnect" bei WinXP. Ob es den noch unter WIN7 gibt?

Ich hatte mal so ein Problem in der Kombination: Novellserver und WinXP, Netzwerkverbindung nach 15 Minuten unterbrochen. Windowsanwendungen wie Word, Excel hatten mit der Neuverbindung keine Probleme. Die damals eingesetzte DOS-Software mit dBase-Datenbanken schon.

Das mit dem "autodisconnect" brachte aber auch nicht die Lösung.

Die Lösung damals war ein kleines Batch mit "Netzlaufwerk dir>nul" im Taskplaner alle 5-Minuten.

Gruß

kegel1965
Bitte warten ..
Mitglied: GuentherH
25.05.2011 um 17:37 Uhr
Hallo.

nur das Handwerksprogramm macht Sorgen

Ist den das Programm vom Hersteller für W2008R2 und 64 BIT freigegeben?

LG Günther
Bitte warten ..
Mitglied: waldi26
25.05.2011 um 18:28 Uhr
Hallo,
danke schon mal für eure Antworten.

@100192
Das Programm ist auf den Clients unter C:\xxx installiert. Das hat der Softwareanbieter schon vor dem Umzug erwähnt. Ich vermute eben auch, daß es während der Arbeit zu einem Kommunikationsproblem zwischen Server und Clients kommt. Aber wo kann ich noch ansetzen?

@Arch Stanton
Der Softwareanbieter hatte keinerlei Einwände gegen die Aktualisierung.

@kegel1965
Der Name des Programms fällt mir momentan nicht ein . Ist ein Programm fürs Fliesenhandwerk.

@Günther
Lt. Sofwareanbieter soll es unter Server2008 R2 64bit kein Problem geben.


Wie kann ich denn überprüfen, ob die GPO fürs SMB-Signing auch korrekt angewendet wurde? Lt. gpresult /r wird die entsprechende Gruppenrichtlinie angewendet.


Vielleicht hat ja jemand noch eine Idee...


Grüße
waldi26
Bitte warten ..
Mitglied: G.Wallenstein
25.05.2011 um 20:49 Uhr
Hallo,

hört sich für mich nach Datenbank Problem an.
Der Server hat doch bestimmt ein Log oder ähnliches, evtl. sogar Tools um die Datenbank zu prüfen.

http://www.sybase.de/products/databasemanagement/advantagedatabaseserve ...

oder ist es vielleicht Interbase?

Gruß
Günter
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Drucker und Scanner
gelöst Toshiba e403 scannt nichtmehr in Laufwerk nach Netzwerkumstellung (18)

Frage von iAmbricksta zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...