Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Datenherkunft per vba im Unterformular ein- und ausstellen Laufzeitfehler 3211

Frage Entwicklung VB for Applications

Mitglied: bumbum

bumbum (Level 1) - Jetzt verbinden

07.01.2010, aktualisiert 14:54 Uhr, 11398 Aufrufe, 4 Kommentare

Hallo zusammen,
ich habe in Access ein Hauptformular(frm_Hauptformular) mit einem Unterformular(frm_Unterformular). In dem Unterformular ist ein Button, der das Formular frm_Saisonkurve_suche öffnen soll. In diesem Formular kann man einen Datensatz mit einem Doppelklick aus einem Listenfeld auswählen.
Beim Doppelklick wird folgender Code ausgeführt:

Forms!frm_Unterformular!frm_Unterformular.RecordSource = ""
DoCmd.RunSQL ("delete * from tbl_TEMP_Saisonkurve")
DoCmd.OpenQuery "TEAbf_TempSK" --> Tabellenerstellungsabfrage(erstellt die Tabelle tbl_TEMP_Saisonkurve)
Forms!frm_Unterformular.RecordSource = "tbl_TEMP_Saisonkurve"
Forms!frm_Unterformular.Refresh

Mein Problem:

Es erscheint immer der "Laufzeitfehler 3211" und ich habe auch in anderen Foren geschaut aber keine Lösung gefunden, auch die Hilfe war nicht sehr hilfreich,
aber da mir hier schon oft geholfen wurde wende ich mich an euch.

LG BumBum
Mitglied: dog
07.01.2010 um 16:07 Uhr
DoCmd.RunSQL ("delete * from tbl_TEMP_Saisonkurve")

Ein Stern in einem DELETE Statement ist AFAIK Fehl am Platze.

http://www.devguru.com/technologies/t-sql/7122.asp
Bitte warten ..
Mitglied: bumbum
08.01.2010 um 07:23 Uhr
Hallo dog,
erstmal danke, ich habe es geändert. Doch jetzt kommt die nächste Fehlermeldung (Laufzeitfehler 2450: Microsoft Office Access kann das Formular 'frmUnterformular' nicht finden, auf das in einem Makroausdruck oder in einer Virtual Basic- Programmzeile verwiesen wird.)
Die Markierung für den Fehler ist auf der folgenden Zeile:

Forms!frm_Unterformular!frm_Unterformular.RecordSource = ""

Dazu ist zu sagen, wenn ich nur das Unterformular öffne, dann den Button klicke, der das Formular frm_Saisonkurve_suche öffnet und den Datensatz per Doppelklick auswähle, dann funktioniert alles alles ohne Probleme.

lg bumbum
Bitte warten ..
Mitglied: Pjordorf
08.01.2010 um 07:41 Uhr
Hallo bumbum,

du bist sicher, das das hier "Forms!frm_Unterformular!frm_Unterformular.RecordSource =" so richtig ist?

Peter
Bitte warten ..
Mitglied: bumbum
08.01.2010 um 08:51 Uhr
Hallo, tut mir leid, das ist natürlich ein Fehler, der Zeile steht oben auch schon Falsch.

"Forms!frm_Unterformular!.RecordSource ="

bumbum
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Excel VBA In Userform Maske Text nach Eingabe löschen (1)

Frage von kluthi69 zum Thema Microsoft Office ...

Datenbanken
gelöst Access 2010 UnterFormular filtern bzw. aktualisieren (2)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

VB for Applications
gelöst VBA Macro Hilfe benötigt (6)

Frage von reissaus73 zum Thema VB for Applications ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (15)

Frage von Static zum Thema CMS ...

RedHat, CentOS, Fedora
Fedora, RedHat, Centos: DNS-Search Domain setzen (13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...