Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Dauerproblem Windows-Explorer (Win 8.1, x64) hängt

Frage Microsoft Windows 8

Mitglied: krahujec

krahujec (Level 1) - Jetzt verbinden

24.02.2015 um 08:58 Uhr, 4278 Aufrufe, 13 Kommentare

Dauerproblem mit Windows-Explorer unter Win 8.1, x64 auf neuem Acer-Notebook.
Symptomatik:
Sehr oft, manchmal sofort, spätestens nach einem halben Dutzend Operationen mit dem Explorer (oder auch "Dieser PC") hängt der Explorer: Sanduhr, keine Annahme von Befehlen mehr ("Außenrum" läuft der Rechner aber weiter.)
Nur Abschuss mit Taskmanager hilft, manchmal auch nur Neustart bzw. "Neuanmelden" des Systems! (Dann tritt das gleiche Symptom aber oft sofort wieder auf.)
Besonders kritisch scheinen zu sein: Spaltensortierung, Kontextmenü (Maustaste 2 emuliert durch Touchpad, rechts unten), aber auch andere einfache Dateiverwaltungs- bzw. Anzeigeoperationen.
Es kommt vor, dass Verzeichnisinhalt erst gar nicht angezeigt wird, sondern scheinbar leer ist.
Verzeichnisse mit bes. vielen Dateieinträgen hängen viel wahrscheinlicher, vor allem mit Maustaste 2.
Typisch dabei: sehr häufige "ewige grüne Balken", also Suchvorgänge, die man zwar abbrechen kann, wobei man dann aber trotzdem mit der Sanduhr konfrontiert wird, die auch nach vielen Minuten nicht verschwindet; ggf. betrifft die Sanduhr nur Teile des Explorer-Fensters, z.B. die linke Spalte mit den Verzeichnishierarchien.

Das Ganze steht wahrscheinlich in Verbindung mit einem weiteren häufigen Symptom:
Fehlermeldungen "COM Surrogate funktioniert nicht mehr". Dllhost.exe? Habe irgendwo gelesen, dass COM Surrogate nur ein "Opferprozess" sei, der zur Vermeidung eines vollständigen Systemabsturzes als Prozess gekillt wird... (?).
Aber die Meldung ist nicht immer assoziiert mit sofortigem Explorer-Einfrieren.

Alle Treiber im System sind aktuell. Hardware ist neu, d.h. Notebook Acer ist ca. 6 Monate alt.
Habe den Verdacht, dass es irgendwo einen Arbeitsspeichermangel, -leck oder -defekt in der
betriebssystem-internen Verwaltung gibt, wenn übliche Explorerfunktionen laufen.
Das System hat 4 GB RAM und auf der Festplatte ist sehr viel Platz, weshalb ich Massenspeicherprobleme ausschließen möchte.

Ach ja, von der reichlich mitgelieferten Acer-Software habe ich einen Großteil deinstalliert,
den Rest verwende ich praktisch nicht.

Kennt jemand das Phänomen oder hat gar eine Lösung?
Danke im voraus.
Mitglied: keine-ahnung
24.02.2015 um 09:19 Uhr
Auch keine Begrüssung!
hat gar eine Lösung?
Neues und sauberes OS aufsetzen ...
Bitte warten ..
Mitglied: krahujec
24.02.2015 um 09:28 Uhr
Ach nee, so war das nicht gemeint. Guten Morgen!
Aber es müsste doch noch was anderes geben als neu aufsetzen?
Bitte warten ..
Mitglied: goscho
24.02.2015 um 09:30 Uhr
Moin,
AV schon deinstalliert bzw. Defender deaktiviert und dann getestet?
Vorschaufunktion im Explorer an oder andere Programme/Tools, die Kontextmenüeinträge im Explorer haben?
Bitte warten ..
Mitglied: krahujec
24.02.2015 um 10:12 Uhr
AV schon deinstalliert bzw. Defender deaktiviert und dann getestet?
Vorschaufunktion im Explorer an oder andere Programme/Tools, die Kontextmenüeinträge im Explorer haben?

Danke... Zwischenergebnis:
Beide Windows Defender-Dienste seit Beginn abgestellt.
Ferner zu AV bwz. Sicherheitssoft mit Autostarts:
- Avira. läuft normal...
- EMET 5.1: mit "recommended settings". Explorer nicht unter Applications eingetragen (aber IEXPLORE.exe)
- GDATA USB Keyboard Guard: sagt nichts, ist auch erst später dazu gekommen.
- Explorer-Einstellungen: keine Vorschaufunktion. Und Kontextmenü (auf Dateiebene):
nur das Acer-mitgelieferte Pokki-Menü (das ich auch nicht benutze): muss ich noch testen...
sonst dort: Classic Shell, Avira, VLC, Winamp, Irfanview

Forsche weiter... weitere Ideen willkommen!
Bitte warten ..
Mitglied: Pjordorf
24.02.2015 um 10:39 Uhr
Hallo,

Zitat von krahujec:
Es kommt vor, dass Verzeichnisinhalt erst gar nicht angezeigt wird
Was sagt ein CHKDSK c: /F? Fehlerfrei und schnell oder extrem langsam?

Gruß,
Peter
Bitte warten ..
Mitglied: kontext
25.02.2015 um 08:07 Uhr
Zitat von Pjordorf:
Was sagt ein CHKDSK c: /F? Fehlerfrei und schnell oder extrem langsam?

Nicht zu vergessen - was sagt sfc /scannow ...
... tritt das Problem im abgesicherten Modus auch auf ?!

Gruß
kontext
Bitte warten ..
Mitglied: tomolpi
25.02.2015 um 18:58 Uhr
Hallo,

Festplatte schon defragmentiert? Schau doch mal, wieviel Prozent die defragmentiert ist und lass das mal über nach "optimieren" so heißt das. Bei ned SSD nicht machen!

Gruß tomolpi
Bitte warten ..
Mitglied: Pjordorf
25.02.2015 um 20:17 Uhr
Hallo,

Zitat von tomolpi:
Festplatte schon defragmentiert?
Dir ist schon klar das dem TO sein OS (Win 8.1) selbsttätig im Hintergrund Defragmentiert? Und wenn sein Notebook nach 6 Monaten dermaßen stark Fragmentiert sein sollte das dies die Ursache wäre, dann ist etwas ganz falsch ...

Gruß,
Peter
Bitte warten ..
Mitglied: tomolpi
25.02.2015 um 20:55 Uhr
Bei mir am Win8 hat er das nur während der automatischen Wartung gemacht. Wenn die von Energiesparplänen ausgemacht wird... Oder abgebrochen wird...
Bitte warten ..
Mitglied: krahujec
26.02.2015 um 18:59 Uhr
[Hab wohl den Eintrag hier erst mal verloren; 2. Versuch ]

LÖSUNG GEFUNDEN:
An alle, die mit Tipps und Vermutungen geholfen haben: Vielen Dank, ich habe das Meiste probiert und keine wesentlichen Fehler gefunden.

Jetzt hab ich aber die Lösung: Eher zufällig bin ich darauf gestoßen...
"Systemeinstellungen" - "Ordneroptionen" - "Ansicht":
In der Liste den Haken entfernt bei: "Ordnerfenster in eigenem Prozess starten"...
(Das als Fazit, z.B. für die "Lösungsdatenbank"?)

Mein Gott, kann es das sein? Wie ist der Haken denn dahin gekommen?
Also ausgerechnet etwas, das ich "im eineinhalbten Schritt" jeder Windowsinstallation abstelle,
war hier aktiv und hat wohl alle diese Symptome verursacht!
Vermute ich richtig, dass die Option nur sinnvoll wird, wenn sehr viel RAM zur Verfügung steht?)

Und noch zu SFC /SCANNOW - (nach "einiger Zeit ...", haha; ca. 1 Stunde):
ein Riesenprotokoll CBS.LOG. Leider kapiere ich nix.
Schlussmeldung: "... beschädigte Dateien, von denen einige nicht repariert werden konnten... "
Bin leider blank damit.

Dazu noch eine off-topic-Nebenfrage:
warum läuft dieses SFC /SCANNOW eigentlich niemals nicht auf Win-7?? Irgendwo wurde da bei mir immer abgebrochen...
Bitte warten ..
Mitglied: tomolpi
26.02.2015, aktualisiert um 20:59 Uhr
Ich kanns heute Nacht mal ausprobieren, habe noch nen Win7 Client hier...

tomolpi
Bitte warten ..
Mitglied: Pjordorf
26.02.2015 um 23:47 Uhr
Hallo,

Zitat von krahujec:
In der Liste den Haken entfernt bei: "Ordnerfenster in eigenem Prozess starten"...
Dann ist dein 4GB System kein 4 GB System oder du hast wie viele Hundert Fenster geöffnet? Hatte damit bisher noch nie ein Problem. Und selbst MS schreibt dazu
Erhöhen der Stabilität von Windows, indem jeder Ordner in einem eigenen Bereich des Arbeitsspeichers geöffnet wird. Verwenden Sie diese Einstellung, wenn der Computer häufiger abstürzt und Sie die Auftrittshäufigkeit von Problemen verringern oder Probleme beheben möchten. Beachten Sie jedoch, dass sich dieser Schritt nachteilig auf die Computerleistung auswirken kann.
gefunden hier http://windows.microsoft.com/de-de/windows7/change-folder-options

Eine sehr sehr langsame CPU welche da ihren Dienst versieht? Dein Problem ist anscheinend auch hier beschrieben, wobei dort der Übeltäter nämlich die Vorschau klar erwähnt wird. Nutzt du dort die Vorschau intensiv in allen deinen zigfach geöffneten Explorer Fenster bzw. Prozesse? http://www.pcwelt.de/tipps/Windows-XP-Vista-7-Sicheres-Explorer-Fenster ...

Dann macht dein Fehlerbild und deine Behebung schon eher sinn

Gruß,
Peter
Bitte warten ..
Mitglied: krahujec
27.02.2015 um 09:04 Uhr
Dann ist dein 4GB System kein 4 GB System oder du hast wie viele Hundert Fenster geöffnet? Hatte
damit bisher noch nie ein Problem. Und selbst MS

Ich kann Deine Logik nicht nachvollziehen:
Woher weißt Du, dass ich keine 4GB RAM habe, wenn ich das so angegeben habe? Oder ziehst Du einfach unbegründete Schlussfolgerungen? Du solltest mir schon glauben, dass hier 4GB RAM sind.

Woher weißt Du, "wie viele Hundert Fenster" ich geöffnet habe?
Ich verrate Dir, dass ohne besondere Hintergrundprogramme meist schon eine einzige Explorer-Ordner-Anzeige wie beschrieben diese Symptomatik entwickelt hat. Es dürften kaum jemals mehr als zwei oder maximal drei gewesen sein... Und es ist doch klar, dass man in solchen Fällen zuerst schaut, ob sich da irgendwas beißt.

Wie kannst Du von Dir auf mich "schließen"? Der Satz klingt wie "'Hier hat sich bis jetzt noch niemand beschwert."
Es ist aber ohne Zweifel eine Information, wenn andere unter vergleichbaren Bedingungen (?ich weiß gar nichts über Deine Bedingungen) etwas anderes erfahren, aber das lässt den Schluss nicht zu, ich sei dann irgendwie unglaubwürdig, wie Du zwischen den Zeilen mehrfach "insinuierst".
Unabhängig davon, dass ich jedem dankbar bin, der versucht zu helfen: Bitte nicht verdächtigen, wenn sonst "die Theorie nicht passt". (Auf einfache Fragen antworte ich natürlich gerne.)

Selbst MS...:
In dem hier zitierten Text (Link) empfiehlt MS diese Option zu verwenden, DAMIT Stabilität erhöht wird (Das hat mich unter geg. Umständen überrascht). Meine Beschreibung und Erfahrung zeigt, dass genau diese Option es war, die das GEGENTEIL bewirkt hat - und dass dann gerade ihre Entfernung Stabilität wieder hergestellt hat.
Das Argument ist also keines, sondern gehört zum umgekehrten Fall, der hier nicht vorlag.

Eine sehr sehr langsame CPU welche da ihren Dienst versieht?
Nun, die 1,9 MHz sind nicht viel, das ist kein schnelles Notebook. Um genau zu sein: Intel Core i3-4030U. Ob das aber zur Erklärung reicht? (und das auch nur, wenn Du das mit Deinen anderen Vermutungen, die Du wie Tatsachen behandelst, kombinierst)

Dein Problem ist anscheinend auch hier beschrieben, wobei dort der Übeltäter nämlich die Vorschau > klar erwähnt wird. Nutzt du dort die Vorschau intensiv in allen deinen zigfach geöffneten Explorer
Fenster bzw. Prozesse?
Das hatte ich in Antwort auf goscho bereits erklärt: Eine Vorschau verwende ich nie.
Dass in der Quelle "klar erwähnt wird", setzt noch mal voraus, dass Du Deine Frage schon selber mit ja beantwortet hast. Ist aber nicht so.

Warum gehst Du schon wieder davon aus, dass Deine Annahme mit den "zigfach"-Fenstern zutrifft.? Weil Dein PC-Welt-Link diesen Fall behandelt, muss das hier auch der Fall sein?

Dann macht dein Fehlerbild und deine Behebung schon eher sinn
Wir suchen alle Sinn, aber wenn die Voraussetzungen nicht stimmen, müssen wir eventuell feststellen, dass der Sinn einfach nicht da ist.

Und:
Ich stoße bei den Links, die Du angibst, auf den Widerspruch, dass diese Texte genau den umgekehrten Fall behandeln: die Option soll die Symptomatik beheben, nicht erzeugen.
Hier war die Symptomatik MIT dieser (unerkannten) Option vorhanden und sie verschwand mit dem Abschalten der Option!!
Man könnte also sagen: Umgekehrt wird KEIN Schuh daraus.

Praktisch wichtig ist für mich natürlich, dass das Problem gelöst ist.
Worin besteht also die Funktion unseres "Nachkartens"?
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
Windows Explorer hängt sich bei Powershell Script auf (5)

Frage von zamsi7 zum Thema Batch & Shell ...

Windows Server
gelöst Windows-Explorer funktioniert nicht mehr Windows Server 2008 R2 (4)

Frage von Zeus0815 zum Thema Windows Server ...

Windows 7
Windows-Explorer stürzt ab (2)

Frage von achklein zum Thema Windows 7 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...