Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Debian / Cups / HP4050TN

Frage Linux Debian

Mitglied: domcom

domcom (Level 1) - Jetzt verbinden

31.10.2006, aktualisiert 01.11.2006, 4211 Aufrufe, 2 Kommentare

... druckt keine Files, die einen Umlaut im Namen haben ....

Hi,

Bin langsam etwas am verzweifeln, Hilfe und Hinweise werden sehr geschätzt!

Vorraussetzungen:

*Server mit Debian 2.6.17.6 + Cups V1.2.5
*Zwei Netzwerkdrucker, über Cups auf den WindowsXP-Clients eingerichtet:
      • HP 4050TN
      • OKI C5300


Situation:
  • Drucken auf den HP funktioniert nicht, sobald ein File gedruckt werden soll, dessen Name einen Umlaut enthält - der Druckjob wird einfach angehalten.
  • Das gleiche File lässt sich problemlos auf dem OKI ausgeben.
  • Das gleiche File lässt sich problemlos über ip/ipp/port (direkt) ausdrucken
  • Ebenso lässt sich dasselbe File drucken, sobald der Name des Files keinen Umlaut enthält.
  • Umlaute im Text werden tadellos gedruckt!?

Charset- und DefaultLanguage-Einträge sind gemacht und korrekt.

Hier ein kleiner Auszug aus dem Error-Log:

[Job 1445] Print file was not accepted (client-error-bad-request)!
PID 11292 (/usr/lib/cups/backend/http) stopped with status 1!

Irritieren tut mich auch der folgende US-ASCII-Eintrag, keine Ahnung woher der kommt, habe ihn weder in mime.types noch .conf gefunden:

>>document-format-supported (5 values)
D [31/Oct/2006:18:38:08 +0100] [0] = "text/plain"
D [31/Oct/2006:18:38:08 +0100] [1] = "text/plain; charset=US-ASCII"
D [31/Oct/2006:18:38:08 +0100] [2] = "application/postscript"
D [31/Oct/2006:18:38:08 +0100] [3] = "application/vnd.hp-PCL"
D [31/Oct/2006:18:38:08 +0100] [4] = "application/octet-stream"

Ich vermute einen Zusammenhang mit dem Job-Name, der - im Gegensatz zum OKI - den File-Namen im Klartext anzeigt. Filter basteln scheint eine Option zu sein, hab davon aber weder Ahnung im Detail noch scheint mir das eine elegante Lösung zu sein...

Schon mal Danke für jeden Hinweis!

D|O|M|C|O|M
Mitglied: 18697
01.11.2006 um 18:04 Uhr
Wurde Samba und Cups korrekt eingerichtet? Siehe auch:
http://wiki.bsdforen.de/index.php/FreeBSD_-_Drucken_in_heterogener_Umge ...
Bitte warten ..
Mitglied: domcom
01.11.2006 um 18:19 Uhr
Hi Andreas,

Danke für den Link, ich schaus mir gerne an, vielleicht finde ich ja einen Anhaltspunkt. Aber offengestanden glaube ich nicht an ein grundsätzliches Setup-Problem, dafür ist der Fehler zu spezifisch und tritt nur in einer ganz bestimmten und auch jederzeit nachvollziehbaren Situation auf (Umlaut im Datei-Namen).

Das PPD ist übrigens ein Original von HP.

Ebenfalls dagegen spricht, dass wir ansonsten im ganzen Netz diverse Dienste laufen lassen (neben Web-/Mail-/File-/CVS-Server noch ein Intranet etc) nirgends jedoch Probleme mit locales oder mime-types haben...ganz allgemein gesprochen funktionieren sonst alle Serverdienste zufriedenstellend.

D|O|M|C|O|M
Bitte warten ..
Ähnliche Inhalte
Apache Server
gelöst Debian CPU Auslastung durch Apache2 sehr hoch (12)

Frage von zeroblue2005 zum Thema Apache Server ...

Hyper-V
Hyper-V 2016 Debian 8 VM frisst Speicherplatz (2)

Frage von m.reeger zum Thema Hyper-V ...

Apache Server
gelöst Apache 2 Debian Zertifikat von GeoTrust installieren (3)

Frage von zeroblue2005 zum Thema Apache Server ...

Neue Wissensbeiträge
Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
VPN Tunnel aufbauen (16)

Frage von Hajo2006 zum Thema LAN, WAN, Wireless ...

Microsoft Office
Saubere HTML aus Word-Dokument (14)

Frage von peterpa zum Thema Microsoft Office ...

Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (14)

Frage von marshall75000 zum Thema Router & Routing ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...