Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Defekte Platte in Linux austauschen

Frage Linux

Mitglied: winlin

winlin (Level 2) - Jetzt verbinden

09.09.2011 um 11:08 Uhr, 3219 Aufrufe, 5 Kommentare

Red Hat EL 5
300GB Datenplatte defekt und soll ausgestauscht werden

Hallo Leute,

ich habe drei Festplatten in meinem Lnux Rechner. Eine Datenplatte also die sdb ist defekt und diese möchte ich nun 1 zu 1 austauschen. Die sdb war noch in zwei Bereich partiotioniert die ich mit folgenden Befehlen einrichten wollte nachdem ich nun die defekte Platte ausgebaut und die neue eingebaut hatte. Zuvor habe ich noch in der fstab die beiden Partitionen von der sdb auskommentiert.

Nachdem ich nun gestartet habe, erscheinen die beiden partitionen natürlich nicht mehr, da ich diese ja nun erst neu anlegen muss. Ich habe also nun eine neue sdb und wollte nun folgendes ausführen:

01.
1. vgcreate data1 /dev/sdb1 
02.
2. lvcreate -n back_data1 -L 72G vgdata1 
03.
3. FREESIZE=`vgdisplay vgdata1 | grep Free | awk '{ print $5 }'` 
04.
4. lvcreate -n back_data2 -l $FREESIZE vgdata1 
05.
5. mkfs.ext3 -q /dev/vgdata1/back_data1 
06.
6. mkfs.ext3 -q /dev/vgdata1/back_data2 
07.
7. vgchange -a y vgdata1
Als ich den ersten Punkt ausführen wollte erschien folgende Meldung:
01.
[root@hostname1]# vgcreate vgdata1 /dev/sdb1 
02.
/dev/sdb1 not identified as an existing physical volume 
03.
Unable to add physical volume '/dev/sdb1' to volume group 'vgdata1'.
Wie gehe ich nun vor?
Mitglied: winlin
09.09.2011 um 11:10 Uhr
fdisk -l ergibt folgendes:
01.
fdisk -l /dev/sdb 
02.
 
03.
Disk /dev/sdb: 300.0 GB, 300000000000 bytes 
04.
255 heads, 63 sectors/track, 36472 cylinders 
05.
Units = cylinders of 16065 * 512 = 8225280 bytes 
06.
 
07.
Disk /dev/sdb doesn't contain a valid partition table
Bitte warten ..
Mitglied: hmarkus
09.09.2011 um 11:17 Uhr
Hallo winlin,

aus Deinem Posting geht nicht hervor, dass Du die Partition /dev/sdb1 tatsächlich auf der neuen Platte angelegt hast. Kann es sein, dass Du diesen Schritt vergessen hast.

In diesem Fall ist übrigens die -q Option für mkfs.ext3 wenig hilfreich weil natürlich auch keine Fehlermeldungen kommen.

Markus
Bitte warten ..
Mitglied: winlin
09.09.2011 um 11:18 Uhr
pvcreate /dev/sdb war die Lösung: -)))))
Bitte warten ..
Mitglied: winlin
09.09.2011 um 11:19 Uhr
habe ich nun angelegt! aber danke nochmal!
Bitte warten ..
Mitglied: aqui
09.09.2011 um 15:07 Uhr
Bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Ähnliche Inhalte
Windows 10
Windows 10 S: Nur Apps aber kein Linux (3)

Link von BassFishFox zum Thema Windows 10 ...

Ubuntu
Ubuntu-Linux mag nicht mit W-LAN verbinden (16)

Frage von Realbilly zum Thema Ubuntu ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (38)

Frage von sabines zum Thema Internet ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

LAN, WAN, Wireless
gelöst Eintägige Netzwerkunterbrechung trotz Backupleitung (15)

Frage von iAmbricksta zum Thema LAN, WAN, Wireless ...

Netzwerke
VPN-Server einrichten PPTPD-Einrichtung gescheitert (15)

Frage von MIlexx zum Thema Netzwerke ...