Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP Server ignoriert DISCOVER (WLAN?)

Frage Netzwerke Netzwerkmanagement

Mitglied: Downlord89

Downlord89 (Level 1) - Jetzt verbinden

25.01.2007, aktualisiert 28.01.2007, 11411 Aufrufe, 9 Kommentare

Wenn der PC direkt an den Router angschlossen wird, funktioniert die Sache mit dem DHCP tadellos. Bei Verbindung PC -> Switch -> WLAN AP -> WLAN Router dauert es jedoch sehr lange, bis eine IP vergeben wird. Dies ist erst seit der neuen Firmware (DD-WRT V23 SP2) der Fall. Bei Linux wird gar keine IP vergeben.

Hi!

Netzwerkaufbau (192.168.123.0/24):

Von PC (IP via DHCP, nachfolgend: 192.168.123.149)
über Switch
über D-Link DWL-2100 AP (Client Mode, statische IP, WEP) (192.168.123.252)
zu Linksys WRT54GS Router (WLAN, DHCP-Server, WEP) (192.168.123.254)

9095d28c862d4427e65aee6de5eac035-netzstruktur - Klicke auf das Bild, um es zu vergrößern

Bisher hat alles funktioniert. Nun habe ich DD-WRT auf dem Router installiert.. erst seither (denke ich) habe ich dieses Problem;

Unter Windows (PC hat noch zweites NIC drin; 192.168.123.149):

1. Netzwekkarte aktivieren (DHCP)
2. "Netzwerkadresse beziehen..."
3. "Netzwerkadresse beziehen..."
4. ....
5. Keine Adresse erhalten -> Windows Krüppelzusweisung (169.x.y.z)
6. Aha, plötzlich DHCP Offerte erhalten
8. Nehme Offerte an -> 192.168.123.119

Damit könnte ich eigentlich leben. Doch..

Unter Linux (Suse 10.2, Laptop über NIC,Wireless deaktiviert):

DHCPREQUEST (...)
DHCPREQUEST (...)
DHCPDISCOVER (...) interval X
DHCPDISCOVER (...) interval X
DHCPDISCOVER (...) interval X
DHCPDISCOVER (...) interval X
DHCPDISCOVER (...) interval X
DHCPDISCOVER (...) interval X
Keine Offerte, abbruch



Um zu sehen, was so in etwa passiert, habe ich mit Wireshark mit dem Laptop folgende Pakete "gecatpured":
(192.168.123.150 ist die IP, die der Laptop

http://www.mjung.ch/share/snapshot1.jpg
http://www.mjung.ch/share/snapshot2.jpg

Hat jemand eine Ahnung, was da los sein könnte?
Mitglied: aqui
25.01.2007 um 13:59 Uhr
Eigentlich funktioniert das problemlos mit dd-wrt... Leider sieht man bei deinem Trace unten nicht die MAC so das man nicht sicher sagen kann wer den Request sendet....
Du schreibst der Win PC hat noch eine 2te NIC und dahinter eine Adresse die auch im WLAN/LAN hängt. Das darf natürlich nicht sein wenn diese Adresse auch auf der 2ten NIC ist ! Ich denek aber das klar ist das diese in einem 2ten separaten IP Netz sein muss. WLAN und LAN dürfen nicht parallel im gleichen Netz aktiv sein....
Ggf. würde ich nochmal prüfen ob sich nicht noch ein anderes Wlan in der Umgebung befindet und deins stört. Mit dd-wrt kannst du das in den Statistics sehen oder eben mit dem Netstumbler von netstumbler.com.
Dein Netz sollte dann mindestens 5 Kanäle Abstand haben....
Bitte warten ..
Mitglied: Downlord89
25.01.2007 um 16:17 Uhr
Das ein Problem wegen den NICs besteht denke ich nicht, denn auch wenn das einte deaktiviert ist gibt es immernoch Probleme, zudem funktioniert es mit dem Notebook auch nicht - früher gab es allerdings keine Probleme!

Doch wie kann es sein, dass er erst eine IP erhält, nachdem er sich selbst eine zugewiesen hat? Das ist nämlich immer so, und geschiet DIREKT nachdem er sich eine IP zugewiesen hat.

Der Request kommt von der Karte, die auch die Discovers sendet.

Das ein Wirelessproblem besteht wage ich auszuschliessen, da ich ja nur Problememit dem DHCP-Server habe, der Rest funktioniert ohne Probleme.

Zudem sind keine anderen WLANs in Reichweite.
Bitte warten ..
Mitglied: aqui
25.01.2007 um 18:04 Uhr
Das ist in der Tat recht ungewöhnlich ! Die APIPA Adresse vergibt sich Windows eben genau deswegen weil der Adapter keine Antwort von einem DHCP Server sieht nachdem der Client ein Request gebroadcastet hat....
Wenn du das mitsnifferst, kannst du dann sehen das der Client (MAC Adresse vergleichen im Trace !) de facto mehrere Requests an die Broadcast Adresse schickt und der DHCP Server nicht antwortet ???
Du hast doch eine Linux Host da laufen. Kannst du nicht spasseshalber mal den DHCP am dd-wrt abschalten und den daemon am SuSE starten und sehen ob der eine Antwort gibt.
Wie gesagt ich sehen keine Probleme hier am dd-wrt mit DHCP.
Bitte warten ..
Mitglied: Downlord89
25.01.2007 um 22:23 Uhr
Also wie auf dem Bild oben zu sehen ist, sendet der Client 4 Discovers. Der DHCP fragt dauernd nach, ob jemand die IP hat. Der wenn dann Win sich selbst eine IP zuteilt und nochmals einen Discover schickt, erhält er dann, beim 5. Versuch, seine IP augenblicklich.

(Sry hab' z.T. request und discover nicht klar auseinandergehalten)

Hab' nun aufm Windows schnell n'DHCP angeschmissen -> Suse holt sich ohne Probleme seine IP.

Das ein Verbindungsproblem vorliegt, ist jedoch ausgeschlossen.

Hilfe =( Ich denke dass der springende Punkt irgendwo was mit der IP zu tun hat, die er erst bekommt, nachdem er quasi schon eine hat. Versteht jemand dieses "Register MJUNG" zeugs? mjung ist der Hostname meines Win Rechners.

Ach und; Gecaptured wurde an dem NIC, dass die IP beziehen sollte.
Bitte warten ..
Mitglied: Downlord89
25.01.2007 um 23:16 Uhr
Hab' das ganze mal mit dem Laptop durchgeführt, siehe aktualisierte Bilder oben.

Der DHCP ignoriert einfach die Anfragen. Bei "Wer hat meine IP" (ARP) gibt's jedoch ne antwort :S
Bitte warten ..
Mitglied: aqui
27.01.2007 um 16:19 Uhr
Das ist genau das Problem... Vermutlich kommt der DHCP Request gar nicht beim dd-wrt an ! Deshalb solltest du den Wireshark einmal NICHT an der NIC anschliessen, sondern mit einem Hub zusammen mit dem dd-wrt an den Switch hängen. So kannst du sehen ob der Request überhaupt physisch am dd-wrt Port landet. Sollte er da gar nicht landen, ist es klar das der keine Antwort schickt.
Der ARP reply kommt übrigens von einem Cisco Router oder Switch, da du wahrscheinlich routest in deinem Netz. Hat also primär erstmal nichts mit dem DHCP Problem zu tun ! Es sein den....
Du musst den DHCP Request über ein Layer 3 (groutetes Interface) übertragen ! Das geht natürlich so nicht, denn dafür brauchst du auf dem Cisco Interface eine "ip helper address <ip v.DHCP>" !
Was auch noch etwas unklar ist: Du schreibst oben ....Switch -> WLAN AP -> WLAN Router.
Sind WLAN AP und Router per Kupfer verbunden ??? Es sollte auch klar sein das nicht beide Komponenten (sofern si das supporten..) einen DHCP Server am Laufen haben dürfen ! Einer muss abgeschaltet werden !
Bitte warten ..
Mitglied: Downlord89
27.01.2007 um 19:22 Uhr
also:

Mein PC und Laptop ist über einen Switch mit einem Wireless AP verbunden.
Dieser stellt die Verbindung zum Router her (Linksys = Cisco), in welchem auch der DHCP Server enthalten ist.

Wenn ich den Laptop direkt am Router anschliesse, via Kabel, gibt es kein Problem.

Mit der alten Firmware hat es mit genau dieser Aufstellung tadellos funktioniert

Ich bin nun daran herauszufinden, ob Laptop -> WLAN Router funktioniert, wenn ja liegt das Problem zwischen WLAN Router -> WLAN AP, ansonsten am WLAN allgemein...
Bitte warten ..
Mitglied: aqui
28.01.2007 um 11:27 Uhr
Ich denke das das so generell nicht geht ! Ist also verwunderlich das es mit der original SW klappt. Der AP kann nicht als Bridge arbeiten, was er aber machen müsste. Ich denke du hast ihn als WDS Repeater laufen, was dann aber ausschliesslich für WLAN Clients supportet ist und nicht mit einen LAN LAN Kopplung.
Du lässt die AP Router Kopplung ja quasi als LAN Bridge laufen und das geht mit WDS Repeating eigentlich so nicht !
DD-WRT sollte das aber supporten siehe hier:
http://www.dd-wrt.com/dd-wrtv2/down.php?path=downloads%2FDocumentation% ...
Bitte warten ..
Mitglied: Downlord89
28.01.2007 um 13:31 Uhr
Nein, kein WDS. Der AP ist auf "Client Mode".

Hab' zum besseren Verständnis oben noch den logischen Netzplan eingefügt.. hätte ich vlt. vorher machen sollen ;)

Aber mit dem WDS hast du mich auf eine Idee gebracht;

Wenn der AP im Client Modus läuft um das Netzwerk zu überbrücken, ist das im Grunde genommen ähnlich wie mit WDS - Er empfängt das Signal und leitet es statt per WLAN per LAN weiter.

Hmm... WDS... in der alten Firmware gab es dazu keine option, bei DD-WRT jedoch hat man die möglichkeit, die MAC-Adressen der WDS-Knotenpunkte einzutragen. Dort hatte ich bisher nur unseren WDS-Repeater (WRE54G) drin. Schaden kann's nicht -> AP hinzugefügt...

Siehe da, keine Probleme mehr :D Da hätt ich auch gleich drauf kommen können -.-
Da jedoch die Verbindung - abgesehen von DHCP - ohne weiteres funktioniert hatte, hab' ich kaum gedacht dass es daran liegt.

Verstehen tu' ich es auch jetzt noch nicht, aber hauptsache es läuft :D

Danke für eure Unterstützung... und für das richtige Stichwort ;)
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Netzwerkmanagement
gelöst Ein Gerät, zwei DHCP Server oder mehr (16)

Frage von fuddel18 zum Thema Netzwerkmanagement ...

Windows Server
gelöst DHCP Server 2012 R2 umziehen (3)

Frage von oce zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...