Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP Server vergibt keine IP an ein Debian System

Frage Linux Debian

Mitglied: Uwe82

Uwe82 (Level 1) - Jetzt verbinden

10.08.2009, aktualisiert 19:17 Uhr, 9893 Aufrufe, 5 Kommentare

Folgende Umgebung:
1x Host mit Server 2008 R2, darauf 1x Windows Server 2008 als DC, DHCP, DNS, VPN, Exchange, 1x Windows Server 2003, 1x Debian Linux
1x Server, um den es hier geht, mit Debian
Mehrere Clients

Hallo zusammen,

obige Konstellation, der virtuelle DHCP Server vergibt einwandfrei IPv4-Adressen, sowohl an die virtuellen Maschinen, als auch an die physikalischen Clients. Jetzt kommt ein weiterer physikalischer Server unter Debian Linux ins Netz. Die Netzwerkkarte ist mit DHCP konfiguriert, bekommt aber keine IP-Adresse vom DHCP-Server. Habe daraufhin mit Network Monitor auf dem Server geschaut:

- DHCP DISCOVER-Paket kommt einwandfrei an, aber der Server reagiert nicht darauf
- Tests mit den anderen Systemen liefen einwandfrei und der DHCP antwortete auch gleich darauf.

Einziger Unterschied, den ich so direkt in NM erkennen kann ist, dass die Spalte Process Name bei den Paketen des neuen Systems leer ist, bei den anderen steht "svchost.exe". Daher denke ich, dass das Paket nicht bis zum DHCP Server selbst durchdringt.

Weiß jemand, woran das liegen könnte?

Grüße und Danke
Mitglied: godlie
11.08.2009 um 08:01 Uhr
Hallo,

wie sieht denn die /etc/networks/interfaces aus vom deb server?
Bitte warten ..
Mitglied: Uwe82
11.08.2009 um 21:40 Uhr
# This file describes the network interfaces available on your system 
# and how to activate them. For more information, see interfaces(5). 
 
# The loopback network interface 
auto lo 
iface lo inet loopback 
 
# The primary network interface 
allow-hotplug eth0 
iface eth0 inet dhcp 
        dns-nameservers 192.168.0.4 192.168.0.1 
        dns-search domain.local
Bitte warten ..
Mitglied: godlie
12.08.2009 um 00:46 Uhr
was passiert wenn du ein ifdown eth0 und ifup eth0 machst?

Wenn ich das richtig sehe dann fehlt irgendwie ein auto eth0 in der config.
Aber bin mir da bei Suse net so sicher...
Bitte warten ..
Mitglied: Uwe82
16.08.2009 um 12:44 Uhr
Danach versucht er ein DHCP-Discover, die kommen auch auf Serverseite an. Allerdings schickt der Windows-DHCP keine Antwort raus.

Ist übrigens kein SuSE, sondern Debian.
Bitte warten ..
Mitglied: Uwe82
16.08.2009 um 23:16 Uhr
Oh Mann, gerade hatte ich mal in die Logs meines VM-Hosts geschaut und den Fehler gefunden. Normalerweise gibt man in Hyper-V den Netzwerkkarten der VMs dynamische MAC-Adressen in einem vordefinierten Bereiche, damit sie nicht mit realen System kollidieren. Mein Debian-System ist allerdings mein alter Server auf dem eine der jetzt virtualisierten Server 2008 läuft, auf dem auch der DHCP läuft.

Virtualisiert wurde das ganze mittels SCVMM 2008 und der nimmt die MAC-Adresse mit. Damit war die MAC bereits im Netzwerk und mein VM-Host hat sie korrekterweise abgelehnt, was auch in den Eventlogs des Systems verzeichnet wird.

Ganz zufällig habe ich das eben gesehen. Also muss ich nur bei Gelegenheit die VM runterfahren und ihr eine neue MAC verpassen, dann sollte es wieder gehen. Und da macht man stundenlang an der Fehlersuche rum ...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Alcatel IP Telefone und Windows DHCP Server - (Option 43) (8)

Frage von wafztb zum Thema Windows Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...