Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS Problem bei Backbone und Intranet

Frage Netzwerke DNS

Mitglied: leuaner

leuaner (Level 1) - Jetzt verbinden

22.02.2008, aktualisiert 26.02.2008, 3230 Aufrufe, 2 Kommentare

Wie muss der DNS-Server richtig konfiguriert werden bei Verwendung eines
LANs und eines Backbones?

Hallo,

Wir haben ein Problem, welches schon seit einiger Zeit für Probleme im Netz sorgt:

Wir haben ein LAN mit dem IP-Range 10.x.x.x
An diesem LAN hängen unsere Clients und Server (auch Terminalserver).
Ein Server (DC) ist dabei Domainencontroller, DNS-Server und WINS-Server in einem.
Es gibt auch noch einen zweiten Server mit gleicher Funktionalität, der ebenfalls
die drei Funktionen beinhaltet und als Backup dient.

Nun hat das LAN nur 100 MBit, daher haben wir auch noch ein Backbone mit
dem IP-Range 192.168.6.x, welches NUR die Server alle über eine zweite
Netzwerkkarte mittels eines Switches verbindet, dieses Netz hat 1 GBit.

Auf dem DNS-Server haben wir 2 Forward-Lookupzonen eingerichtet:

firma.de:
Router 10.0.0.1
DC1 10.0.0.2
DC2 10.0.0.3
TS1 10.0.0.4
TS2 10.0.0.5
AnwSrv 10.0.0.6
Client1 10.0.0.7
Client2 10.0.0.8
usw.

giga.firma.de:
DC1 192.168.6.2
DC2 192.168.6.3
TS1 192.168.6.4
TS2 192.168.6.5
AnwSrv 192.168.6.6

Die Server stehen also in beiden Zonen mit gleichem Namen aber unterschiedlichen
IPs drin. Die Eintragungen im WINS-Server sind analog.

Ziel ist es, dass die Clients bei DNS/WINS-Anfragen eine Antwort aus Ihrem
Range bekommen sollen (10.x), während die Server auf die gleichen Anfragen
eine Antwort 192.168.6.x bekommen sollen.

Möchte ein Client also auf den TS1, dann sollte der DNS-Server 10.0.0.4 zurückliefern.
Möchte der TS1 aber auf den AnwSrv, dann sollte die Antwort 192.168.6.6 lauten.

Das Problem ist nun, dass auf Client-Anfragen manchmal eine Antwort aus der
192.168.6.x- Bereich geliefert wird, die dann vom Client aus nicht erreichbar ist.


Frage: Wie löst man dieses Problem? Wie müssten die Zonen auf dem DNS-Server
eingerichtet werden? Wie müssten die IP-Einstellungen der Netzwerkkarten der
Clients, der Server zum LAN hin und der Server zum Backbone hin konfiguriert werden?
Können die gleichen Namen in beiden Zonen überhaupt verwendet werden oder
müssen die Server zum Giganetz hin andere Namen haben?

Gruß,
Leuaner
Mitglied: leuaner
22.02.2008 um 10:59 Uhr
Ich wollte noch was anfügen:

Ich habe mal von einem Client aus nslookup aufgerufen.
Bei der Abfrage von TS1 bekomme ich: 10.0.0.4, 192.168.6.4
Bei der Abfrage von TS1.giga.firma.de bekomme ich: 192.168.6.4
Bei der Abfrage von TS1.firma.de bekomme ich: 10.0.0.4, 192.168.6.4

Vor allem die letzte Abfrage wundert mich, warum wird mir hier auch die
Giganetz-IP zurückgeliefert? Was müsste ich ändern, damit man nur
die IP 10.0.0.4 bei der Abfrage vom Client aus bekommt?
Bitte warten ..
Mitglied: user01
26.02.2008 um 14:57 Uhr
So ich bin mir nicht sicher wie man das eigentlich konfigurieren sollte aber ich denke du hast in jedem Server nur 1 Netzwerkkarte? und die Server sind eigentlich auch in der AD Domäne firma.de - welches wir hier böserweise verwenden.

Auf dem Server bei den eigenschaften der Lan Verbindung - TPC/IP - Erweitert - DNS ist unten ein hacken gesetzt - Adressen dieser verbindung im DNS registrieren.

Tja so kommen denke ich die adressen auch in die forward lookup zone firma.de und werden dann zurückgegeben.

wenn das so ist sollten sie auch in der entsprechenden zone im dns eingetragen sein - also einfach 2 A Records für den jeweiligen server unter firma.de und 1 A Record unter giga.firma.de

LG, Thomas
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Webbrowser
DNS Problem in Browsern - Suche in Adresszeile (5)

Frage von tobivan zum Thema Webbrowser ...

DNS
gelöst Homeserver (Zentyal) und Fritzbox DNS Problem (6)

Frage von CharlyXL zum Thema DNS ...

DNS
gelöst Server 2012 R2 DNs Problem (9)

Frage von dan0ne zum Thema DNS ...

DNS
DNS Problem im VLAN (7)

Frage von momai zum Thema DNS ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...