Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS-Server für LAN-Verbindung sollte die Loopbackadresse enthalten

Frage Microsoft Windows Server

Mitglied: geTr0ffEn

geTr0ffEn (Level 2) - Jetzt verbinden

06.10.2012, aktualisiert 15:03 Uhr, 5114 Aufrufe, 11 Kommentare

DNS Problem nach Installation von DNS Rolle

Moin,

habe gestern auf einem Server 2008R2 während eines dcpromo die DNS Rolle mitinstalliert.
Im Anschluss habe ich die Loopbackadresse eingetragen.

ich ahbe jetzt mal den Practice Analyzer gestartet und bekomme folgende Meldung:




DNS ist auf dem DC als 127.0.0.1 konfiguriert.

Kennt jemand diese Meldung ??

Gruß
Mitglied: win-dozer
06.10.2012, aktualisiert 07.10.2012
Moin,

Naja hast du es so gemacht wie es da steht?
LAN-Verbindung -> konfigurieren:
primärer DNS -> 127.0.0.1
sekundärer DNS -> Router IP Adresse

Grüße

win-dozer
Bitte warten ..
Mitglied: Dani
06.10.2012 um 09:42 Uhr
Moin,
also primärer DNS dient nie der Route in einem ADS!

Man trägt wohl laut Microsoft die DNS-Server gekreuzt ein.

Server A:
primärer DNS -> SERVER B
sekundärer DNS -> 127.0.0.1

Server B:
primärer DNS -> SERVER A
sekundärer DNS -> 127.0.0.1


Grüße,
Dani
Bitte warten ..
Mitglied: 60730
06.10.2012, aktualisiert um 11:14 Uhr
Moinsen,

Ich halte davon nix und das hab ich auch schon oft geschrieben.
(funktioniert die suchfunktion nicht?)

Warum immer die 127.o.o.1?

Das ist ein ganzes netz, kein einzelner horst, nehmt doch mal die 127.o.o.2, macht genau das gleiche ist auch genau das selbe. Und wuerde hier mal fuer abwechslung sorgen.

@ dani, das mit dem ueber kreuz mag ja bei der mcse/a pruefungsbrillensicht irgendwie richtig srin, aber doch nur damit der dns beim booten die eine meldung nicht ins eventlog pfeffert. Schmiert der counterpart wech (und seis nur, weil derm ein neuer flickenteppich ausgerollt wuede), hagelt es nicht nur die gleichen fehler, sondern auch noch stress im netz.

Und wenn ich das weiss, dann boote ich eine kiste durch, geh auf der kiste ins eventlog und pfeffer da die fehler weg statt michnauf ne andere zu konecten und das gleiche da zu machen.

Aber jeder wie er es mag.

127 ist aber immer falsch

Edit @ win-dozer: nimm mal bitte den bull-dozer und schieb deine zeilen zum bibers rundablage auffangbecken.

Sowohl router, als auch 127 ist so falsch, wie flasche fertig.

/edit
Bitte warten ..
Mitglied: Dani
06.10.2012 um 11:12 Uhr
@LimboSeil
Ist nicht auf meinen Mist gewachsen aber das sagt auch der Microsoft Support (Stand: Juli 2012).
Frag mich nicht warum, ist so.
Bitte warten ..
Mitglied: Lochkartenstanzer
06.10.2012, aktualisiert um 11:24 Uhr
Zitat von 60730:
127 ist aber immer falsch

Nope.

127.0.0.0/8 ist dann richtig, wenn die Dienste den host nicht verlassen sollen.

Benutz ich auf unix-Kisten ausgiebig, um daemons miteinander reden zu lassen und dabei die Außenwelt, wie es sich gehört, außen vor zu lassen.

Und 127.0.0.x ist üblicherweise immer erreichbar, im Gegensatz zu den IP-Adressen auf den Interafces, weil die ja durchaus mal weg sein können, wie z.B. kaputt, deaktiviert, andere DHCP-Adresse, etc.

Ich sach mal so: Mit sich selbst kann man immer reden, mit anderen nur dann, wenn die auch da sind.


lks

Nachtrag: Für den NS im Ad kann mag das aber durchaus sein, daß das imerm falsch ist.
Bitte warten ..
Mitglied: 60730
06.10.2012, aktualisiert um 11:33 Uhr
Dani,

Ich weiss es doch, aber irgenwo in den tiefen des forums habe ich mich mal mit yusuf unterhalten ( lang ists her, da hat der noch nicht beim symphatischen marktfuehrer gewerkelt)

Das ist reiner pruefungstheoriekram, der dann sinn macht, wenn man viele dnsse hat und einer immer da ist, weil der in ner ha nummer lauft und sonst nix macht.

Alles andere ist reine kosmetik und man hat angst vorm "dns in a island" szenario, was aber gar nicht so schlimm ist, denn egal wo es klemmt, klemmt dns oder die ad repl. Klemmt kurz danach alles andere. Von daher ist das jacke wie hose.

(wer von uns ueberwacht denn seine ad repl. nicht und wuerde dann wirklich wie robinson crusoe auf der insel stehen und vor den kanibalen fluechten)?

Gruss

Edit
@ lks...
Ja ?ux, da haben die nicht nur viel codezeilen uebernommen, auch manchmal den ganzen text, der hinter /? zu lesen ist
Und weil die teilweise praktikanten einsetzen, die zu doof sind, quellcode anzupassen, haben die viel (zu viel) uebernommen.
Auf ner *ux kiste macht das auch wirklich sinn, aber wir schreiben doch ueber dns in zusammenhang "ad unter mickeyschrott aufblasebalg os".

Was geht denn, wenn der ad dc server keine dhcp adresse mehr bekommt oder wenn der mit sich selber redet und kein anderer mehr zuhoert?

Ebent

Der greift in die gruetze und mit glueck ( wenn ich den ueber kms oder ilo anschau) krieg ich das nicht mal dort im eventlog praesentiert, wo ich es suchen wuerde, weil mein 127er netz ja immer noch da ist
Bitte warten ..
Mitglied: geTr0ffEn
06.10.2012, aktualisiert um 15:08 Uhr
Hi, alle Veränderungen haben nix gebracht, das Problem ist immer noch da.
Ich bin grad mal auf den DC in meiner Firma drauf :D Analyzer gestartet, haha, das gleiche Problem, jedoch nichts gemerkt bisher. Also keine Probleme. Kann das ein neues Allgemeinproblem sein? (Update, Bug?? keine Ahnung und davon viel) IP6 is disabled.

Zudem habe ich aber jetzt ein weiteres Problem, also Rotes Kreuz.
Zusehen auf dem unteresten Foto.

Kann jemand helfen, hab noch n shot von den adaptereinstellungen gemacht, das stimmt ja alles.



c8fcb039edd8d8935e02f8b7a82cf18c - Klicke auf das Bild, um es zu vergrößern

71f07717892abec99c65ca02bf84b073 - Klicke auf das Bild, um es zu vergrößern

Hier das neue Problem

32e2c4518df2b44fd0b4c94e7f920392 - Klicke auf das Bild, um es zu vergrößern

Gruß
Mark
Bitte warten ..
Mitglied: 60730
07.10.2012 um 21:34 Uhr
Moin,

Mal langsam und der reihe nach...

Du hast was genau gemacht?
Und das ist der erste dc in der domain?

Wenn nein, warum steht der andere dc nicht als dns in dem drin?
Und, was sagt das dns eventlog von allen dcs?
Wer hat die oben beanstandete zone und wer hat die nicht.

Wenn ja, tret das ding in die tonne und mach neu mit dcpromo ohne vorher irgendwas mit der dns rolle zu machen, das macht scpromo schon selber.

Je genauer du dein vorgehen formulierst, desto simpler kann man helfen.
Bitte warten ..
Mitglied: geTr0ffEn
07.10.2012, aktualisiert um 21:58 Uhr
hi,

ja, es ist der erste DC in der Domain, hab den ja hier zuhause neu aufgesetzt.
Deswegen nur ein DNS, oder sollte ich den DNS von meinem Router mit reinnehmen?

Eventlog zeigt auch nur diesen Fehler an.

Hast du ne Möglichkeit, den ebenso wie ich, mal virtuell aufzusetzen? Ich denke du wirst auch den Fehler haben.
Mir fällt auf, das es nach dcpromo erst da ist.

Ich werde wie du empfiehlst, mal den dns aus dcpromo heraus installieren.
Was ist, wenn das Problem immernoch da ist?


Die Bedingung des BPA ist "Es darf nicht der erste sein".
Die Bedingung des AD ist "Es darf auch kein anderer außer AD-DNS sein" und
deine Bedingung ist "Es gibt nur einen DNS".

Die drei Punkte schließen sich aus??? Ist es möglich das es garnicht geht? Es muss doch mit einem auch laufen. Wie soll ich sonst ne Testumgebung aufbauen?
Gruß
Bitte warten ..
Mitglied: 60730
07.10.2012, aktualisiert um 22:59 Uhr
hi,

ja, es ist der erste DC in der Domain,

Mach paltt und neu
oder sollte ich den DNS von meinem Router mit reinnehmen?

Nein, der kommt als forwarder rein.

Eventlog zeigt auch nur diesen Fehler an.

Mach trotzdem fdisk und neu, wenn der eh neu war.

Die Bedingung des BPA ist "Es darf nicht der erste sein".
Nein, die loopbackadresse darf nicht, also 127.o.o.x
Die Bedingung des AD ist "Es darf auch kein anderer außer AD-DNS sein"
Yupp, deswegen (u.a) auch den router da raus lassen!
und deine Bedingung ist "Es gibt nur einen DNS".

Kein thema, ausser das das halt vom backup und ausfallrisiko fuer ne domain etwas .... Ist.

Die drei Punkte schließen sich aus???
Nein.
Ist es möglich das es garnicht geht?
Nein
Es muss doch mit einem auch laufen.
yupp, ist aber sinngemaess wie mit einem bein laufen.
Wie soll ich sonst ne Testumgebung aufbauen?
Egal, ich schreib mal, was da aus meiner sicht schief lief...
Dcpromo findet dns, dns ist 127 und dcpromo will die ad intergriierten zonen erzeugen, kann aber mit 127. Nix anfangen und dann rappelts im karton.

Das auszumerzen waere zwar moeglich, aber wenn die karre eh neu war, ist es fuer nen anfaenger (und meine ipadsxhreiberei) einfacher neu und von dcpromo die rollen aufzusetzen und die richtigen werte einzutragen.

Und wenn das ein 2k8 r2 ist, dann wird der die 127. Als 2. Dns eintragen, lass das - solange kein 2. Dc / dns da ist.

Nachtrag.
Lass dich nicht berwirren, nachdem der neu gemacht wurde, wird dir dns einen fehler im eventlog praesentieren, dass ist der den ich oben angesprochen habe.
Sinngemaess in den letzten 24 stunden ist ein fehler aufgetreten. Das ist "normal" !!!

Gruß
Bitte warten ..
Mitglied: geTr0ffEn
07.10.2012, aktualisiert um 23:02 Uhr
So,

hab das Teil jetzt 4mal neu aufgesetzt,
immer noch der Fehler, jedesmal, (habe alle Installationsvarianten gewählt, demnach deine und MS).

Egal wie ich installiert habe(nach deiner Empfehlung oder auch MS Empfehlung) jedesmal hat der Neustart nach DCPROMO den DNS Server zunächst als 127.0.0.1 angegeben. Natürlich habe ich dann manuell wieder auf (beispielweise 10.0.0.1) gestellt und IPV6 auf auto.

Immer wieder die Fehlermeldung.

Da ich danach den Exchange installiere, muss ich das beheben, sonst wird der Schneeball im größer

Gruß
Mark
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...