Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Drucker im Subnet nicht erreichbar

Frage Netzwerke Router & Routing

Mitglied: insoft

insoft (Level 1) - Jetzt verbinden

28.02.2013 um 20:35 Uhr, 3066 Aufrufe, 10 Kommentare

Hallo Zusammen,


zum Szenario:
Subnet1 und Subnet2 sind per VPN miteinander verbunden. Auf den Routern pro Standort sind die Routen so eingerichtet, dass die Geräte (Server, Clients, drucker) aus dem Subnet1 für das Subnet2 erreichbar sind und umgekehrt genauso.

Im Subnet1 haben wir insgesamt 6 Netzwerk-Drucker (2 HP-Drucker und 4 Samsung CLP610). Im Subnet2 haben wir einen Samsung CLP610.

Problem:
Vom Subnet2 erreicht man die 4 Samsung-Drucker im Subnet1 nicht (kein Ping, telnet, http), die 2 HP-Drucker und die Clients erreicht man jedoch problemlos.
Umgekehrt vom Subnet1 erreicht man den Samsung-Drucker im Subnet2.

Hat jemand eine Idee. M.e. sieht es nach einem Problem mit den Druckern aus. Die Samsung-Hotline konnte mir allerdings nicht weiterhelfen.

Vielen Dank

Gruß Daniel
Mitglied: Pjordorf
28.02.2013 um 20:38 Uhr
Hallo,

Zitat von insoft:
Vom Subnet2 erreicht man die 4 Samsung-Drucker im Subnet1 nicht (kein Ping, telnet, http)
Werden diese denn überhaupt erreicht (wirklich, tatsächlich)? Wireshark sagt dir dies. Werden die erreicht so stellt sich die Frage wo die Antwort hingeht (GW). Wireshark sagt dir auch dieses.

Gruß,
Peter
Bitte warten ..
Mitglied: insoft
28.02.2013 um 20:56 Uhr
Hallo Peter,

danke für deine schnelle Antwort.

Ich habe Wireshark noch nie verwendet. Zum testen habe ich es nun auf einem Server im Subnet2 installiert. Kannst Du mir kurz erläutern was ich im wireshark einstellen muss, damit ich dir eine Antwort auf deine Frage geben kann?

Danke

Gruß Daniel
Bitte warten ..
Mitglied: Pjordorf
28.02.2013 um 21:14 Uhr
Hallo,

Zitat von insoft:
Ich habe Wireshark noch nie verwendet.
Na toll.

Zum testen habe ich es nun auf einem Server im Subnet2 installiert.
Auf irgendeinem Server in Netz 2 (nichts mit Sub) wird es dir nicht helfen, ausser dein Switch kann Portmirror (oder ähnliches). Du kannst in einem geswitschten netzwerk nunmal halt nur den Verkehr sehen den du selbst erzeugts bzw. der für deinen Anschluß (MAC) bestimmt ist. Aber wir reden hier über Basics und dieses Forum ist nicht gross genug um dir alles zu erklären

Am Switch also ein Portmirror des Druckersports auf den Serverport leiten. dann solltest du das meiste sehen können.

Im Wireshark eine Capture filter auf ICMP machen. Blendet dir also alles andere schon beim erfassen aus.
Den Drucker vom Server in Netz 2 anpingen (ICMP) und Wireshark beonachten.

:Anfang
ICMP an Drucker
Drucker Antwortet auf ICMP Anfrage
Goto :Anfang

Du solltest sowohl deine Anfrage sehen (Tx), sowie die Ankunft am Drucker (Rx) (Portmirror), dann die Antwort an dir (Rx) sowie die Antwort des Druckers (Tx).

Alles andere steht in der lektüre zum Wireshark und im Internet.

Gruß,
Peter
Bitte warten ..
Mitglied: insoft
28.02.2013 um 21:16 Uhr
Hallo Peter,

habe folgendes protokolliert:

No. Time Source Destination Protocol Length Info
108 43.765028000 10.20.38.240 10.20.31.235 ICMP 74 Echo (ping) request id=0x0200, seq=12032/47, ttl=128

Frame 108: 74 bytes on wire (592 bits), 74 bytes captured (592 bits) on interface 0
Ethernet II, Src: Dell_e4:d7:4d (00:1e:c9:e4:d7:4d), Dst: BintecCo_1b:07:d0 (00:a0:f9:1b:07:d0)
Internet Protocol Version 4, Src: 10.20.38.240 (10.20.38.240), Dst: 10.20.31.235 (10.20.31.235)
Version: 4
Header length: 20 bytes
Differentiated Services Field: 0x00 (DSCP 0x00: Default; ECN: 0x00: Not-ECT (Not ECN-Capable Transport))
0000 00.. = Differentiated Services Codepoint: Default (0x00)
.... ..00 = Explicit Congestion Notification: Not-ECT (Not ECN-Capable Transport) (0x00)
Total Length: 60
Identification: 0x7804 (30724)
Flags: 0x00
0... .... = Reserved bit: Not set
.0.. .... = Don't fragment: Not set
..0. .... = More fragments: Not set
Fragment offset: 0
Time to live: 128
Protocol: ICMP (1)
Header checksum: 0x0000 [incorrect, should be 0x67ba (may be caused by "IP checksum offload"?)]
[Good: False]
[Bad: True]
[Expert Info (Error/Checksum): Bad checksum]
[Message: Bad checksum]
[Severity level: Error]
[Group: Checksum]
Source: 10.20.38.240 (10.20.38.240)
Destination: 10.20.31.235 (10.20.31.235)
[Source GeoIP: Unknown]
[Destination GeoIP: Unknown]
Internet Control Message Protocol
Type: 8 (Echo (ping) request)
Code: 0
Checksum: 0x1c5c [correct]
Identifier (BE): 512 (0x0200)
Identifier (LE): 2 (0x0002)
Sequence number (BE): 12032 (0x2f00)
Sequence number (LE): 47 (0x002f)
Data (32 bytes)

0000 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f 70 abcdefghijklmnop
0010 71 72 73 74 75 76 77 61 62 63 64 65 66 67 68 69 qrstuvwabcdefghi
Bitte warten ..
Mitglied: 104286
28.02.2013, aktualisiert um 23:31 Uhr
insoft, in den Samsung-Druckern von Subnet 1 muss als Gateway die IP-Adresse des Routers/Subnet 1 eingestellt sein. Die Einstellungen dazu findest du im Druckerhandbuch. Die Drucker wissen sonst nicht, wohin sie Antwortpakete schicken sollen.
Bitte warten ..
Mitglied: Pjordorf
28.02.2013 um 23:21 Uhr
Hallo,

Zitat von insoft:
habe folgendes protokolliert:
Nicht jedes Bit ist jetzt relevant

No.     Time           Source                Destination           Protocol Length Info 
    108 43.765028000   10.20.38.240          10.20.31.235          ICMP     74     Echo (ping) request  id=0x0200, seq=12032/47,
Ethernet II, Src: Dell_e4:d7:4d (00:1e:c9:e4:d7:4d), Dst: BintecCo_1b:07:d0 (00:a0:f9:1b:07:d0)
Ist das ein Drucker mit der MAC 00:A0:F9:1B:07:D0 und der IP 10.20.31.235? Wo ist die Antwort von ihm? ICMP Reply?

Gruß,
Peter
Bitte warten ..
Mitglied: aqui
01.03.2013 um 18:10 Uhr
Kann es sein das die Drucker keinen Default Gateway Eintrag haben ??? Ist oben ja schon richtig bemerkt.
Das ist der klassische Fehler hier in solchen Szenarien !
Ohne Gateway natürlich keinerlei Traffic in andere IP Netze...logo !
Bitte warten ..
Mitglied: insoft
01.03.2013, aktualisiert um 21:00 Uhr
Hallo,

der Gateway ist mit 10.20.31.253 (Router) hinterlegt.

Anbei Bilder

f3d919defe3f57391ec38e02ee6939b9 - Klicke auf das Bild, um es zu vergrößern

3a747b2f7d00b1f956af52f3aeae68b6 - Klicke auf das Bild, um es zu vergrößern

Zum Vergleich:

- HP4200 mit der IP 10.20.31.234 antwortet
- Samsung CLP610 mit der IP 10.20.31.235 antwortet nicht.
Bitte warten ..
Mitglied: Pjordorf
01.03.2013 um 21:26 Uhr
Hallo,

Zitat von insoft:
der Gateway ist mit 10.20.31.253 (Router) hinterlegt.
OK. Und du bist dir sicher das die Subnetzmaske .128 dort passt? Verwendest du in allen Geräten ein .128? Können alle Geräte mit einer .128 umgehen?

Gruß,
Peter
Bitte warten ..
Mitglied: insoft
01.03.2013, aktualisiert um 21:43 Uhr
Ja, die clients also PC´s, Drucker haben alle die Maske .128
Es scheint so, dass nur die Samsung-Drucker Probleme machen

Samsung1 mit 10.20.31.231 geht nicht
UPS-Drucker mit 10.20.31.232 geht
Samsung2 mit 10.20.31.233 geht nicht
HP-Drucker mit 10.20.31.234 geht
Samsung3 mit 10.20.31.235 geht nicht
Samsung4 mit 10.20.31.236 geht nicht
Terminalserver1 mit 10.20.31.241 geht
Terminalserver2 mit 10.20.31.242 geht
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkgrundlagen
SMB-Scanfreigabe von Xerox-Drucker (8)

Frage von mcdutch zum Thema Netzwerkgrundlagen ...

Windows 10
"geräte und drucker" unter w8 bzw. w10 zu starten dauert ewig (5)

Frage von tobias3355 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...