Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Einloggen in die Community fehlerhaft

Frage Entwicklung PHP

Mitglied: Snowboarder1994

Snowboarder1994 (Level 1) - Jetzt verbinden

11.10.2010 um 18:12 Uhr, 2390 Aufrufe, 5 Kommentare

Hallo,

bei diesem Header http://pastebin.com/ivYRmFb7 funktioniert das einloggen und registrieren in meiner Community leider nicht... lade ich aber diesen Header hoch http://pastebin.com/ff3ihwSP , dort funktioniert das einwandfrei. Habe beide Dateien schon verglichen, auch die Datenbankabfrage ist einprogrammiert. Wer könnte mir helfen, den Bug zu suchen?

Wäre echt cool. Danke.
Mitglied: Biber
11.10.2010 um 19:46 Uhr
Moin Schneebrettler,

willkommen im Forum.
Würde es helfen wenn du in diesem Bereich...
01.
.... 
02.
.... 
03.
  $usernasme_session = $_SESSION["username"]; 
04.
  $username_get = $_GET["username"]; 
05.
  
06.
  if($username_session == $username_get){$s = "mp";} 
07.
  
08.
  ###################User Daten########################### 
09.
 
10.
  $abfrage_ud = "SELECT * FROM member WHERE username = '$username_session'"; 
11.
....
....den Variablennamen usernasme_session mit nur 3 statt 4 "s" schreibst?

Grüße
Biber
Bitte warten ..
Mitglied: dog
11.10.2010 um 20:37 Uhr
....den Variablennamen usernasme_session mit nur 3 statt 4 "s" schreibst?

Und da wäre es sehr hilfreich gewesen nicht mit Scheuklappen zu programmieren:

01.
ini_set('display_errors','On'); 
02.
error_reporting(E_ALL|E_STRICT);
Gehört beim Entwicklen an den Anfang jedes PHP-Scripts und Xdebug eigentlich auch noch...
Bitte warten ..
Mitglied: Snowboarder1994
11.10.2010 um 22:02 Uhr
Ok, das "S" wurde entfernt. Danke Top. Hab ich ganz übersehen.

Funktioniert aber leider immer noch nicht...
@dog wo muss der Code von dir hin & was muss geändert werden?
Bitte warten ..
Mitglied: dog
11.10.2010 um 22:24 Uhr
@dog wo muss der Code von dir hin & was muss geändert werden?

Wie ich geschrieben habe: ganz an den Anfang der Datei.
01.
<?php 
02.
ini_set('display_errors','On');  
03.
error_reporting(E_ALL|E_STRICT); 
04.
?>
Danach siehst du alle Fehler.

Zudem kann
include("<?echo $domain;?>/connect.inc.php");

Niemals funktionieren.
Was hier beim Ausführen tatsächlich steht ist:
include("<?echo http://xyz.de ;?>/connect.inc.php");
Das ist gleich doppelt falsch.
Zum einen darfst du kein <?echo $domain;?> innerhalb von PHP benutzen.
Korrekt wäre
include("$domain/connect.inc.php");
gewesen.
Zum anderen darfst du niemals Dateien über eine URL include()n (auch wenn PHP das manchmal erlaubt).
Der Pfad muss lokal sein.
Bitte warten ..
Mitglied: Snowboarder1994
12.10.2010 um 17:24 Uhr
Irgendwie bekomme ich das nicht hin, das man sich mit dieser Header Datei registrieren kann. Was ist falsch, warum funktioniert das bei dem alten?
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 10
RDP Verbindung auf PC fehlerhaft, auf Handy jedoch problemlos! (3)

Frage von MarcoSwatch zum Thema Windows 10 ...

Windows Netzwerk
gelöst Windows 10 Kann nicht bei Domäne einloggen? (35)

Frage von Dennis2016 zum Thema Windows Netzwerk ...

Windows Userverwaltung
gelöst Kaputtes Lokales-Profil neu erstellen mit Office Einstellungen. Fehlerhaft (1)

Frage von fireskyer zum Thema Windows Userverwaltung ...

Heiß diskutierte Inhalte
DSL, VDSL
gelöst DSL 200m verlängern (15)

Frage von Angela44 zum Thema DSL, VDSL ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...

Windows Server
SBS 2011 Standard virtualisieren (11)

Frage von HeinrichM zum Thema Windows Server ...

Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...