Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Emailserver - XMail installieren und konfigurieren mit PHPxmail-

Frage Linux Linux Tools

Mitglied: DonniDuck

DonniDuck (Level 1) - Jetzt verbinden

12.06.2006, aktualisiert 03.04.2007, 15909 Aufrufe, 1 Kommentar

Ich möchte einen Emailserver mit Xmail und PHPxmail installieren. Bei der Installation von Xmail treten größere Probleme auf. Wer kann helfen, damit der Emailserver läuft?

Hallo,

ich möchte auf einem Linux-Server (Samba 10.0) einen Emailserver aufsetzen. Dazu möchte ich Xmail nehmen und später die Konfiguration mit PHPxmail vollziehen!

1. Problem:

Beim Downloaden des RPM-Paketes (xmail-1.22-1.i386.rpm) von www.xmailserver.org und Installation unter Yast kam die Fehlermeldung, dass der Linux-gate.so.1 fehlt!

Im Forum von Xmail steht zu dieser Thematik:

Bitte downloaden Sie das xmail-1.22.tar.gz-Archiv und kompilieren Sie es selber.
So wie ich das verstanden habe, ist mein Prozessor für das RPM-Paket *.i386 nicht geeignet.

1. Das Paket habe ich dann auch gedownloadet und entpackt ...
2. Der neue Ordner heißt jetzt xmail-1.22 und befindet sich im Homeverzeichnis von root ...
3. Das Paket muss ja jetzt kompiliert werden ...
4. cd /root/xmail-1.22 und make -f Makefile.lnx ...
5. Der g++ -Kompiler übersetzt auch die ersten Pakete ...
6. Bricht aber dann ab und zeigt folgende Meldung an:

g++: Internal error: Speicherzugriffsfehler (programm collect2)
Please submit a full bug report.
make: *** [bin/XMail] Fehler 1

Was ist das Problem und wie soll ich weiter machen?
Wo werden die Dateien (vom Kompiler) abgespeichert?
In welchen Pfad muss der Befehl zum Installieren ausgeführt werden?
Xmail --install oder Xmail --install-auto, was ist der richtige Befehl?!
Kann ich die Fehlermeldung von Yast in kauf nehmen und das rpm-Paket installieren (unstabiles System)?!


Donni Duck

P.S.
1. Der g++ Compiler ist unter Yast installiert. Müssen noch bestimmte Pakete nachinstalliert werden?

2. Ich hatte Xmail und PHPxmail schon einmal zum Laufen gebracht. Emails holte der Server ab, leider konnte ich mich nicht mehr einloggen und andere seltsame Fehler traten auf. Deshalb will ich jetzt das System noch einmal neuaufsetzen.
Mitglied: 12223
03.04.2007 um 23:07 Uhr
Moin,

erstmal muss ich sagen dass ich auch Probleme mit der 1.22 und der 1.24 Version hatte. Also hab ich gegoogled und eins der unzähligen Tutorials für die 1.17 Version durchgemacht, was letztendlich auch geklappt hat.

Nur dass keine Mails ankommen und ich nicht per SMTP drauf komme, aber der POP3 Login ist erfolgreich. Jemand Ahnung?
Bitte warten ..
Ähnliche Inhalte
Router & Routing
DIR-518L gleicher Adressraum wie Fritzbox konfigurieren? (3)

Frage von rudi52001 zum Thema Router & Routing ...

Microsoft Office
gelöst Access 2016 installieren bei bestehenden Home and Business 2016 (4)

Frage von Huibuh2010 zum Thema Microsoft Office ...

DNS
gelöst Win2k8 R2 DNS-Server richtig konfigurieren (5)

Frage von OlliSWE zum Thema DNS ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...