Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Emailversand per Batchdatei mit dem Tool Blat

Frage Entwicklung Batch & Shell

Mitglied: anfaenger500

anfaenger500 (Level 1) - Jetzt verbinden

02.03.2011, aktualisiert 08:47 Uhr, 14076 Aufrufe, 8 Kommentare

Hallo das Problem wurde in folgendem Aufruf "email automtisch per Batch versenden" schonmal abgehandelt.
Nur leider kann ich dazu nichts posten und habe daher ein neues Aufgemacht.

Mein Datei sieht so aus:

01.
C:\blat262_full\blat.exe -install Bobbie.Workstation  logfile@freenet.de 
02.
C:\blat262_full\blat.exe "C:\winziplog.txt" 
03.
-to tester@freenet.de -server mx.freenet.de -u xxx -pw xxx 
04.
-subject "Logfile fuer Backup"
Wenn ich diese Batchdatei jetzt ausführe bekomme ich folgende Fehlermeldung:

No target email address or newsgroup was specified. You must give an email address or usenet newsgroup to send messages to.
Use -to, -cc, -bcc option for email or -groups for usenet.
Aborting, nobody to send messages to.

Die Emailadressen stimmen und der Pop 3 Server ebenfalls.

Kann mir bitte jemand helfen, ich drehe mich im Kreis.

Danke
René
Mitglied: mrtux
02.03.2011 um 02:43 Uhr
Hi !

Bitte setze deine Batch Anweisungen in Code Tags damit man sie besser lesen kann. Es ist oben nämlich nicht ersichtlich ob Du die Parameter von blat.exe in eine Zeile gesetzt hast oder nicht.

mrtux
Bitte warten ..
Mitglied: anfaenger500
02.03.2011 um 08:48 Uhr
Zitat von mrtux:
Hi !

Bitte setze deine Batch Anweisungen in Code Tags damit man sie besser lesen kann. Es ist oben nämlich nicht ersichtlich ob Du
die Parameter von blat.exe in eine Zeile gesetzt hast oder nicht.

mrtux





Wurde umgesetzt!
Bitte warten ..
Mitglied: Crusher007
02.03.2011 um 09:23 Uhr
Moin anfaenger500!

Wie mrtux bereits schrieb; Die Anweisung muss in einer Zeile stehen, z.B.:

01.
blat.exe "C:\winzip.txt" -to tester@freenet.de -subject "Dies ist ein Test" -server mx.freenet.de -u xxx -pw xxx -mailfrom absender@freenet -replyto absender2@freenet.de -noh2 -sensitivity 2 -priority 1 -log logfile.log
Die Parameter -mailfrom, -replyto, -noh2, -priority & -log sind natürlich optional!

Greets Crusher
Bitte warten ..
Mitglied: danielfr
02.03.2011 um 09:33 Uhr
Hi, vielleicht reicht es ja, wenn Du mit -f SenderMailAddy noch die Mailadresse des Senders genau spezifizierst.
Gruß
Daniel
edit: sorry, dann muss man natürlich mailfrom weglassen.
Bitte warten ..
Mitglied: DerWoWusste
02.03.2011 um 12:58 Uhr
Vielleicht auch einen Blick wert: blatguy http://www.outlook-net.de/7-9-2.htm die GUI für blat, zum komfortablen erstellen einer Kommadozeile.
Bitte warten ..
Mitglied: anfaenger500
02.03.2011 um 19:33 Uhr
Erstmal an alle vielen Dank, jedoch hat es nicht geklappt.

Stelle den kompletten Pfad nochmal ein.
01.
C:\blat262_full\blat.exe -install BOBBIE. test@freenet.de 
02.
C:\blat262_full\blat.exe "C:\blatguy0.9.0.25\body.txt" -to logfile@freenet.de -server mx.freenet.de -u test -pw xxxxx -debug -timestamp -log blatSMTPlog.txt -subject "Blat Email-Test started 02-Maerz-2011 / 18:55:22"
Hier die Meldung von der Kommandozeile:
No target email address or newsgroup was specified. You must give an email address or usenet newsgroup to send messages to.
Use -to, -cc, -bcc option for email or -groups for usenet.
Aborting, nobody to send messages to.

Anbei noch das LogFile vom SMTP:
2011.03.02 19:01:19 (Wed)------------Start of Session-----------------
Blat v2.6.2 w/GSS encryption (build : Feb 25 2007 12:06:19)
2011.03.02 19:01:21 (Wed): <<<getline<<< 220 13.mx.freenet.de ESMTP Exim 4.72 Wed, 02 Mar 2011 19:01:24 +0100
2011.03.02 19:01:21 (Wed): >>>putline>>> EHLO Bobbie.freenet.de
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-13.mx.freenet.de Hello host-xxx-xxx-xxx-xxx.customer.t-online.de [xxx.xxx.xxx.xxx]
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-SIZE 209715200
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-8BITMIME
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-ETRN
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-PIPELINING
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-AUTH LOGIN PLAIN CRAM-MD5
2011.03.02 19:01:21 (Wed): <<<getline<<< 250-STARTTLS
2011.03.02 19:01:21 (Wed): <<<getline<<< 250 HELP
2011.03.02 19:01:24 (Wed): Sending C:\Dokumente und Einstellungen\Bobbie\Desktop\blatguy0.9.0.25\body.txt to logfile@freenet.de
2011.03.02 19:01:24 (Wed): Subject: Blat Email-Test started 02-Mõrz-2011 / 18:55:22
2011.03.02 19:01:24 (Wed): Login name is test@freenet.de
2011.03.02 19:01:24 (Wed): >>>putline>>> AUTH CRAM-MD5
2011.03.02 19:01:24 (Wed): <<<getline<<< 334 PDI0NDgyLjEyOTkwODg4ODhAMTMubXg+
2011.03.02 19:01:24 (Wed): >>>putline>>> cmVuZTE1NiAzZWU3NWQwNGIxYmFlMzEyOTMyMmJmMzllMmUxNjI5ZA==
2011.03.02 19:01:24 (Wed): <<<getline<<< 535 Incorrect authentication data
2011.03.02 19:01:24 (Wed): The SMTP server did not accept Auth CRAM-MD5 value.
Are your login userid and password correct?
2011.03.02 19:01:24 (Wed): >>>putline>>> AUTH PLAIN AHJlbmUxNTYAc2ljaGVyaGVpdA==
2011.03.02 19:01:24 (Wed): <<<getline<<< 535 Incorrect authentication data
2011.03.02 19:01:24 (Wed): The SMTP server did not accept Auth PLAIN value.
Are your login userid and password correct?
2011.03.02 19:01:24 (Wed): >>>putline>>> AUTH LOGIN
2011.03.02 19:01:24 (Wed): <<<getline<<< 334 VXNlcm5hbWU6
2011.03.02 19:01:24 (Wed): >>>putline>>> cmVuZTE1Ng==
2011.03.02 19:01:24 (Wed): <<<getline<<< 334 UGFzc3dvcmQ6
2011.03.02 19:01:24 (Wed): >>>putline>>> c2ljaGVyaGVpdA==
2011.03.02 19:01:24 (Wed): <<<getline<<< 535 Incorrect authentication data
2011.03.02 19:01:24 (Wed): The SMTP server did not accept Auth LOGIN PASSWD value.
2011.03.02 19:01:24 (Wed): >>>putline>>> QUIT
2011.03.02 19:01:25 (Wed): <<<getline<<< 221 13.mx.freenet.de closing connection
2011.03.02 19:01:25 (Wed)-------------End of Session------------------

Was kann ich noch verkehrt gemacht haben?
Bitte warten ..
Mitglied: anfaenger500
03.03.2011 um 00:17 Uhr
Diese Batchdatei hat geklappt
01.
:: Versand mit freenetadressen klappt nicht 
02.
:: Versand mit gmxadresse hat geklappt 
03.
 
04.
C:\blat262_full\blat.exe -install BOBBIE. absender@abc.de 
05.
C:\blat262_full\blat.exe "C:\blatguy0.9.0.25\body.txt" -to empfaenger@abc.de -server mail.gmx.net -u Benutzername -pw Kennwort -attach "C:\winziplog.txt" -debug -timestamp -log blatSMTPlog.txt -subject "Betreff"
Der Versand mit einer Freenet-Adresse hat nicht geklappt.
Der Versand mit einer GMX-Adresse hat ohne Probleme jingehauen.

Warum, vsl. hat Freenet bei der Authentifizierung eine Variable die von blat nicht unterstützt wird.
Bitte warten ..
Mitglied: BenediktXVII
21.08.2011 um 11:01 Uhr
Hallo Anfänger500,
ist das noch aktuell?
Verwende doch mal die komplette Sender-E-Mail-Adresse als Parameter vom Usernamen:
statt: -u test
so: -u test@freenet.de
wobei Du allerdings bei -install logfile@freenet.de angegeben hast.

Also mal mein funktionierender Aufruf, ohne eine -install -Zeile, User (-u) = Sender (-f):

Blat "body.txt" -f logfile@freenet.de -u logfile@freenet.de -pw xxxxx -subject "Blat E-Mail-Test" -to tester@freenet.de -server mx.freenet.de -port 25 -debug -timestamp -log "blatSMTPlogTest.txt" -attach "Testdat.TXT"

Benedikt
Bitte warten ..
Ähnliche Inhalte
E-Mail
Ersatz für BLAT gesucht (Kommandozeilen-eMail-Tool)
gelöst Frage von schmitziE-Mail2 Kommentare

Hallo admins, kennt jemand ein ähnliches Tool welchjeniges in der Lage ist, auch Mails per SMTPS (nur notfalls TLS) ...

E-Mail
Emailversand Postausgangsprüfung
Frage von acocalypsoE-Mail5 Kommentare

Guten Tag zusammen, aktuelle habe ich folgendes Problem: In meiner Firma werden Emails an div. Person / Bewerber verschickt, ...

Batch & Shell
Wie kann ich eine Mail über Blat versenden mit Batch
gelöst Frage von Dreamkiller112Batch & Shell8 Kommentare

Hallo, Hey ich benötige drigend Hilfe ich habe das Problem ich möchte eine Batch-Datei erstellen mit der ich eine ...

Batch & Shell
Mailing via blat aus verschiedenen Ordnern
Frage von hoffi3dBatch & Shell3 Kommentare

Guten Morgen, ich habe folgendes anliegen. Ich möchte ein Mailing via Blat.exe ) erstellen. Ausgangslage ist folgende, ich habe ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 5 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 6 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 8 StundenAdministrator.de Feedback9 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 13 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...