Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel-Abfrage

Frage Microsoft Microsoft Office

Mitglied: Pandamir

Pandamir (Level 1) - Jetzt verbinden

14.08.2013 um 16:57 Uhr, 4630 Aufrufe, 7 Kommentare, 1 Danke

Hallo, ich steh grad auf dem Schlauch.
Ich möchte eine Abfrage in Excel bauen und komme nicht weiter.
Meine Tabelle hat folgende Tabellenblätter:
- Artikel (Artikelnummer, Artikelname, Artikelbezeichnung)
- Kunde (Kundennummer, Kunde-Name, Kunde-Strasse, Kunde-PLZ, Kunde Ort)
- Bestellung (Menge, oben aufgeführte Spalten)

jetzt möchte ich gern in dem Blatt Bestellung nur die Menge des Artikels, die Artikelnummer sowie die Kundennummer eingeben.
Die restlichen Daten sollen automatisch aus den jeweiligen Tabellenblättern befüllt werden.
Ich habe es mit der Wenn-Dann-Sonst Formel versucht, leider wird dort wenn ich die Artikelnummer eintrage (genauso bei der Kundennummer) nur der Reihenfolge der Referenztabellen nach abgearbeitet. Soll heißen ich gebe in dem Tabellenblatt "Bestellungen" Spalte "Artikelnummer" Zeile 2 die Artikelnummer 0815 ein und er trägt mir dann Artikelname und Bezeichnung automatisch ein aber nur wenn sich die Artikelnummer im selben Feld des Tabellenblattes "Artikel" befindet. Ich benötige aber bei der Abfrage die Auswahl E2-Exxx, da ich ja irgeneine Artikelnummer eintragen möchte und er mir die Felder automatisch befüllen soll. die derzeitige Formel ist: =WENN(Bestellung!B2=(Artikel!A2:A30);Artikel!B2:B30).

Ich hoffe das war nicht allzu verwirrend und mir kann hier von einem der Cracks geholfen werden.
Die Suche war was meine Frage betraf nicht wirklich hilfreich und Frau "Google" schmeisst bei dem Thema Abfrage immer nur Access raus.

Viele Grüße
Panda
Mitglied: colinardo
14.08.2013 um 17:47 Uhr
Hallo Panda,
schau dir mal die Formel SVERWEIS an.
Hier ein Demo-Sheet dazu.

Grüße Uwe
Bitte warten ..
Mitglied: Metzger-MCP
14.08.2013, aktualisiert um 19:35 Uhr
Mahlzeit,
das ist relativ einfach und nicht problematisch dein Freund und Helfer ist der

Zitat von colinardo:
schau dir mal die Formel SVERWEIS an.

du baust selbigen wie folgt :

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; FALSCH)

Suchkriterium -> das was du suchst
Matrix -> der Bereich wo du suchst, 1 Spalte -> hier muss das Suchkriterium drin sein. Restspalten der Information die angezeigt werden sollen.
Spaltenindex -> die Spalte in der die anzuzeigende Info steht
FALSCH -> exakte Übereinstimmung @ Suchkriterium

Du musst für jede Zelle ( Info aus den anderen Tabellen ( Artikelname, ... ) ) , im Bestellungen-Blatt einen eigenen Sverweis aufbauen.

Ich mache es mal anhand der Blätter Atikel und Bestellungen

Artikel

Zelle A1 = NR
Zelle B1 = Name
Zelle C1 = Bezeichnung

Zelle A2 = 0815
Zelle B2 = CPU
Zelle C2 = I7 - 950

Zelle A3 = 0816
Zelle B3 = CPU
Zelle C3 = I7 - 960

Bestellungen

Zelle A1 = Menge
Zelle B1 = ART-NR
Zelle C1 = ART-Name
Zelle D1 = ART-Bezeichnung

Formeln in Zellen

Zelle A2 =
Zelle B2 =
Zelle C2 = =SVERWEIS(B2;Artikel!A2:C3;2;FALSCH)
Zelle D2 = =SVERWEIS(B2;Artikel!A2:C3;3;FALSCH)

Ergebniss mit den Eingaben

Zelle A2 = 10
Zelle B2 = 0815
Zelle C2 = CPU
Zelle D2 = I7 - 950
MFG Uwe
Bitte warten ..
Mitglied: Pandamir
14.08.2013 um 21:03 Uhr
Hallo,

vieeeeelen Dank das funktioniert perfekt. Nur ein Problem habe ich derzeit noch.
Ich kopiere die Formel zwischen den Zellen was solange gut geht wie die Felder in der Referenztabelle auch beschrieben sind. Sobald dort die Referenzzelle leer ist werden die Einträge nicht übernommen das sich die nachfolgende Zelle auf die vorhergehende bezieht. Kann ich das irgendwie umgehen, dass wenn kein Eintrag da ist dass er dort nichts macht und nur die Zellen übernimmt in denen etwas drin steht?
Bsp:
Zelle D2: =SVERWEIS(C2;Artikel!A1:C500;2;FALSCH)
Zelle D3: =SVERWEIS(C3;Artikel!A2:C501;2;FALSCH)
Zelle D4: =SVERWEIS(C4;Artikel!A3:C502;2;FALSCH)

Was ich verstanden habe ist dass das Suchfeld immer in meinem Fall die Spalte "C" ist. Der Suchbereich soll sich allerdings nur auf den Bereich A1 bis C500 beziehen. Gibt es eine Möglichkeit das automatische Hochzählen der Spalten A und C zu verhindern?

Viele Grüße
Panda
Bitte warten ..
Mitglied: Metzger-MCP
14.08.2013 um 21:09 Uhr
Hallo ;)

na sicher Bereich Festsetz dafür dienen die $ im Zell defi....

$A$1:$C$500

$a$1 -> setzt beides fest a1 a1 a1 a1 a1
a$1 -> setzt 1 fest -> a1 b1 c1 d1 ...
$a1 -> setzt a fest -> a1 a2 a3 a4 ...
a1 -> setzt nichts fest a1 a2 b1 b2 ....

MFG Uwe
Bitte warten ..
Mitglied: Pandamir
15.08.2013 um 17:54 Uhr
Hallo Uwe,

du scheinst wirklich der Excelgott zu sein.
Kannst du mir noch bei folgendem Problem helfen?
Die Formel soweit funktioniert, aber nur dann wenn auch alle Felder befüllt sind.
Sobald ich ein Feld nicht befülle z.B. Artikelbezeichnung in der Referenztabelle, befüllt er mir die Folgefelder in der Abfragetabelle nicht mehr.
Als Wert wird dann "0" eingetragen und die Folgefelder mit "NV" befüllt.

Viele Grüße
Panda
Bitte warten ..
Mitglied: Pandamir
15.08.2013 um 18:20 Uhr
Hab den Fehler selbst gefunden. Hatte den Spaltenindex falsch gesetzt. Entsprechend angepasst funktioniert alles.

Danke an alle
Bitte warten ..
Mitglied: Metzger-MCP
15.08.2013 um 18:59 Uhr
Hallo Panda ;)

gerne doch ... habe gerade aber erst die Meldung bekommen ... wenn du den Fehler aber schon hast ...

LG Uwe
Bitte warten ..
Ähnliche Inhalte
VB for Applications
DB-Abfrage in Excel mit Kriterien aus Excel
gelöst Frage von JensDNDVB for Applications11 Kommentare

Hallo Admins, hab grad folgendes Problem: Es sollen Daten aus einer DB mittels Excel abgerufen werden. Soweit klappt das ...

VB for Applications
SNMP Abfrage in EXCEL über VBA
Frage von SebastianLVB for Applications7 Kommentare

Hallo Zusammen, Erstmal zum Sachverhalt: Ich habe mehrere Drucker (ca. 50) die über SNMP ansprechbar sind. Mein Ziel ist ...

VB for Applications
Excel Macro ODBC Abfrage
gelöst Frage von highpriestVB for Applications7 Kommentare

Hallo Experten! Da ich nicht viel Ahnung davon habe, bitte ich Euch um Hilfe. Ich suche nach eine Möglichkeit ...

VB for Applications
Excel Wert Abfrage
gelöst Frage von Florian86VB for Applications3 Kommentare

Hallo, ich möchte über ein Makro eine Abfrage machen leider komme ich nicht zum gewünschten Ergebnis. Ich habe 2 ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office9 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner15 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...