Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel-Abfrage

Frage Microsoft Microsoft Office

Mitglied: Pandamir

Pandamir (Level 1) - Jetzt verbinden

14.08.2013 um 16:57 Uhr, 4384 Aufrufe, 7 Kommentare, 1 Danke

Hallo, ich steh grad auf dem Schlauch.
Ich möchte eine Abfrage in Excel bauen und komme nicht weiter.
Meine Tabelle hat folgende Tabellenblätter:
- Artikel (Artikelnummer, Artikelname, Artikelbezeichnung)
- Kunde (Kundennummer, Kunde-Name, Kunde-Strasse, Kunde-PLZ, Kunde Ort)
- Bestellung (Menge, oben aufgeführte Spalten)

jetzt möchte ich gern in dem Blatt Bestellung nur die Menge des Artikels, die Artikelnummer sowie die Kundennummer eingeben.
Die restlichen Daten sollen automatisch aus den jeweiligen Tabellenblättern befüllt werden.
Ich habe es mit der Wenn-Dann-Sonst Formel versucht, leider wird dort wenn ich die Artikelnummer eintrage (genauso bei der Kundennummer) nur der Reihenfolge der Referenztabellen nach abgearbeitet. Soll heißen ich gebe in dem Tabellenblatt "Bestellungen" Spalte "Artikelnummer" Zeile 2 die Artikelnummer 0815 ein und er trägt mir dann Artikelname und Bezeichnung automatisch ein aber nur wenn sich die Artikelnummer im selben Feld des Tabellenblattes "Artikel" befindet. Ich benötige aber bei der Abfrage die Auswahl E2-Exxx, da ich ja irgeneine Artikelnummer eintragen möchte und er mir die Felder automatisch befüllen soll. die derzeitige Formel ist: =WENN(Bestellung!B2=(Artikel!A2:A30);Artikel!B2:B30).

Ich hoffe das war nicht allzu verwirrend und mir kann hier von einem der Cracks geholfen werden.
Die Suche war was meine Frage betraf nicht wirklich hilfreich und Frau "Google" schmeisst bei dem Thema Abfrage immer nur Access raus.

Viele Grüße
Panda
Mitglied: colinardo
14.08.2013 um 17:47 Uhr
Hallo Panda,
schau dir mal die Formel SVERWEIS an.
Hier ein Demo-Sheet dazu.

Grüße Uwe
Bitte warten ..
Mitglied: Metzger-MCP
14.08.2013, aktualisiert um 19:35 Uhr
Mahlzeit,
das ist relativ einfach und nicht problematisch dein Freund und Helfer ist der

Zitat von colinardo:
schau dir mal die Formel SVERWEIS an.

du baust selbigen wie folgt :

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; FALSCH)

Suchkriterium -> das was du suchst
Matrix -> der Bereich wo du suchst, 1 Spalte -> hier muss das Suchkriterium drin sein. Restspalten der Information die angezeigt werden sollen.
Spaltenindex -> die Spalte in der die anzuzeigende Info steht
FALSCH -> exakte Übereinstimmung @ Suchkriterium

Du musst für jede Zelle ( Info aus den anderen Tabellen ( Artikelname, ... ) ) , im Bestellungen-Blatt einen eigenen Sverweis aufbauen.

Ich mache es mal anhand der Blätter Atikel und Bestellungen

Artikel

Zelle A1 = NR
Zelle B1 = Name
Zelle C1 = Bezeichnung

Zelle A2 = 0815
Zelle B2 = CPU
Zelle C2 = I7 - 950

Zelle A3 = 0816
Zelle B3 = CPU
Zelle C3 = I7 - 960

Bestellungen

Zelle A1 = Menge
Zelle B1 = ART-NR
Zelle C1 = ART-Name
Zelle D1 = ART-Bezeichnung

Formeln in Zellen

Zelle A2 =
Zelle B2 =
Zelle C2 = =SVERWEIS(B2;Artikel!A2:C3;2;FALSCH)
Zelle D2 = =SVERWEIS(B2;Artikel!A2:C3;3;FALSCH)

Ergebniss mit den Eingaben

Zelle A2 = 10
Zelle B2 = 0815
Zelle C2 = CPU
Zelle D2 = I7 - 950
MFG Uwe
Bitte warten ..
Mitglied: Pandamir
14.08.2013 um 21:03 Uhr
Hallo,

vieeeeelen Dank das funktioniert perfekt. Nur ein Problem habe ich derzeit noch.
Ich kopiere die Formel zwischen den Zellen was solange gut geht wie die Felder in der Referenztabelle auch beschrieben sind. Sobald dort die Referenzzelle leer ist werden die Einträge nicht übernommen das sich die nachfolgende Zelle auf die vorhergehende bezieht. Kann ich das irgendwie umgehen, dass wenn kein Eintrag da ist dass er dort nichts macht und nur die Zellen übernimmt in denen etwas drin steht?
Bsp:
Zelle D2: =SVERWEIS(C2;Artikel!A1:C500;2;FALSCH)
Zelle D3: =SVERWEIS(C3;Artikel!A2:C501;2;FALSCH)
Zelle D4: =SVERWEIS(C4;Artikel!A3:C502;2;FALSCH)

Was ich verstanden habe ist dass das Suchfeld immer in meinem Fall die Spalte "C" ist. Der Suchbereich soll sich allerdings nur auf den Bereich A1 bis C500 beziehen. Gibt es eine Möglichkeit das automatische Hochzählen der Spalten A und C zu verhindern?

Viele Grüße
Panda
Bitte warten ..
Mitglied: Metzger-MCP
14.08.2013 um 21:09 Uhr
Hallo ;)

na sicher Bereich Festsetz dafür dienen die $ im Zell defi....

$A$1:$C$500

$a$1 -> setzt beides fest a1 a1 a1 a1 a1
a$1 -> setzt 1 fest -> a1 b1 c1 d1 ...
$a1 -> setzt a fest -> a1 a2 a3 a4 ...
a1 -> setzt nichts fest a1 a2 b1 b2 ....

MFG Uwe
Bitte warten ..
Mitglied: Pandamir
15.08.2013 um 17:54 Uhr
Hallo Uwe,

du scheinst wirklich der Excelgott zu sein.
Kannst du mir noch bei folgendem Problem helfen?
Die Formel soweit funktioniert, aber nur dann wenn auch alle Felder befüllt sind.
Sobald ich ein Feld nicht befülle z.B. Artikelbezeichnung in der Referenztabelle, befüllt er mir die Folgefelder in der Abfragetabelle nicht mehr.
Als Wert wird dann "0" eingetragen und die Folgefelder mit "NV" befüllt.

Viele Grüße
Panda
Bitte warten ..
Mitglied: Pandamir
15.08.2013 um 18:20 Uhr
Hab den Fehler selbst gefunden. Hatte den Spaltenindex falsch gesetzt. Entsprechend angepasst funktioniert alles.

Danke an alle
Bitte warten ..
Mitglied: Metzger-MCP
15.08.2013 um 18:59 Uhr
Hallo Panda ;)

gerne doch ... habe gerade aber erst die Meldung bekommen ... wenn du den Fehler aber schon hast ...

LG Uwe
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(6)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
VB for Applications
gelöst VBA Excel Recordset - Abfrage auf SQL-Server (4)

Frage von Aximand zum Thema VB for Applications ...

C und C++
gelöst IF Abfrage funktioniert nicht mehr (2)

Frage von pablovic zum Thema C und C ...

Microsoft Office
gelöst Excel: Text in Zellbereich prüfen mit Vergleichstext ggf. mit Exact-Funktion (5)

Frage von Michi1 zum Thema Microsoft Office ...

VB for Applications
Excel VBA Sortierung von Daten (5)

Frage von easy4breezy zum Thema VB for Applications ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (17)

Frage von Unwichtig zum Thema Netzwerkmanagement ...