Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Excel: Exakte Übereinstimmung finden

Frage Microsoft Microsoft Office

Mitglied: ralfkausk

ralfkausk (Level 1) - Jetzt verbinden

19.01.2015, aktualisiert 14:42 Uhr, 1339 Aufrufe, 3 Kommentare

Hallo zusammen

Ich bräuchte mal Hilfe bei einem Excel Problem.

Ich habe eine Liste mit Benutzernamen
01.
LogonName	hansPrincipalName	NTAccountName	        SamAccountName 
02.
hans.dampf	hans.dampf@domäne	domäne\hans.dampf	hans.dampf 
03.
jupp.dupp	jupp.dupp@domäne	domäne\jupp.dupp1	jupp.dupp
Wie man sehen kann hat sich in Zeile zwei (3) ein Fehler eingeschlichen: jupp.dupp2 anstatt jupp.dupp

Da die gesamte Tabelle mehr als 6000 Zeilen hat dachte ich mir ich mache das über eine Funktion.
Versucht habe ich:
01.
=VERGLEICH(A2;B2:D2;0)
Funktioniert leider nicht, da der Wert aus Zelle A2 auch in C2 enthalten ist.
Wie kann ich in Excel eine Exakte übereinstimmung suchen/finden?
Kann mir jemand helfen?

Gruß Ralf
Mitglied: Andinistrator1
19.01.2015 um 14:35 Uhr
Hallo Ralf,

z.B. könntest du eine neue Spalte machen mit

=WENN(A4=B4; "0";"1")

Jetzt hast du eine neue Spalte in welcher irendwelche 1er drinstehen, über den Autofilter nimmst du genau diese raus, d.h. 1 = A ist ungleich B, damit solltest du alle haben.
Bitte warten ..
Mitglied: ralfkausk
19.01.2015 um 14:44 Uhr
Hallo Administrator1

Sorry, mir ist da eben ein Fehler unterlaufen.
Es stehen nicht nur die Namen in der Tabelle sondern auch noch die Domänennamen.
Gibt es dafür auch eine Lösung

(siehe korrigierte Tabelle)
Bitte warten ..
Mitglied: bastla
19.01.2015 um 15:11 Uhr
Hallo ralfkausk!

Für die Spalte D sollte ja der Vorschlag von Andinistrator1 passen, und für die Spalte B könntest Du
=WENN(A2=LINKS(B2;SUCHEN("@";B2)-1);0;1)
bzw für die Spalte C
=WENN("\"&A2=RECHTS(C2;LÄNGE(A2)+1);0;1)
nach dem gleichen Schema verwenden ...

Grüße
bastla
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Microsoft Office
gelöst Excel: Text in Zellbereich prüfen mit Vergleichstext ggf. mit Exact-Funktion (5)

Frage von Michi1 zum Thema Microsoft Office ...

VB for Applications
Excel VBA Sortierung von Daten (5)

Frage von easy4breezy zum Thema VB for Applications ...

Microsoft Office
gelöst Excel-Formel oder VBA (7)

Frage von nicki01 zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...