Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Excel: Exakte Übereinstimmung finden

Frage Microsoft Microsoft Office

Mitglied: ralfkausk

ralfkausk (Level 1) - Jetzt verbinden

19.01.2015, aktualisiert 14:42 Uhr, 1772 Aufrufe, 3 Kommentare

Hallo zusammen

Ich bräuchte mal Hilfe bei einem Excel Problem.

Ich habe eine Liste mit Benutzernamen
01.
LogonName	hansPrincipalName	NTAccountName	        SamAccountName 
02.
hans.dampf	hans.dampf@domäne	domäne\hans.dampf	hans.dampf 
03.
jupp.dupp	jupp.dupp@domäne	domäne\jupp.dupp1	jupp.dupp
Wie man sehen kann hat sich in Zeile zwei (3) ein Fehler eingeschlichen: jupp.dupp2 anstatt jupp.dupp

Da die gesamte Tabelle mehr als 6000 Zeilen hat dachte ich mir ich mache das über eine Funktion.
Versucht habe ich:
01.
=VERGLEICH(A2;B2:D2;0)
Funktioniert leider nicht, da der Wert aus Zelle A2 auch in C2 enthalten ist.
Wie kann ich in Excel eine Exakte übereinstimmung suchen/finden?
Kann mir jemand helfen?

Gruß Ralf
Mitglied: Andinistrator1
19.01.2015 um 14:35 Uhr
Hallo Ralf,

z.B. könntest du eine neue Spalte machen mit

=WENN(A4=B4; "0";"1")

Jetzt hast du eine neue Spalte in welcher irendwelche 1er drinstehen, über den Autofilter nimmst du genau diese raus, d.h. 1 = A ist ungleich B, damit solltest du alle haben.
Bitte warten ..
Mitglied: ralfkausk
19.01.2015 um 14:44 Uhr
Hallo Administrator1

Sorry, mir ist da eben ein Fehler unterlaufen.
Es stehen nicht nur die Namen in der Tabelle sondern auch noch die Domänennamen.
Gibt es dafür auch eine Lösung

(siehe korrigierte Tabelle)
Bitte warten ..
Mitglied: bastla
19.01.2015 um 15:11 Uhr
Hallo ralfkausk!

Für die Spalte D sollte ja der Vorschlag von Andinistrator1 passen, und für die Spalte B könntest Du
=WENN(A2=LINKS(B2;SUCHEN("@";B2)-1);0;1)
bzw für die Spalte C
=WENN("\"&A2=RECHTS(C2;LÄNGE(A2)+1);0;1)
nach dem gleichen Schema verwenden ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Apache Server
gelöst Exaktes Matching bei RewriteCond (2)

Frage von qwertz1 zum Thema Apache Server ...

VB for Applications
gelöst DB-Abfrage in Excel mit Kriterien aus Excel (11)

Frage von JensDND zum Thema VB for Applications ...

Microsoft Office
Excel - Summe einer Formel mit einer enthaltenen Reihe mit Dezimalzahl (10)

Frage von Traxtormer zum Thema Microsoft Office ...

Microsoft Office
Hilfe bei Erstellung eines Suchfelds im Excel (1)

Frage von ZeeRee zum Thema Microsoft Office ...

Neue Wissensbeiträge
Mac OS X

Apple hat macOS High Sierra veröffentlicht

Information von Frank zum Thema Mac OS X ...

Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

(4)

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(7)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Windows 10
gelöst Netzwerkkarte schaltet sich erst nach dem Logon ein (24)

Frage von DerWoWusste zum Thema Windows 10 ...

Windows Server
Seit IP Umstellung DC DNS Fehler (19)

Frage von Yaimael zum Thema Windows Server ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (15)

Frage von Voiper zum Thema Weiterbildung ...