Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Excel Text von Zahlen trennen

Frage Microsoft Microsoft Office

Mitglied: Martinoli

Martinoli (Level 1) - Jetzt verbinden

13.09.2013 um 11:10 Uhr, 9644 Aufrufe, 6 Kommentare

Hallo zusammen

Ich hab eine Frage

Ich habe eine Excel Tabelle auf der die Grössen von Datein stehen (zb. 380.0K).
Ich muss jetzt alle in MB verwandeln (also K/1024 und G*1024).
Dabei hab ich zwei probleme, und zwar:

1. Wie kann ich das "K","M","G" von der Zahl trennen (es hat manchmal auch Kommas vor der Grösse also 1.1M oder 15.8G zb, und es sind nicht alle gleich lang)
2. Wie kann ich dann einstellen das alle Spalten mit "K" / 1024 und alle Spalten mit "G" * 1024 gerechnet werden?

Danke schon im Vorraus

-Martinoli

PS: Ich habe Excel 2010 und Tabelle sieht so aus:

1. | 1.1M
2. | 380.0K
3. | 380.0K
4. | 1.8G
5. | 1.1M
6. | 666.5M
7. | 380.0K
8. | 2.1G
Mitglied: BirdyB
13.09.2013 um 11:58 Uhr
Hallo Martinoli,

Text und Zahlen trennen solltest du mit Hilfe dieser Anleitung: http://www.excelformeln.de/formeln.html?welcher=101 können. Wenn es immer nur ein Buchstabe ist, müsstest du auch mit der Funktion RECHTS den einzelnen Buchstaben abtrennen können.
Die Umrechnung kannst du einfach mit einer WENN-Formel realisieren.

Beste Grüße

Berthold
Bitte warten ..
Mitglied: Martinoli
13.09.2013 um 12:09 Uhr
Hallo Bernhold

Danke für deine Antwort, aber der Buchstabe sollen nachher noch da stehen und es soll in der gleichen Zeile bleiben.
Sie sollen nur um ein Leerzeichen "rutschen"
Von:
380.0K
1.1M
15.6G

Zu:
380.0_K
1.1_M
15.6_G

_ = Leerzeichen

-Martinoli
Bitte warten ..
Mitglied: colinardo
13.09.2013, aktualisiert um 12:17 Uhr
Zitat von Martinoli:
Sie sollen nur um ein Leerzeichen "rutschen"
ABC
380.0K =LINKS(A1;LÄNGE(A1)-1) & " " & RECHTS(A1;1) =WENN(RECHTS(A1;1)="K";WERT(WECHSELN(LINKS(A1;LÄNGE(A1)-1);".";","))/1024;WENN(RECHTS(A1;1)="G";WERT(WECHSELN(LINKS(A1;LÄNGE(A1)-1);".";","))*1024;WERT(WECHSELN(LINKS(A1;LÄNGE(A1)-1);".";","))))

Spalte B ist der Wert mit dem Buchstaben um ein Leerzeichen erweitert, und Spalte C die abhängige Berechnung je nachdem ob "K" oder "G"

Grüße Uwe
Bitte warten ..
Mitglied: LianenSchwinger
13.09.2013 um 12:18 Uhr
Hallo,

für die Umrechnung der Werte auf "M" geht folgendes:

01.
=WENN(RECHTS(A1;1)="G";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;","))*1024;WENN(RECHTS(A1;1)="K";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;","))/1024;WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;","))))
G Jörg
Bitte warten ..
Mitglied: Martinoli
13.09.2013 um 14:01 Uhr
Zitat von LianenSchwinger:
=WENN(RECHTS(A1;1)="G";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;","))*1024;WENN(RECHTS(A1;1)="K";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;","))/1024;WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;","))))

Danke für die Hilfe
Ich musste zwar es noch ein bisschen bearbeiten aber jetzt funktioniert es

Bearbeite Version:
=WENN(RECHTS(A1;1)="G";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;"."))*1024;
WENN(RECHTS(A1;1)="K";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;"."))/1024;
WENN(RECHTS(A1;1)="M";WERT(ERSETZEN(LINKS(A1;LÄNGE(A1)-1);FINDEN(".";A1);1;".")))))

@colinardo

Das mit dem Leerzeichen hat geklappt, aber ist jetzt überflüssig (ich dachte man MUSS den Abstand machen um zu rechnen).

Danke Leute

-Martinoli
Bitte warten ..
Mitglied: Biber
13.09.2013, aktualisiert um 17:12 Uhr
Moin Martinoli,

etwas einfacher ginge die Formel schon IMHO.

01.
=RUNDEN(WECHSELN(LINKS(A1;LÄNGE(A1)-1);".";",")*VERWEIS(RECHTS(A1;1);{"G";"K";"M"}; {1024;0,0009756;1});1)
...rechnet auch alles um in MByte mit einer Nachkommastelle.

Beispiel:
380.0K --> 0,4	 
1.8G --> 1843,2	 
1.1M	--> 1,1	 
666.5M--> 666,5	 
380.0K --> 0,4	 
2.1G	--> 2150,4	
Und ist etwas kürzer als dieses dreizeilige Gestrunkele oben.

Zu beachten ist nur, dass ich beim Arbeiten mit Arraykonstanten eben auch nur -nomen est omen - Konstanten verwenden darf.
Der Wert "0,0009756" in VERWEIS(RECHTS(A1;1);{"G";"K";"M"}; {1024;0,0009756;1}) entspricht natürlich einem 1/1024 oder 1024^-1.
Aber das kann ich der Formel nicht errechnen.

Grüße
Biber
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Excel - Ganze Zahlen werden nicht korrekt angenommen (2)

Frage von Cometcola zum Thema Microsoft Office ...

Microsoft Office
gelöst EXCEL: Zahlen aufrunden volle Tausenderstelle (10)

Frage von sims zum Thema Microsoft Office ...

VB for Applications
gelöst Excel - VBA - Fusszeile Text und Grafik (1)

Frage von Juckie zum Thema VB for Applications ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Rechtliche Fragen
gelöst Geschäftsführer Email gefaked (18)

Frage von xbast1x zum Thema Rechtliche Fragen ...

Vmware
VMware ESX - Start einer VM verhindern (16)

Frage von emeriks zum Thema Vmware ...

iOS
IPhone wird ferngesteuert Hacker? (15)

Frage von Akcent zum Thema iOS ...

Vmware
gelöst Update auf ESXI 6.5 Installieren (15)

Frage von zeroblue2005 zum Thema Vmware ...