Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

excel unklarheit

Frage Microsoft Microsoft Office

Mitglied: KrasserItFreak

KrasserItFreak (Level 1) - Jetzt verbinden

13.08.2007, aktualisiert 23:28 Uhr, 2990 Aufrufe, 7 Kommentare

ich möchte dass bei excel wenn ich eine zahl eingebe eine abfrage gestartet wird

das soll herauskommen

<199 0%
200-599 3%
600-1199 6%
1200-2399 9%
2400-3999 12%
4000-6999 15%
7000-9999 18%
10000>> 21%

wie muss ich das in excel definieren dass ich die richtigen prozentwerte bekomme?

habe es mit folgender abfrage probiert aber geht nicht:
01.
=WENN(F3<200;0;WENN(F3>=200&F3<600;3;WENN(F3>=600&F3<1200;6;WENN(F3>=1200&F3<2400;9;WENN(F3>=2400&F3<4000;12;WENN(F3>=4000&F3<7000;15;WENN(F3>=7000&F3<10000;18;21)))))))
bitte hilfestellungen geben
Mitglied: Alforno
13.08.2007 um 19:43 Uhr
Soweit ich weiß lässt sich die WENN Anweisung nur 7 oder 8 mal verkschachteln.
Ich weiß nicht ob du dich ein wenig mit vba auskennst, da wäre das schnell gemacht.

Sonst probiere das hier:

http://www.office-loesung.de/ftopic74022_0_0_asc.php

mfg
Alforno
Bitte warten ..
Mitglied: bastla
13.08.2007 um 19:58 Uhr
Hallo KrasserItFreak und Alforno!

Der Link war schon nicht schlecht, da er indirekt zu diesem Thread mit der sinnvollen Lösung SVERWEIS (im vorletzten Kommentar der ersten Seite) führt:
http://www.office-loesung.de/ftopic33270_0_0_asc.php

Grüße
bastla
Bitte warten ..
Mitglied: bastla
13.08.2007 um 20:18 Uhr
... oder, um es gleich konkret zu machen: Baue eine kleine Tabelle aus den beiden Spalten "ab Menge" und "Satz" (zB ab M2 oder auch in einem anderen Tabellenblatt) auf und befülle sie mit den entsprechenden Wertepaaren:

MN
2ab MengeSatz
300%
42003%
56006%
612009%
7240012%
8400015%
9700018%
101000021%

Wichtig ist bei dieser Tabelle, dass sie immer mit der Untergrenze eines Bereiches (und daher gleich mit 0) beginnt und aufsteigend sortiert ist.

Verwende dann in G3 die Formel
01.
=SVERWEIS(F3;$M$3:$N$10;2)
wobei der zweite Parameter nur die Daten (ab M3) ohne Überschriften (in M2 und N2) umfassen darf.

Grüße
bastla
Bitte warten ..
Mitglied: Biber
13.08.2007 um 22:30 Uhr
Na, KrosserITFreak,

ein oder zwei Varianten hätte ich auch noch...

Am knackigsten finde ich die hier:
01.
=WAHL(VERGLEICH($F3;{0;200;600;1200;2400;4000;7000;10000};1);0;3;6;9;12;15;18;21)
[Es werden Integer-Werte geliefert; ich unterstelle eine Formatierung auf Prozent]

Btw, eigentlich habe ich mich nur angemeldet, weil ich diesen Beitrag mal von "Betriebssysteme" nach "Excel-Krams" verschieben wollte.

Gruß
Biber
Bitte warten ..
Mitglied: bastla
13.08.2007 um 22:48 Uhr
@Biber

Da "knackig" ja sicher nicht als Synonym für "wartbar" gemeint ist, gefällt mir der Ansatz als "Oneliner" wirklich sehr gut ...

Grüße
bastla
Bitte warten ..
Mitglied: Biber
13.08.2007 um 22:56 Uhr
@bastla

Okay, erwischt...
ich würde natürlich Deine Hilfstabelle nehmen und dann Namen vergeben für MaxWerte (=M2:M10) bzw. Prozent (=N2:N10) und dann schreiben:
01.
=WAHL(VERGLEICH(F3;MaxWerte;1);Prozente)
Sinngemäß zumindest... müsste Excel ja mitmachen...
Ist aber ungetestet. *zugeb

Grüße
Biber
Bitte warten ..
Mitglied: bastla
13.08.2007 um 23:28 Uhr
@Biber

Mit INDEX() ginge es tatsächlich:
01.
=INDEX(Prozente;VERGLEICH(F3;MaxWerte;1))
Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
VB for Applications
gelöst DB-Abfrage in Excel mit Kriterien aus Excel (11)

Frage von JensDND zum Thema VB for Applications ...

Microsoft Office
Excel 2016 - Verknüpfung zu anderer Excel Datei automatisch aktualisieren (2)

Frage von devil7974 zum Thema Microsoft Office ...

Microsoft Office
Excel 2010 - Microsoft Excel kann die Daten nicht kopieren (4)

Frage von EDV-Oellerking zum Thema Microsoft Office ...

Batch & Shell
gelöst Excel Farblich (3)

Frage von 131181 zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows 10

Heise Newsticker: Microsoft veröffentlicht das "Fall Creators Update

(8)

Information von Penny.Cilin zum Thema Windows 10 ...

LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (16)

Frage von sunics zum Thema Hosting & Housing ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...