Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange 2010 aktualisiert Datenbank nicht im laufenden Betrieb

Frage Microsoft Exchange Server

Mitglied: ms160382

ms160382 (Level 1) - Jetzt verbinden

29.08.2012 um 10:26 Uhr, 3979 Aufrufe, 11 Kommentare

Hallo,

ich habe folgendes Problem. Ich habe einen Exchange 2010 SP2 Rollup 4 (Version 14.2 (Build 247.5)) unter Windows Server 2008 R2 Enterprise laufen. Zwei Postfachdatenbanken und eine Public Folder Database.

Vor zwei Wochen ist mir aufgefallen, dass die Datenbankdateien nicht mehr geändert werden. Das Änderungsdatum der Datenbank lag weit in der Vergangenheit. Ich habe dann die Einbindung der Datenbanken aufgehoben und mit eseutil geprüft. Dabei wurden keine Fehler festgestellt. Ich habe dann die Datenbanken wieder eingebunden. Dies hat sehr lang gedauert, weil mehrere Tage Protokolldateien in die Datenbanken geschrieben wurden. Im Ereignislog finde ich keine Fehlermeldungen und sonst scheint es auch keine Fehler zu geben.

Gestern habe ich die selbe Prozedur wiederholt, weil wieder mehrere Tage nicht in die Datenbanken geschrieben wurde. Heute habe ich wieder auf dem Server nachgesehen und die Datenbankdateien sind gestern, nach dem erneuten Einbinden das letzte mal geändert worden.

Kann sich jemand erklären, was hier "faul" sein könnte?
Mitglied: d4shoerncheN
29.08.2012 um 10:37 Uhr
Hallo,

könnte mich nun irren, aber wieso sollte sich die Datenbank ansich auch ändern? Das Änderungsdatum meiner Datenbank ist auch von Februar 2012. Hat ja, meiner Meinung nach, nichts mit irgendwelchen Änderungen zu tun die man innerhalb des Exchange tätigt.

Gruß
Bitte warten ..
Mitglied: 2hard4you
29.08.2012 um 10:40 Uhr
Moin,

wie machst Du das Backup Deines Exchange?

Bei einem ordnungsgemäßen Backup werden die Logs in die Datenbank geschrieben...

Gruß

24
Bitte warten ..
Mitglied: d4shoerncheN
29.08.2012, aktualisiert um 10:45 Uhr
Hallo,

ich mache das Backup über BackupAssist. Wenn ich die Datenbank aufrufe, zeigt er auch folgendes an:

Letzte vollständige Sicherung: Dienstag, 28. August 2012 23:03:49
Geändert: Dienstag, 14. Februar 2012 14:29:53

Von daher würde ich oben beschriebenes nicht als Fehler ansehen, außer auch ich habe diesen Fehler.

Gruß
@d4shoerncheN

NACHTRAG 10:45 Uhr
Nun ist die Frage, wie er es überprüft.

Geht er in folgenden Pfad
C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database\
und guckt sich das Änderungsdatum der Mailbox Database.edb an - dann sollte das Datum aktuell sein.

Oder geht er über die Exchange-Console
Organisationskonfiguration -> Postfach -> Rechtsklick auf "Mailbox Database" -> Eigenschaften
Bitte warten ..
Mitglied: ms160382
29.08.2012 um 11:02 Uhr
Danke für eure Antworten. Ich sicher den Exchange mit Symantec Backup Exec 2010.
Das Änderungsdatum ist von der Datenbankdatei unter D:\Exch-Databases\xyz.edb.

Ich kann mich daran erinnern, dass zu Anfang und auch noch vor ein paar Wochen die *.edb regelmäßig geändert wurde.
Bitte warten ..
Mitglied: d4shoerncheN
29.08.2012 um 11:06 Uhr
Hallo,

Ich kann mich daran erinnern, dass zu Anfang und auch noch vor ein paar Wochen die *.edb regelmäßig geändert wurde.
Wenn man es direkt im Pfad überprüft, sollte dies auch so sein.

Hast du das Update-Rollup vor kurzem erst eingespielt? Schau mal nach, ob er eventuell dadurch den Standard-Pfad (siehe mein Post oben) wieder verwendet. Wie mir scheint, habt ihr den Pfad ja geändert.

Gruß
Bitte warten ..
Mitglied: ms160382
29.08.2012 um 11:14 Uhr
Ja wir haben das Update-Rollup vor zwei Wochen eingespielt.

Wir haben die Datenbanken auf einer seperaten Festplatte und die Logfiles wiederum auf einer anderen Festplatte.
Die Datenbanken und Logfiles liegen auch nach dem Update noch an der Stelle, wo sie liegen sollen.

Ich probiere es jetzt mal mit einem Windowsbackup und schaue, was dann passiert.

Gruß
Bitte warten ..
Mitglied: Ausserwoeger
29.08.2012 um 12:03 Uhr
Hi

Ich habe genau die selbe Konfigurtion wie du Exchange 2010 Logs und Datenbank auf einem anderen laufwerk ! Sicherungssoftware Backup Exec 2010

Bei mir werden bei jeder Vollsicherung die Logs in die Datenbank übertragen. Ich hatte aber das selbe Problem wie du bereits bei anderen Kunden. Bei mir lag es immer am Backup Exec 2010 das die Logs nicht in die Datenbank übertragen wurde. Nach einem Update auf BE 2010 R3 gibt es den Fehler allerdings nicht mehr.

LG
Bitte warten ..
Mitglied: ms160382
29.08.2012 um 15:19 Uhr
Zitat von Ausserwoeger:
Nach einem Update auf BE 2010 R3 gibt es den Fehler allerdings nicht mehr.

Hallo Ausserwoeger,

das Backup Exec ist 2010 R3 mit allen Patches. Die Logs werden nach einer Sicherung auch in die DB geschrieben. Jedoch sichern wir nur einmal die Woche komplett, da die Sicherung ca. 17 Stunden dauert. Unter der Woche werden nur die Protokolle stündlich gesichert.

@ d4shoerncheN
Die Windowssicherung scheint die Protokolle auch erst in die Datenbank zu schreiben, wenn die Protokolldateien danach gelöscht werden. Dies wollte ich jetzt aber nicht testen, weil sonst die Sicherung mit BackupExec quer schießt.
Bitte warten ..
Mitglied: Ausserwoeger
29.08.2012 um 15:36 Uhr
Dann sollten die Protokolle auch jede Woche in die Datenbank übertragen werden.

Wenn du jeden tag die Daten übertragen haben willst solltest du jeden tag eine Vollsicherung des Exchange machen und BE sollte auch dann die Daten in die DB übertragen.

LG
Bitte warten ..
Mitglied: Onitnarat
29.08.2012, aktualisiert um 15:47 Uhr
Entschuldigung, aber das ist doch völlig normal! Der Zeitstempel im Explorer sagt gar nichts aus!

Es ist so, wenn Du 10GB Daten aus der EDB löschst, z.b. Postfächer oder öffentliche Ordner, wird die EDB ja nicht 10GB kleiner sondern sie bleibt in ihrer ursprünglichen Größe. Bei der nächsten Onlinedefragmentierung, die auf dem Exchange 2010 ja 24/7 läuft, räumt der Exchange INNERHALB der Datenbank 10GB weg und diese sind INNERHALB der Datenbank dann frei und werden mit den nächsten Mails belegt.
Solange bleibt der Zeitstempel der EDB unverändert, weil die Datei sich ja nicht ändert. Erst wenn die EDB intern "voll" ist vergrößert der Exchange die EDB und aktualisiert dann den Timestamp der EDB im Explorer!

Ich würde mir keine Sorgen machen und vor allem das ESEUTIL nicht auf einen Verdacht hin ausführen! Die Sicherung mit BackupExec ist super und ordentlich.

Gruß
Marcus
Bitte warten ..
Mitglied: ms160382
29.08.2012 um 16:52 Uhr
Hallo Onitnarat,

jetzt wo du es sagst, scheint es mir auch logisch. Also mache ich mir mal keine Sorgen mehr

Vielen Dank!

Gruß
Mathias
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange 2010 - Anonymes relay für einzelnen Client?? (14)

Frage von eastfrisian zum Thema Exchange Server ...

Exchange Server
Exchange 2010 Akzeptierte Domäne löschen (4)

Frage von Rob1982 zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (21)

Frage von semperf1delis zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...