Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2010 Datenbankbank wiederherstellen bzw zugreifen

Frage Microsoft Exchange Server

Mitglied: LordCheese

LordCheese (Level 1) - Jetzt verbinden

08.11.2011 um 09:59 Uhr, 8800 Aufrufe, 11 Kommentare

Hallo,

einem Kunden ist am Freitag sein Windows Server (2008Enterprise + Exchange 2010) abgeschmiert! Dieser Server war der einzige DC und auch der einzige Exchange.
Wiederherstellung des alten Servers war nicht möglich.

So also habe ich jetzt hier die Exchange Daten (reine Daten dateien). Ich habe versucht die Datenbank mithilfe folgender Anleitung: http://www.it-datasys.de/exchange-server/exchange-server-2010/exchange- ...

wieder zu Mounten dies gelingt aber aufgrund eines Fehlers beim eseutil /r nicht. Hat jemand eine andere Idee?
Mitglied: Pjordorf
08.11.2011 um 10:54 Uhr
Hallo,

Zitat von LordCheese:
einem Kunden
Dein Kunde?

Windows Server (2008Enterprise + Exchange 2010) abgeschmiert! Dieser Server war der einzige DC und auch der einzige Exchange.
Also alles auf ein Blech und keine redundanz.

Wiederherstellung des alten Servers war nicht möglich.
Warum nicht? Was war / ist passiert? Was ist mit Datensicherung?

So also habe ich jetzt hier die Exchange Daten (reine Daten dateien).
Du meinst die xxx Datei(en)?

es gelingt aber aufgrund eines Fehlers beim eseutil /r nicht.
Welcher (genau)?

Hat jemand eine andere Idee?
Andere Idee(n)? Ja Aber warum soll ich dir diese nennen? Du gibst uns ja noch nicht einmal eine Fehlermeldung.

Gruß,
Peter
Bitte warten ..
Mitglied: LordCheese
08.11.2011 um 10:59 Uhr
Hallo Peter,

nein, nicht mein Kunde, vielleicht jetzt ja.

Alles Blech keine Redundanz und Datensicherung ist was für feiglinge (Aussage des pot. Kunden)

Passiert ist das er auf die schlaue Idee kam das SP1 für Server 2008 zu installieren dabei (wahrscheinlich weil er vorher schon da war) ist ein fehler in der AD entstanden der nicht behebbar war.

eseutil /r läuft inzwischen durch, aber der Status

dbtime: 101168162 (0x607b422)
State: Dirty Shutdown
Log Required: 0-0 (0x0-0x0)

bleibt leider, damit ist ein Mount nicht möglich

Gruß
Bitte warten ..
Mitglied: Pjordorf
08.11.2011 um 11:15 Uhr
Hallo,

Zitat von LordCheese:
State: Dirty Shutdown
Log Required: 0-0 (0x0-0x0)
Die Log Dateien sind doch auch noch da, oder?
Schau mal hier nach:
http://www.msxfaq.de/notfall/korrupt.htm
http://www.msxfaq.de/tools/eseutil.htm
http://technet.microsoft.com/de-de/library/aa996757(EXCHG.80).aspx

Gruß,
Peter
Bitte warten ..
Mitglied: ollembyssan
08.11.2011 um 11:26 Uhr
Zitat von LordCheese:
Hallo Peter,

nein, nicht mein Kunde, vielleicht jetzt ja.

Alles Blech keine Redundanz und Datensicherung ist was für feiglinge (Aussage des pot. Kunden)

Passiert ist das er auf die schlaue Idee kam das SP1 für Server 2008 zu installieren dabei (wahrscheinlich weil er vorher
schon da war) ist ein fehler in der AD entstanden der nicht behebbar war.

eseutil /r läuft inzwischen durch, aber der Status

dbtime: 101168162 (0x607b422)
State: Dirty Shutdown
Log Required: 0-0 (0x0-0x0)

bleibt leider, damit ist ein Mount nicht möglich

Gruß

Hallo,

es werden keine Logfiles benötigt.

Bitte gehe hiernach vor:
http://exchangeserverpro.com/restore-individual-mailbox-exchange-2010#e ...

Grüße
Stephan
Bitte warten ..
Mitglied: Ausserwoeger
08.11.2011 um 11:55 Uhr
Die Aussage Datensicherung is was für feiglinge find ich geil !! LOOOOL

Falls du das Problem nicht weg bekommst kannst dem Kunden Powercontrols von Ontrack anbieten. Mit dem Tool kannst du die Mails bzw. Postfächer aus den Files in einen Aktiven Exchange importieren oder in PST files exportieren lassen.

LG Andreas
Bitte warten ..
Mitglied: LordCheese
08.11.2011 um 13:15 Uhr
Hallo Stephan,

eine echt gute Anleitung, Vielen Dank!

Die Soft Recovery läuft zur Zeit, melde mich nochmal falls es noch immer nicht funktioniert.

Eine Frage hätte ich noch, gibts es die möglichkeit mit Restore-Mailbox direkt eine PST der Mailbox zu erstellen?

Danke nochmal und Gruß!
Bitte warten ..
Mitglied: LordCheese
08.11.2011 um 14:22 Uhr
So, soweit so gut.

Jetzt stürzt mir eseutil /p ab.

Folgendes ist dazu im Ereigniss Protokoll zu finden:
01.
Protokollname: Application 
02.
Quelle:        Application Error 
03.
Datum:         08.11.2011 14:16:22 
04.
Ereignis-ID:   1000 
05.
Aufgabenkategorie:(100) 
06.
Ebene:         Fehler 
07.
Schlüsselwörter:Klassisch 
08.
Benutzer:      Nicht zutreffend 
09.
Computer:      WIN-SRTNV72F1KG.domäne.local 
10.
Beschreibung: 
11.
Name der fehlerhaften Anwendung: eseutil.exe, Version: 14.0.639.19, Zeitstempel: 0x4aaa0679 
12.
Name des fehlerhaften Moduls: ESE.dll, Version: 14.0.639.19, Zeitstempel: 0x4aaa067e 
13.
Ausnahmecode: 0xc0000005 
14.
Fehleroffset: 0x000000000022f6a4 
15.
ID des fehlerhaften Prozesses: 0xe24 
16.
Startzeit der fehlerhaften Anwendung: 0x01cc9e176e2869cd 
17.
Pfad der fehlerhaften Anwendung: C:\Program Files\Microsoft\Exchange Server\V14\bin\eseutil.exe 
18.
Pfad des fehlerhaften Moduls: C:\Program Files\Microsoft\Exchange Server\V14\bin\ESE.dll 
19.
Berichtskennung: d9a32d2b-0a0b-11e1-88ea-002215ab2ae2 
20.
Ereignis-XML: 
21.
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> 
22.
  <System> 
23.
    <Provider Name="Application Error" /> 
24.
    <EventID Qualifiers="0">1000</EventID> 
25.
    <Level>2</Level> 
26.
    <Task>100</Task> 
27.
    <Keywords>0x80000000000000</Keywords> 
28.
    <TimeCreated SystemTime="2011-11-08T13:16:22.000000000Z" /> 
29.
    <EventRecordID>1926</EventRecordID> 
30.
    <Channel>Application</Channel> 
31.
    <Computer>*********</Computer> 
32.
    <Security /> 
33.
  </System> 
34.
  <EventData> 
35.
    <Data>eseutil.exe</Data> 
36.
    <Data>14.0.639.19</Data> 
37.
    <Data>4aaa0679</Data> 
38.
    <Data>ESE.dll</Data> 
39.
    <Data>14.0.639.19</Data> 
40.
    <Data>4aaa067e</Data> 
41.
    <Data>c0000005</Data> 
42.
    <Data>000000000022f6a4</Data> 
43.
    <Data>e24</Data> 
44.
    <Data>01cc9e176e2869cd</Data> 
45.
    <Data>C:\Program Files\Microsoft\Exchange Server\V14\bin\eseutil.exe</Data> 
46.
    <Data>C:\Program Files\Microsoft\Exchange Server\V14\bin\ESE.dll</Data> 
47.
    <Data>d9a32d2b-0a0b-11e1-88ea-002215ab2ae2</Data> 
48.
  </EventData> 
49.
</Event>
Jemand eine Idee?
Bitte warten ..
Mitglied: LordCheese
09.11.2011 um 13:50 Uhr
Hey,

danke dafür. Ich habe die Datenbank jetzt auch in dem Clean Shutdown Status, jetzt gibt es nur noch ein kleines Problem.

Beim Einbinden der Datenbank, mit gleichzeitigem erstellen jammert er folgendes:

01.
[PS] C:\Windows\system32>New-MailboxDatabase RecoveryDB -Server SERVER -Recovery:$true -EdbFilePath C:\bu\MBDdata\Mailboxes.edb -LogFolderPath C:\bu\MDBdata\ 
02.
Fehler beim Verbinden mit Zielserver "SERVER". Fehler: WMI-Ausnahme auf Server 'SERVER.domain.local': Datenträgerkontingentverletzung .. 
03.
    + CategoryInfo          : InvalidOperation: (:) [New-MailboxDatabase], InvalidOperationException 
04.
    + FullyQualifiedErrorId : 783FD0B3,Microsoft.Exchange.Management.SystemConfigurationTasks.NewMailboxDatabase
Die Kontingentverwaltung ist aus. Ich habe auch versucht sie anzumachen und zu "deaktivieren" selbes ergebnis.


//Lösung dessen:

Die Logfiles mussten gelöscht werden. Danach wars es möglich die Datenbank zumindest hinzuzufügen. Jetzt lässt er sie noch nicht Mounten.

Ich probiere jetzt nochmal eseutil /p
Melde mich wieder.
Bitte warten ..
Mitglied: LordCheese
09.11.2011 um 18:23 Uhr
So, die Datenbank ist zwar jetzt eingebunden, allerdings bekomme ich beim Mounten der Datenbank folgenden Fehler:

01.
 
02.
[PS] C:\Windows\system32>Mount-Database RecoveryDB 
03.
Die angegebene Datenbank konnte nicht eingebunden werden. Angegebene Datenbank: RecoveryDB; Fehlercode: An Active Manager operation failed. Error: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionCall 
04.
Failed: Unable to mount database. (hr=0x80004005, ec=1276) 
05.
.. [Database: RecoveryDB, Server: SERVER.domain.local]. 
06.
    + CategoryInfo          : InvalidOperation: (RecoveryDB:ADObjectId) [Mount-Database], InvalidOperationException 
07.
    + FullyQualifiedErrorId : 6075EEAD,Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase
Bitte warten ..
Mitglied: Ausserwoeger
10.11.2011 um 09:38 Uhr
Weisst du welches Update Level der Exchange hatte ? SP1 Oder Sp2 oder kein SP ???

Ist die installierte Exchange Version exakt die gleiche? Oder war am alten Exchange Server eine andere Version installiert ?

LG Andreas
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Activesync Problem bei IOS 10.1.1 und Wildcard SSL Zertifikat (2)

Frage von hasel123 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...