Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2013 Suchindex Fehler

Frage Microsoft Exchange Server

Mitglied: Cerpal

Cerpal (Level 1) - Jetzt verbinden

18.02.2015 um 09:41 Uhr, 3224 Aufrufe, 1 Kommentar

Hallo zusammen. Nach vielem Lesen und Hilfestellung von diesem Portal muss ich das erste mal selbst nach Hilfe fragen:


Also:
Ich habe hier einen Exchange 2013 auf Server 2012R2.
Dieser Exchange hat vor ca. 1 Woche aus heiterem Himmel aufgehört den Suchindex zu bearbeiten -> Die Suche in Outlook findet zu diesem Zeitpunkt zwar noch Mails aber keine aktuellen.

Soweit zum Symptom.

Folgendes erstmal aus dem Ereignisprotokoll:

Bei Windows/Anwendungen kommt zum Zeitpunkt des Dienststarts (MSExchangeFastSearch) folgende Warnung:

Warnung MSExchangeFastSearch Code 1010
Ausnahme bei dem Versuch, einen Vorgang für einen FAST-Endpunkt auszuführen. Dieser Vorgang wird möglicherweise erneut ausgeführt. Fehlerdetails: Microsoft.Exchange.Search.Fast.PerformingFastOperationException: An Exception was received during a FAST operation. ---> System.ServiceModel.EndpointNotFoundException: Es konnte keine Verbindung mit "net.tcp://localhost:3803/Management/IndexController" hergestellt werden. Der Verbindungsversuch hat für einen Zeitraum von 00:00:02.0156335 angedauert. TCP-Fehlercode 10061: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 127.0.0.1:3803.  ---> System.Net.Sockets.SocketException: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 127.0.0.1:3803 
   bei System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) 
   bei System.Net.Sockets.Socket.Connect(EndPoint remoteEP) 
   bei System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout) 
   --- Ende der internen Ausnahmestapelüberwachung --- 
 
Server stack trace:  
   bei System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout) 
   bei System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout) 
   bei System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout) 
   bei System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout) 
   bei System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
   bei System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout) 
   bei System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
   bei System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade) 
   bei System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout) 
   bei System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) 
   bei System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) 
   bei System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) 
 
Exception rethrown at [0]:  
   bei System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) 
   bei System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) 
   bei Microsoft.Ceres.SearchCore.Admin.IIndexControllerManagementAgent.get_IndexSystemNames() 
   bei Microsoft.Exchange.Search.Fast.IndexManager.<GetCatalogs>b__1d() 
   bei Microsoft.Exchange.Search.Fast.IndexManagementClient.PerformFastOperation[T](Func`1 function, String eventLogKey) 
   --- Ende der internen Ausnahmestapelüberwachung ---


Außerdem gibt es unter ManagedAvailabilty folgende Fehler:

Die Suche weist einen fehlerhaften Kopierstatus für die Datenbank 'mailbox01' auf dem lokalen Server auf. Letzter Testfehler:  
 
Der Suchkatalog für die eingebundene Datenbank 'mb01' ist fehlerhaft. Er weist den Status 'Failed' auf, und die Fehlermeldung für die Inhaltsindizierung lautet 'An internal error occurred for the database or its index.'. Der Failoverversuch ist entweder fehlgeschlagen oder wurde eingeschränkt. 
 
Fehler aus den Diagnoseinformationen des Suchdiensts:  
(nicht verfügbar) 
Knoteninfo:  
Name: 'IndexNode1', State : 'Active', Description: 'Secondary index node.'. 
Name: 'AdminNode1', State : 'Active', Description: 'Components OK'. 
Name: 'ContentEngineNode1', State : 'Active', Description: 'Components OK'. 
Name: 'InteractionEngineNode1', State : 'Active', Description: 'Components OK'. 
 
 
Status aller Datenbankkopien auf dem Server:  
Kopie: 'mailbox01', Datenbankstatus: 'Mounted', Inhaltsindexstatus: 'Failed', Fehlermeldung: 'An internal error occurred for the database or its index.'.


Nun folgen die schon durchgeführten Schritte bzw. von mir zu diesem Problem schon gefundenen Dinge:


Auf dem EX habe ich als erstes Versucht ganz rudimentär versucht den Suchindex zu löschen und neu zu erstellen:

Diese beiden Dienste beendet:

MSExchangeFastSearch
HostControllerService

und im Speicherpfad der Datenbank den XXXXXXXXXXXXXXXXXXXXXXXX.single Ordner umbenannt.

Anschließend Dienste wieder gestartet: Der Ordner wird neu erstellt und bleibt bei einer Größe von 16,2 MB stehen und wird nicht größer (Der Umbenannte vorherige Ordner ist 3,5GB)



Beschriebenes vorgehen aus http://support.microsoft.com/kb/2879739/de durchgeführt bzw. nur geprüft: Alles war OK



Gruppe ContentSubmitters im AD erstellt und Rechte gegeben wie hier beschrieben: http://support.microsoft.com/kb/2807668



Ein
Get-MailboxDatabaseCopyStatus mb01 | fl *index*
in der Shell des EX gibt:
01.
ContentIndexState            : Failed 
02.
ContentIndexErrorMessage     : An internal error occurred for the database or its index. 
03.
ContentIndexVersion          : 
04.
ContentIndexBacklog          : 
05.
ContentIndexRetryQueueSize   : 
06.
ContentIndexMailboxesToCrawl : 
07.
ContentIndexSeedingPercent   : 
08.
ContentIndexSeedingSource    : 
09.
ContentIndexServerSource     :



Nun hoffe ich inständig auf einen Tip aus dieser tollen Community damit ich hier ein wenig weiter komme...

Falls ich noch weitere Infos liefern könnte, die zu einer Problemlösung führen bitte bescheid sagen.


Gruß Cerpal


Mitglied: SmogKiel
20.07.2017 um 17:27 Uhr
Hallo, gabe es hierzu eine Lösung?
Stehe vor dem gleichen Problem.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst Fehler bei Installation von Exchange 2013 (3)

Frage von ingoue zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2013 Fehler ID "1009" (1)

Frage von amarsin zum Thema Exchange Server ...

Exchange Server
Exchange 2013 -Fehler bei der nachrichtenzustellung (1)

Frage von leon123 zum Thema Exchange Server ...

Exchange Server
Migration Exchange 2007 zu 2013 schlägt fehl (1)

Frage von zimlars zum Thema Exchange Server ...

Neue Wissensbeiträge
LAN, WAN, Wireless

WPA-2 hat erste Risse: KRACK

(3)

Information von the-buccaneer zum Thema LAN, WAN, Wireless ...

Hardware

GPD Pocket: Winziger Laptop für Wenig Tipper

(1)

Information von pelzfrucht zum Thema Hardware ...

Windows 10

Microsoft veröffentlicht das "Fall Creators Update

(10)

Information von Penny.Cilin zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (20)

Frage von sunics zum Thema Hosting & Housing ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...