Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Exchange DB wird nicht gemountet

Frage Microsoft Exchange Server

Mitglied: wuggale

wuggale (Level 1) - Jetzt verbinden

17.07.2013 um 01:03 Uhr, 4390 Aufrufe, 15 Kommentare

Hallo Ich habe ein riesen Problem meine ExcahngeDB will überhaupt nicht mehr starten

Umgebung: W2k8R2 und Exch2010 SP2

Und ich habe festgestellt dass meine DB Corrupted ist, jedoch weis ich nicht mehr was ich machen soll.

Was habe ich gemacht:

Eseutil /p "Databasename" danach "CleanShutdown"
Eseutil /d "Databasename" Fehlermeldung Operation terminated with error -1603 (JET_errNoCurrentRecord, Currency not on a record) after 3.463 seconds.

Eseutil /g "Dataabsename" Fehlermeldung Integrity check completed. Database is CORRUPTED!
Operation terminated with error -1206 (JET_errDatabaseCorrupted, Non database file or corrupted db) after 277.495 secon

Eseutil /r E00 Recovery has indicated that there might be a lossy recovery option. Run recovery with the /a argument.
Operation terminated with error -528 (JET_errMissingLogFile, Current log file missing) after 0.593 seconds.

Vor dem Befehl war die E00 noch vorhanden ich setzte den Befehl ab und die Datei ist weg...

Den Versuch die DB über die EMC zu Mounten und mit vorherigen verschieben der Logfiles Fehler
--------------------------------------------------------
Microsoft Exchange Fehler
Die Datenbank 'Mailbox Database 0329364906' konnte nicht eingebunden werden.

Mailbox Database 0329364906
Fehler
Fehler:
Die angegebene Datenbank konnte nicht eingebunden werden. Angegebene Datenbank: Mailbox Database 0329364906; Fehlercode: Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionJetErrorKeyDuplicate: Unable to mount database. (hr=0x80004005, ec=-1605)
. [Datenbank: Mailbox Database 0329364906, Server: IPH-MAIL.xxx.local].

Fehler bei Active Manager-Vorgang: Fehler bei der Datenbankaktion: Fehler bei Vorgang mit folgender Meldung: MapiExceptionJetErrorKeyDuplicate: Unable to mount database. (hr=0x80004005, ec=-1605)
. [Datenbank: Mailbox Database 0329364906, Server: IPH-MAILxxx.local]

Fehler bei Active Manager-Vorgang: Fehler bei Vorgang mit folgender Meldung: MapiExceptionJetErrorKeyDuplicate: Unable to mount database. (hr=0x80004005, ec=-1605)
[Server: IPH-MAIL.xxx.local]

MapiExceptionJetErrorKeyDuplicate: Unable to mount database. (hr=0x80004005, ec=-1605)

Ich bin sowas am verzweifeln, könnt Ihr mir helfen
Mitglied: Herbrich19
17.07.2013 um 01:22 Uhr
Hallo,

Sieht nach einen Klassischon Notfall aus, schau mal in der gleichnahmigen Kattegorie auf www.msxfaq.de, da wird die vorgehensweise beschrieben, und vorerst kannt du neue DB,s anlegen und diese den Benutzern zuweisen damit sie weiterhin ihre emails bekommen können.

Und ein Backup sollte man immer zur hand haben.

LG, Herbrich
Bitte warten ..
Mitglied: wuggale
17.07.2013, aktualisiert um 02:13 Uhr
Sieht nach einen Klassischon Notfall aus, schau mal in der gleichnahmigen Kattegorie auf www.msxfaq.de, da wird die vorgehensweise beschrieben,

ok werde ich mal suchen ob ich da was finde

und vorerst kannt du neue DB,s anlegen und diese den Benutzern zuweisen damit sie weiterhin ihre emails bekommen
können.

einen neue DB habe ich bereits angelegt jedoch wie kann ich dem User die DB zuweisen? da ich keine DB verschiebung machen kann

Und ein Backup sollte man immer zur hand haben.

Das wurde als nicht notwendig angeseen und somit leider nicht vorhanden
Bitte warten ..
Mitglied: keine-ahnung
17.07.2013, aktualisiert um 08:30 Uhr
Zitat von wuggale:
Hi,
Das wurde als nicht notwendig angeseen und somit leider nicht vorhanden
dann ist doch alles o.k.! Fangt wieder bei Punkt 0 an und alles ist schick ...

LG, Thomas

BTW: Hier könnte Dir geholfen werden ...

Achte aber besonders auf folgenden Passus: "Microsoft bietet im Falle einer defekten Exchange-Datenbank zwei Werkzeuge, die in Kombination zu verwenden sind: eseutil.exe und isinteg.exe, beide im BIN-Verzeichnis des Exchange zu finden. Microsoft warnt jedoch vor dem Einsatz dieser Werkzeuge, da diese evtl. (defekte) Teile der Datenbank löschen und empfiehlt dringend, im Problemfall die letzte Sicherung der Exchange-Datenbank einzuspielen."
Bitte warten ..
Mitglied: wuggale
17.07.2013, aktualisiert um 09:19 Uhr
Hallo Thomas,

das sind genau diese Schritte die ich schon versucht habe, bleibt mir wirklich nix anderes übrig als neu zu beginnen, wie kann ich die bestehenden user auf einen NeueDB umziehen bzw. eine neue Mailbox erstellen?
Bitte warten ..
Mitglied: keine-ahnung
17.07.2013, aktualisiert um 09:53 Uhr
Jetzt muss ich mich outen ... ich bin ein Feigling! Ein Weichei und Warmduscher. Und: mein Vertrauen in NSA und MI6 ist begrenzt ...
Noch erstelle ich backup's, sowohl vom Informations- als auch vom Postfachspeicher. Das auch noch mehrmals täglich auf verteilte Medien ...

Insofern stand ich noch nie vor einer solchen Situation .... aber schau mal hier und da.

LG, Thomas
Bitte warten ..
Mitglied: Herbrich19
17.07.2013 um 09:54 Uhr
Hallo,

Du kannst die alte Datnbank (glaube ich) irgendwie Aufbrechen um an die Inhallte zu kommen, da fällt mir so spontan laufwerk M ein :D Aber davon ist echt Strikt abzuraten.

LG, Herbrich
Bitte warten ..
Mitglied: wuggale
17.07.2013 um 10:00 Uhr
Zitat von keine-ahnung:
Jetzt muss ich mich outen ... ich bin ein Feigling! Ein Weichei und Warmduscher. Und: mein Vertrauen in NSA und MI6 ist begrenzt
...
Noch erstelle ich backup's, sowohl vom Informations- als auch vom Postfachspeicher. Das auch noch mehrmals täglich auf
verteilte Medien ...

da gebe ich dir Recht aber gut soll eine Lehre gewesen sein ;)

Ich will neu Anfangen hab ne DB erstellt jedoch wie bekomme ich nun die AD User dazu das diese eine neue Mailbox erstellen auf der neune DB

Insofern stand ich noch nie vor einer solchen Situation .... aber schau mal hier und da.

Die "Holzahmmer Methode" habe ich versucht jedoch ohne den Part mit adsiedit, ich konnte die DB nicht Mounten gleicher Fehler wie oben... ich bekommen echt noch die Krise
Bitte warten ..
Mitglied: wuggale
17.07.2013 um 10:01 Uhr
Du kannst die alte Datnbank (glaube ich) irgendwie Aufbrechen um an die Inhallte zu kommen, da fällt mir so spontan laufwerk
M ein :D Aber davon ist echt Strikt abzuraten.

Hallo Herbrich ja die Daten kann ich mit einen Tool aufbrechen ich denke das wäre nicht das Problem zumindest da alle User auch Cache Modus verwendeten, könnte mann hier schon einen Teil der Daten wieder haben.
Aber wie gesagt wie bringe ich den AD User dazu dass er sich einen neue Mailbox auf der neuen DB anlegt
Bitte warten ..
Mitglied: wuggale
17.07.2013 um 10:08 Uhr
Jetzt neue Meldung bei

eseutil /p
Operation terminated with error -1605 (JET_errKeyDuplicate, Illegal duplicate key) after 658.496 seconds.
Bitte warten ..
Mitglied: Herbrich19
17.07.2013 um 10:20 Uhr
Hallo,

Du kannst die Mailbox immer jeden einzehlnden User einer Datenbank zuweisen, und dann hast du es ja schon. Also unter Exchange 2007 / 201X Kannst du es (glaube ich) in den eigenschaften des Users machen, ansonsten geht dass genau so unter 200X (2003), 2007 ist ja schon wieder mehr 201X Style. (Mit dieser neuen Oberfläche die mehr auf Powershell Basierd^^).

LG, Herbrich
Bitte warten ..
Mitglied: wuggale
17.07.2013 um 10:27 Uhr
Du kannst die Mailbox immer jeden einzehlnden User einer Datenbank zuweisen, und dann hast du es ja schon. Also unter Exchange
2007 / 201X Kannst du es (glaube ich) in den eigenschaften des Users machen, ansonsten geht dass genau so unter 200X (2003), 2007
ist ja schon wieder mehr 201X Style. (Mit dieser neuen Oberfläche die mehr auf Powershell Basierd^^).

Meins du über die Attribute des User dei HomeDBA und HomeMTA?
Bitte warten ..
Mitglied: Herbrich19
19.07.2013 um 04:54 Uhr
Ja, ich glaube diese Attributte sind es, ich habe zurzeit Exchange 2007 in Einsatz, und da ist alles ein wenig geändert worden.

LG, Herbrich
Bitte warten ..
Mitglied: wuggale
22.07.2013 um 22:52 Uhr
So mein Exchange läuft wieder, leider habe ich einen neue gleichnamige DB erstellt und die Attribute angepasst.
Die "alte" defekte DB habe ich mit einem edb2pstTool exportiert so konnte ich den geringsten Datenverlust gewährleisten.
Bei 60 User is das einbinden auf den Outlooks überschaubar.

Jetzt habe ich auch ein Backup eingerichtet sodass mir dass nie mehr passiert.
Was mich allerdings noch interesieren würde wie sowas passieren kann denn normalerweise ist ein Ex2010 unkaputtbar...

ICh bedanke mich für all die Hilfe die Ihr mir gegeben habt

Gruss Danke
Tom
Bitte warten ..
Mitglied: Herbrich19
22.07.2013 um 23:40 Uhr
Die Transactions Daten lieen auf den RAM, wen der Server nicht heruntergefahren wird kann es schon mal Passieren das die DB so kaputt geht.

LG, Herbrich
Bitte warten ..
Mitglied: wuggale
24.07.2013 um 11:09 Uhr
Ja der Server ist lange Zeit nicht mehr neugestartet worden, nachdem einspielen von hunderten von Patche muss wohl irgendwas passiert sein...

Unschön aber nagut - ich hoffe mit der int. Windows Sciehrung klaptt das wiederherstellen auch in solchen fällen

.BG
Tom
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
Frage: restore exchange 2013 public-db mit backupexec 2014

Frage von royal zum Thema Exchange Server ...

Exchange Server
Outlook synchronisiert sich auf iOS nicht mit Exchange (4)

Frage von Akrosh zum Thema Exchange Server ...

Windows Server
Schemaerweiterung - Office 365 - Exchange Online mit lokalem AD

Frage von chb1982 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...