Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Falsche Formel

Frage Microsoft Microsoft Office

Mitglied: SlamFaL

SlamFaL (Level 1) - Jetzt verbinden

11.09.2008, aktualisiert 12.09.2008, 4013 Aufrufe, 12 Kommentare

Hallo zusammen,

ich habe eine Excel Formel erstellt bzw. möchte jetzt 2 Formeln zu einer zusammenführen kann mir dabei jemand helfen?

Mein erster Versuch sah so aus: =FINDEN(" ";A7)*WENN(FEHLER.TYP(B7)=3;"";B7)

das sind die 2 Formeln:

=FINDEN(" ";A7)
=WENN(FEHLER.TYP(B7)=3;"";B7)

Schöne Grüße
SlamFaL
Mitglied: bastla
11.09.2008 um 15:00 Uhr
Hallo SlamFaL!

Das Ergebnis 0 zu erhalten, wenn es in A7 kein Leerzeichen gibt, sollte es so klappen:
01.
=WENN(ISTFEHLER(FINDEN(" ";A7));0;FINDEN(" ";A7))
Grüße
bastla
Bitte warten ..
Mitglied: SlamFaL
11.09.2008 um 15:10 Uhr
Hallo bastla,

ich möchte gar nicht 0 erhalten, ich habe eine excel tabelle erstellt in der ich jetzt namen mit oder ohne leerzeichen habe. nun möchte ich einfach eine formel haben die den namen hinschreibt ohne nachzusehn ob er ein leerzeichen hat oder nicht.

Gruß
SlamFaL

Ps.: ich habe davor die umlaute aus den namen genommen - bedeutet lässer ist nun zu laesser geworden.
es ist ein bisschen schwierig einem aussenstehenden der die tabelle nicht gesehen hat zu erklären was ich brauche.

hoffe du/ihr könnt mir trotzdem helfen!
Bitte warten ..
Mitglied: bastla
11.09.2008 um 15:20 Uhr
Hallo SlamFaL!

Wenn Du den in A7 stehenden Namen ohne Leerzeichen erhalten willst, sollte
01.
=WECHSELN(A7;" ";"")
genügen - ansonsten solltest Du darstellen, was in A7 steht, und was Du daraus machen willst ...

Grüße
bastla
Bitte warten ..
Mitglied: kristov
11.09.2008 um 17:38 Uhr
Hallo,

das ist ja wirlich ulkig. Ich weiß auch nicht, worum's geht. Biite wie bastla angeregt, ein Beispiel.

Wenn =FINDEN(" ";A7) in der Zelle B7 steht und =WENN(FEHLER.TYP(B7)=3;"";B7) in C7 steht, dann sollte das wohl =WENN(FEHLER.TYP(FINDEN(" ";A7))=3;"";B7) heissen. Aber was das werden soll...

lg,
kristov
Bitte warten ..
Mitglied: SlamFaL
12.09.2008 um 08:24 Uhr
so sieht meine tabelle aus:

A7 B7 C7 D7 E7 F7
admtkab #WERT! #WERT! #WERT! a #WERT
=FINDEN(" ";A8) =LÄNGE(A8) =RECHTS(A8;C8) =LINKS(A8;1) =D8&"."&E8
G7
admtkab
=WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(A8;"ä";"ae");"ü";"ue");"ö";"oe");"Ä";"Ae");"Ü";"Ue");"Ö";"Oe")

so sieht das aus..also ich kann damit nichts anfangen wenn ich das so sehen würde..hoffe ihr excel profis könnt das..

deine formel steht jetzt in B7
=WENN(FEHLER.TYP(FINDEN(" ";A11))=3;"";B11) funktioniert auch super nur habe ich das problem das es namen gibt mit leerzeichen, wo ich dann den fehler #NV bekomme wenn ich deine formel in der spalte B nach unten ziehe.

Gruß
SlamFaL
Bitte warten ..
Mitglied: kristov
12.09.2008 um 11:54 Uhr
Bitte sag uns doch einfach, worum es geht. Am besten mit einem konkreten Beispiel (Beispiele für Namen, wie sie drin stehen, und wie die Namen dann ausgegeben werden sollen).

kristov
Bitte warten ..
Mitglied: SlamFaL
12.09.2008 um 12:03 Uhr
also ich versuchs so gut wie möglich zu erklären..

ich muss diese excel tabelle so umfunktionieren das sie funktioniert egal ob ein leerzeichen drinnen ist oda nicht --> meine erste aufgabe bestand darin die ganzen user vom ad ins excel zu kopieren danach sollte ich eine formel machen in der ich die ganze umlaute heraus nehme und den namen der dort stand zb. max mustermann zu max m. abzuändern
nun muss ich es eine formel haben die mir das so konfiguriert das das feld mit dem namen der kein leerzeichen hat einfach frei bleibt und das feld mit dem namen das leerzeichen sucht (=FINDEN(" ";A8))..hoffe du bekommst langsam einen eindruck was ich genau meine damit..ist sehr schwer jemandem das zu erklären wenn er diese tabelle noch nicht gesehen hat..

Gruß
SlamFaL
Bitte warten ..
Mitglied: kristov
12.09.2008 um 12:41 Uhr
Danke für Deine Erklärung. Ganz kenn ich mich noch immer nicht aus (ob's am gestrigen Stammtisch liegt?)

Um bei den Beispielen zu bleiben:

Karl Ölheimer -> Karl Oe.
SeppHuber ->
Franz Müller -> Franz M.

Die drei Beispiele sollten Deine Anforderung vollständig zusammenfassen, richtig, oder hab ich da was übersehen?
Bitte warten ..
Mitglied: bastla
12.09.2008 um 12:58 Uhr
Hallo SlamFaL!

Du hättest es vermutlich leichter (zumindest, wenn es eine einmalige Aktion sein sollte), wenn Du einfach mittels "Daten / Text in Spalten ... / Getrennt / Leerzeichen" die Namen "auseinanderschneiden" lässt ...

Grüße
bastla
Bitte warten ..
Mitglied: SlamFaL
12.09.2008 um 14:46 Uhr
Hallo Ihr 2..Ich habs geschafft..Ich hatte den falschen Befehl angegeben..
So schaut die Lösung meines Problems aus: =WENN(ISTFEHLER(FINDEN(" ";A7));"";FINDEN(" ";A7))

Hoffe euch hat das Raten nach dem was ich meine trotzdem gefallen..*=)

Danke für eure Unterstützung und Mithilfe!!

Lg
SlamFaL
Bitte warten ..
Mitglied: bastla
12.09.2008 um 14:54 Uhr
Hallo SlamFaL!

So weit weg war ich da ja anfangs gar nicht ...

Meine Überlegung war, dass FINDEN() ein numerisches Ergebnis liefert, und deshalb auch der Vorschlag mit der Null (anstelle von "").

Grüße
bastla
Bitte warten ..
Mitglied: SlamFaL
12.09.2008 um 15:57 Uhr
Hallo bastla!

Ja jetzt wo du es sagts stimmt das eigentlich!
Mein Fehler war das ich mich zu sehr auf das FEHLER.TYP fixiert hatte und das ISTFEHLER gar nicht beachtet habe anders als du! Tja später ist man immer schlauer .

Gruß
SlamFaL
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Dateiliste in Excel 2010 wird nur nach Formel löschen aktualisiert (1)

Frage von dressa zum Thema Microsoft Office ...

Windows Update
gelöst WSUS weißt die falsche Creators Update Lizenz zu (5)

Frage von SociallyawkwardPenguin zum Thema Windows Update ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Update
gelöst MS: Update-Server-Adressen OHNE Wildcards (17)

Frage von mrserious73 zum Thema Windows Update ...

Viren und Trojaner
Ransomware .nm4 (14)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (11)

Frage von Matsushita zum Thema Microsoft Office ...