Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehler in batch? robocopy wird nicht gefunden

Frage Entwicklung Batch & Shell

Mitglied: speedy4you

speedy4you (Level 1) - Jetzt verbinden

26.03.2008, aktualisiert 12:32 Uhr, 8824 Aufrufe, 2 Kommentare

Hallo,
ich habe das Forum und das Internet jetzt schon zeit zwei Tagen durchsucht und habe immer noch nicht mein Problem gelöst.

Ich möchte Updates per CD verteilen. Dafür habe ich eine Batch-Datei geschrieben die per autorun sofort gestartet wird. Funktioniert auch alles.
Jetzt wollte ich als Startseite eine html Datei angeben. Auch noch O.K.
Auf dieser Startseite ist ein link zur Batch-Datei. Sobald ich diesen Link anklicke startet die Batch-Datei.
Jetzt bekomme ich aber eine Fehlermeldung:

Pfad=""C:\LINDE_MH\lindos_F\Programm""
* Lindos Verzeichnis gefunden! *
* Lindos Updates werden kopiert! *
Der Befehl "robocopy.exe" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.




Die Datei robocopy.exe wird nicht gefunden, da ich sie aus dem InternetExplorer aufrufe.

Irgend etwas stimmt in meiner Batch-Datei nicht. Vielleicht kann mir jemand dabei Helfen ?!

Besten Dank schon einmal im voraus.


meine Batch:
01.
@ECHO OFF 
02.
 
03.
FOR /F "tokens=2*" %%A IN ('REG QUERY "HKEY_LOCAL_MACHINE\SOFTWARE\LexCom\DICSY5" /v LastPath') DO SET Pfad=%%B 
04.
 
05.
set Pfad="%Pfad%" 
06.
ECHO Pfad="%Pfad%" 
07.
 
08.
if exist "%Pfad%" echo  ********* Lindos Verzeichnis gefunden! ********* 
09.
if not exist "%Pfad%" echo  ********* Lindos Verzeichnis NICHT gefunden! ********* 
10.
if not exist "%Pfad%" goto ENDE 
11.
 
12.
 
13.
@ECHO  ********* Lindos Updates werden kopiert! ********* 
14.
robocopy.exe "Lindos\update" "%Pfad%\update" /E /ZB /COPY:DAT /R:3 /W:1 
15.
 
16.
:ende  
17.
 
18.
echo  ********* Updates erfolgreich kopiert! ********* 
19.
pause
Mitglied: reap705
26.03.2008 um 11:56 Uhr
Ich hatte mal ein ähnliches Problem mit einer exe-Datei. Vielleicht ist es hier ähnlich. Habe es folgendermaßen gelöst:

Eine Verknüpfung auf die bat-Datei anlegen und dann auf diese Verlinken. Also bspw. so:

file://metis/Intranet/sonstiges/Verknüpfungmitbatdatei.lnk

Bei mir ließ sich die Anwendung dann aufrufen.
Bitte warten ..
Mitglied: speedy4you
26.03.2008 um 12:32 Uhr
Ja, super )
hat funktioniert, besten Dank
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Batch & Shell
gelöst Splitten in Batch. Wo liegt der Fehler!? (4)

Frage von Todybear zum Thema Batch & Shell ...

Windows 7
gelöst Fehler 0xC0000034 BCD nicht gefunden - Partition geloescht (6)

Frage von SauseMaus zum Thema Windows 7 ...

Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...