Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehler Disk ID 7 Fehlerhafter Block raid 5 system

Frage Hardware Festplatten, SSD, Raid

Mitglied: existenz

existenz (Level 1) - Jetzt verbinden

30.09.2010 um 14:07 Uhr, 8168 Aufrufe, 9 Kommentare

Guten Tag zusammen,

langsam bin ich etwas am verzweifeln.
System: Microsoft Windows Server 2003 SP2
Exchange Server
Raid 5 System - MegaRaid SAS 8308ELP

Seit einen Systemabsturz erscheint immer wieder in der Ereignissanzeige folgendes: Disk Fehler ID: 7
Fehlerhafter Block bei Gerät \Device\Harddisk1

lässt mich vermuten das eine der Platten einen defekt hat. Leider finde ich im Array Manager keinerlei Fehler. Daher weiß ich nicht welche Platte ausgetauscht werden müsste. chkdsk hat auch keine Ergebnisse gebracht.

Ein weiteres Problem ist vermutlich dadruch entstanden, Fehler Code 7011 Service Control Manager - Zeitberschreitung (30000 ms) beim Warten auf eine Transaktionsrckmeldung von Dienst NtFrs. - Dies hat bewirkt das das System für wenige Minuten komplett eingefrohren ist und die Verbindungen in Outlook getrennt wurden. Habe das aber behoben indem ich die Zeit für eine Zeitüberschreibung in der Registry erhöht habe.

Kann mir jemand erklären wie ich herrausfinde welche der drei Platten einen defekt hat. Wäre dann wohl der schönste weg diese einfach auszutauschen.

Viel Dank schonmal,
André
Mitglied: SamvanRatt
30.09.2010 um 16:10 Uhr
Hi
da scheint keine direkt defekt zu sein (sonst muß dein Kontroller anspringen, er kann ja durch N+1 den Fehler auf einer HD beheben, egal wie viel), sondern dein Kontroller meldet keinen Fehler/Daten zurück (evtl meldet die HD auch keinen Fehler und gibt Mülldaten zurück; das hatte ich mit Seagate und Fujitsu HDs einmal in unterschiedlichen ICP Vortex Controllern) und wird dann vom OS als defekt (Block) erkannt. Solche Fehler kenne ich eigentlich nur von unserem Areca und Highpoint Kontrollern, bei denen dann meist ein BSOD folgt; Was passiert wenn du einen chkdsk /r anwirfst?
Alternativ: nimm die HDs offline raus und teste sie einzeln mit den Herstellertools oder fast besser mit einem dummen ddrescue /dev/sdx /dev/null; die mit Fehlern dann im Offline noch rausnehmen und durch eine Fehlerfreie ersetzen
Gruß
Sam
Bitte warten ..
Mitglied: existenz
30.09.2010 um 18:43 Uhr
wenn ich chkdsk /r mache - findet er nichts... keinen fehler... jetzt tritt auch wieder der Fehler Code 7011 Service Control Manager - Zeitberschreitung (30000 ms) beim Warten auf eine Transaktionsrckmeldung von Dienst NtFrs auf. DAs bewirkt das, das System für einige Minuten komplett einfriert und Exchangeverbindungen getrennt werden. Mit meiner Lösung die Zeitbeschränkung hoch zu setzten lief es nur kurzfristig stabieler - 3 stunden etwa....
Bitte warten ..
Mitglied: SamvanRatt
30.09.2010 um 19:33 Uhr
Wie viele BadBlocks meldet denn dein chkdsk (kannst du im Eventlog-System-winlogon nachsehen)? Die Probleme die ich in der Richtung kenne stammen alle von einem Fehlverhalten HD/Controller her: wenn der Kontroller bei x sek keine Daten bekommen hat (HD) muß er die HD entweder deaktivieren oder den Block markieren/austauschen. Dein OS sollte nur bei nicht wiederherstellbaren Blöcken (von 3 members im R5 also zwei gleichzeitig Bad). Bisher entspricht es meiner Erfahrung wenn die HDs nicht den Richtlinien folgen, sprich vom (controller) Hersteller auch nicht dafür erlaubt sind; da hatte ich selbst schon ein Array aus 16 Hds bei der am Tag so zwei ausfielen und ich erst nach dem Wechsel der alten Marke (SGT) auf die neue (HIT) keine Ausfälle in JAhren vermelden mußte; Problematisch war dabei eher das die HD einwandfrei im Test und Verhalten war aber mit dem Timing des Controllers (Areca) gar nicht zurecht kam.
Gruß
Sam
Bitte warten ..
Mitglied: existenz
01.10.2010 um 08:47 Uhr
kannst du mir vielleicht helfen wie ich die festplatte lokalisiere welche sich hinter \Device\Harddisk1 verbirgt?
Bitte warten ..
Mitglied: SamvanRatt
01.10.2010 um 09:12 Uhr
Hi
ja das ist die Windowsbezeichnunng für die erste Logische HD; das ist die OS Ansicht, sprich dein R5 Array ist damit gemeint. Bei einem Hardware RAID soll das OS auch nichts davon sehen (transparent); wenn dann muß dein Kontroller das sehen (entgegen meiner teils schlechten Erfahrung mit bestimmten Kombinationen).
An Deiner Stelle (mußte das ja auch schon öfters durchgehen), würde ich folgendes machen:
a) Treiber im OS auf Stand bringen
b) Firmware im Kontroller auf Stand bringen
c) SMART Werte auslesen+HD's einzeln (offline) mittels ddrescue 1:1kopieren um auf Lesefehler zu stoßen; danach SMART erneut auslesen und vergleichen. [sofern du drei HDs nur hast kannst du sie ja alle parallel testen; bei 10 oder 15k HDs geht das ja innerhalb einer Stunde]
d) sofern die HDs in Ordnung sind solltest du asap einen anderen Kontroller angehen und solange möglich ein Image von der jetzigen Inst ziehen (HDs wieder online).

Solltest du eine def HD finden, kannst du sie mit der R5 Rebuild Funktion ersetzen, zur Not (lesefehler auf zweiter dazu) kannst du immer noch ein Image mittels ddrescue erstellen.

Wenn alle Stricke reißen: ich lebe von solchen Fällen. Vermutlich ist es aber ein simpler Bug im Kontroller (SMART Werte lügen nur selten)
Gruß
Sam
Bitte warten ..
Mitglied: existenz
07.10.2010 um 10:18 Uhr
Nur zur Info - Problem war ein Defekter USB-Kontroller.... jetzt läuft wieder alles Problemlos
Bitte warten ..
Mitglied: SamvanRatt
07.10.2010 um 10:32 Uhr
Hi
hast du eine HD am USB Kontroller dran (die kriegt natürlich auch Harddisk Kennung)?
Gruß
Sam
Bitte warten ..
Mitglied: existenz
07.10.2010 um 10:35 Uhr
ja hatte ich - die sicherungsplatte war über usb angeschlossen. Festplatte hat einen Crash.
Bitte warten ..
Mitglied: SamvanRatt
07.10.2010 um 11:00 Uhr
Ja dann klar; habe an die Möglichkeit gar nicht gedacht das du noch ein anderes System benutzt
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
Fehlerhafte Blöcke im RAID 10
gelöst Frage von Kojak-LEFestplatten, SSD, Raid12 Kommentare

Hallo liebe Gemeinde, ich habe mich heute angemeldet, weil ich so langsam verzweifle und mein technisches Wissen an seine ...

Backup
QNAP NASC77A61 mit Fehlerhaften Blöcken
Frage von Fitzel69Backup11 Kommentare

Hallo zusammen, anbei folgendes Problem: Ich versuch mit Windows Boardmitteln Sicherungen auf einem QNAP NASC77A61 durchzuführen. Seit etwa 1 ...

SAN, NAS, DAS
Raid 5 System - zwei Partitionen weg
gelöst Frage von gn3wbi3SAN, NAS, DAS12 Kommentare

Hallo, leider sind bei einem Raid 5 System von uns mitten im Betrieb die Partitionen verloren gegangen. Es war ...

RedHat, CentOS, Fedora
Welches RAID-System für einen Fileserver auf CentOS 7?
Frage von SlobodanRedHat, CentOS, Fedora14 Kommentare

Hallo zusammen, ich benötige Hilfe bei der Einrichtung des RAID-Systems für unseren Fileserver mit dem OS CentOS 7 Welches ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 106 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
Frage von HelloWorldBatch & Shell16 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...

Hardware
Fujitsu Workstation mit K80 und Quadro P5000, Fehlermeldung: Connect Power Adapter
Frage von MachelloHardware7 Kommentare

Hallo Zusammen, ich benötige euren Rat da ich ratlos bin. Folgende Konfiguration im Büro: Fujitsu Workstation Celcius R940 Power ...