Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehlerhafte Automatik bei USB Treiberinstallation

Frage Hardware

Mitglied: martin1ehm

martin1ehm (Level 1) - Jetzt verbinden

23.09.2009 um 16:38 Uhr, 7175 Aufrufe, 5 Kommentare

Bei der Installation von USB Geräten (Egal welches, Maus, Tastatur, Speicher, Kamera,...... also bei allen) findet Windows XP zwar das Gerät jedoch den Treiber dafür nicht von selbst.

Ein herzliches Hallo an alle "administratoren.de" Benutzer...

..ich melde mich hier mit einer Frage und hoffe das mir jemand mit einer Kurzen (oder auch längeren) Anleitung zur Problembehebung helfen kann..




-->Bei der Installation von USB Geräten (Egal welches, Maus, Tastatur, Speicher, Kamera,...... also bei allen) findet Windows XP zwar das Gerät jedoch den Treiber dafür nicht von selbst.


Genaues Problem (bzw. Mein Vorgehen und Was mir aufgefallen ist)

1. PC einschalten, anmelden etc..(mit PS2 Maus/Tastatur --> Da USB ja nicht hinhaut)
2. Beim Anschließen eines USB Gerätes, passiert genau.... -> NICHTS!
3. Im Gerätemanager findet sich das Gerät als "USB - Device" wider, jedoch mit gelben Fragezeichen icl. kleinen gelben Rufzeichen.
4. Als Fehler wird (Code 1) angegeben:
--- Das Gerät ist nicht richtig konfiguriert. (Code 1)
--- Klicken Sie auf TREIBER AKTUALISIEREN, um die Treiber zu aktualisieren. Falls das Problem erneut auftritt, schauen Sie in die Hardwaredokumentation des entsprechenden Geräts.


Jetzt kommt das Intresannte an der Geschichte (oder woran ich gescheitert bin).

Wenn man auf Microsoft Hört und der Problembehebung folgt (Den Treiber von Hand neu installiert) wird das Gerät sofort erkannt und funktioniert Fehlerfrei.

Die von getesteten Geräte sind nichts besonderes, es handelt sich um eine schnöde HP (Usb) Tastatur einen USB stick (auch nichts besonderes) und um eine Microsoft Maus mit TiltWheel (funktioniert bei allen anderen 20 PCs bei uns im Betrieb auch ohne den Treiber extra installieren zu müssen)

Mein Schluss Daraus ist das die USB Treiber nicht automatisch installiert werden.



Es handelt sich bei den PC um einen HP Compaq dx2400 Microtower. (Die Windows XP Ausführung --> SP3)
-- UPNP Service ist gestartet und meldet Fehlerfrei, wobei ich denke das es nicht an dem liegt, weil ohne den Service noch mehr nicht gehen würde.
-- Treibercache wurde von mir gelöscht.
-- Alle USB Hubs und Controller Treiber neu installiert
-- Chipset treiber neu installiert



Vielen, vielen Dank im voraus falls mir bei der Sache wer helfen könnte.


Mfg Martin
Mitglied: 45877
23.09.2009 um 16:57 Uhr
Hallo,

sowas hattee ich auch schon mal, da war die Pfadangabe zum Treiberordner in der registry nicht mehr in Ordnung.

http://www.mcseboard.de/windows-forum-allgemein-28/treiberdatenbank-def ...
Bitte warten ..
Mitglied: martin1ehm
23.09.2009 um 17:07 Uhr
Danke für die rasche Antwort...



Du meinst wohl das hier oder

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion:
%SystemRoot%\inf;%SystemDrive%\SWSetup\Drivers\32;%SystemDrive%\SWSetup\Drivers\Global;%SystemDrive%\SWSetup\PCCS;%SystemDrive%\SWSetup\PCCS2

Ergänzung...
...zu dem Link: Eine ähnliche Beschreibung hatte ich schon gefunden, hat aber nichts geholfen



Hatte ich auch schon in Verdacht aber das wars auch nicht...

Mfg Martin
Bitte warten ..
Mitglied: Snowman25
23.09.2009 um 17:16 Uhr
schau lieber nochmal ganz genau, wenn da nur ein kleines Semikolon fehlt, geht nix mehr.
hatte ich schonmal.. da hat mir der Treiber für meinen WLAN-Adapter den key umgeschrieben und das Semikolon (;) vergessen
evtl. mal alle USB-Controller nicht nur deinstallieren, sondern auch deaktivieren, dann neustarten und danach wieder aktivieren, neuinstallieren.
Bitte warten ..
Mitglied: martin1ehm
23.09.2009 um 17:18 Uhr
schau lieber nochmal ganz genau, wenn da nur ein kleines Semikolon fehlt, geht nix mehr .
---> Kann fast nicht sein da ich es (zur vorsicht) von einen Funktionierenden gerät rauskopiert habe...

evtl. mal alle USB-Controller nicht nur deinstallieren, sondern auch deaktivieren, dann neustarten und danach wieder aktivieren, neuinstallieren.

---> wie oben vl nicht ganz genau so beschireben, aber hab ich auch schon
Bitte warten ..
Mitglied: Snowman25
24.09.2009 um 10:05 Uhr
Vielleicht hilft es dir ja, wenn du die Treiber neu in dein System eingliederst.
Auf der XP Installations-CD gibt es eine Driver.cab (am besten die von SP2) im Ordner i386. Diese kannst du im cmd-Prompt per extract entpacken. Das dauert ein wenig, weil das zigtausende Files sind.
Dort wirst du dann einige Files finden, die .dl_, .ex_ und .in_ als Erweiterung haben.
Diese kannst du per cmd-Prompt und dem Befehl expand in ihre eigentlichen Formate umwandeln.
Und die Files, die du dann bekommst, teilst du auf.
SYS-Dateien kopierst du nach %windir%\System32\drivers
INF-Dateien kommen nach %windir%\inf
für die restlichen Dateien kenne ich die Orte gerade nicht, musst halt schauen, wo die schon vorhanden sind.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
USB Festplatte eingesteckt - Netzwerkverbindung fehlerhaft
gelöst Frage von netzwerkschlumpfLAN, WAN, Wireless6 Kommentare

Grüß' euch! Ich habe im Heimnetzwerk eines Kollegen folgendes (sonderbares) Problem: Beim Einstecken einer USB Festplatte an das NAS ...

Windows 7
Windows Update für Treiberinstallation fehlt
Frage von Squal10Windows 72 Kommentare

Hallo zusammen, ich brauche einen speziellen PS Treiber von Microsoft den ich nur über Windows Update beziehen kann. Bei ...

Windows Installation
Treiberinstallation unter Win 7 nicht zu knacken??
Frage von maken14Windows Installation14 Kommentare

Hallo, seid mein Sohn seinen Quadro mittels einer Assistenten SW konfigurieren möchte und dies leider nach Stunden langen Recherchen ...

Windows Tools
Automatische Erkennung von Hardware und Treiberinstallation
gelöst Frage von unixminWindows Tools10 Kommentare

Hallo zusammen, ich suche eine Freeware mit der unbekannte Hardware erkannt wird und passende Treiber automatisch installiert werden. Ich ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 2 StundenViren und Trojaner

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 6 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server15 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell10 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Windows Server
Administratoren-Gruppe abfragen?
Frage von 1410640014Windows Server6 Kommentare

Hallo, kennt jemand eine einfache (und schnelle) Möglichkeit, von allen Client-Computern im Active Directorey die Administratoren-Gruppe abzufragen, wer da ...