Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehlermeldung Unzulässige Parameteranzahl bei xcopy Batch

Frage Entwicklung Batch & Shell

Mitglied: hiho

hiho (Level 1) - Jetzt verbinden

04.04.2006, aktualisiert 06.04.2006, 43722 Aufrufe, 6 Kommentare

Hallo!

Ich kenne mich nicht so gut aus mit den Computern (bin halt eine Frau ), aber ich habe versucht mich durchzuwurschteln, nachdem ich mir eine externe Festplatte zur Sicherung meiner Daten gekauft habe. Habe über den Befehl xcopy recherchiert und alles auch ganz gut verstanden, dachte ich, und dann versucht, eine solche Batch zu schreiben. Folgender Inhalt:

@echo off
xcopy c:\Dokumente und Einstellungen\Besitzer\Eigene Dateien i:\Sicherung Eigene /d /e /i /y
pause

Es gibt keine zusätzlichen Leerzeichen davor oder dahinter, alles schon kontrolliert. Aber es kommt immer diese doofe Fehlermeldung mit der unzulässigen Parameteranzahl. Ich bin schon ganz verzweifelt.

Es kann doch nciht daran liegen, dass der Ordner 'Sicherung Eigene' auf der ext. Festplatte noch nicht existiert, oder?

Wo wir gerade dabei sind: sollte ich (wenn die batch dann irgendwann mal funktioniet) auch noch den Buchstaben a/ aufnehmen? Ein Kollege hat mir irgendwas erzählt von einem Attribut, das die neuen/bearbeiteten Dateien bekommen und die dann durch a/ mit kopiert werden. Aber ist das nicht schon durch d/ abgedeckt?

Für Hilfe bin ich dankbar!

hiho

Wichtiges PS: In der Vorschau dieses Beitrags stehen meine Backslashes alle doppelt... ich weiß nicht warum und ob das auch so ist, wenn ich den Beitrag abschicke. In meiner Batch steht aber jeder Backslash nur einfach...
Mitglied: yashi
04.04.2006 um 19:12 Uhr
hiho hiho.
^^


Also Pfade mit Leerzeichen umschließen würde ich sagen.
xcopy "c:\Dokumente und Einstellungen\Besitzer\Eigene Dateien" "i:\Sicherung Eigene" /d /e /i /y
Noja. Kannst auch mal F1 drücken wenn du auf dem Desktop bist und dann xcopy eingeben - da sind alle Parameter erklärt.


mfg


/edit:
du meinst bestimmt den Parameter /d ?! Denn wenn du hinter den kein Datum schreibst, kopiert xcopy nur Dateien über die alten die NEUER sind (also seit dem letzten Backup wieder bearbeitet wurden)
Bitte warten ..
Mitglied: WithOutName
04.04.2006 um 19:24 Uhr
Ich kenne mich nicht so gut aus mit den
Computern (bin halt eine Frau ),

Bitte keine Ausreden.

@echo off
xcopy c:\Dokumente und
Einstellungen\Besitzer\Eigene Dateien
i:\Sicherung Eigene /d /e /i /y
pause

Du solltest dein Quell- und Zielverzeichnis in Anführungszeichen setzten oder generell(falls möglich) auf Leerzeichen in Datei- und Verzeichnisnamen verzichten.

Es kann doch nciht daran liegen, dass der
Ordner 'Sicherung Eigene' auf der ext.
Festplatte noch nicht existiert, oder?

Dafür hast du ja "/i".

Wo wir gerade dabei sind: sollte ich (wenn
die batch dann irgendwann mal funktioniet)
auch noch den Buchstaben a/ aufnehmen?

Nein, es sei denn du willst mit dem Archivbit arbeiten.

Aber ist das nicht schon
durch d/ abgedeckt?

Kopiert ohne Parameter nur neue Dateien.

Evtl. wirst du noch die Optionen /s /c /h benötigen.
Bitte warten ..
Mitglied: yashi
04.04.2006 um 19:37 Uhr
och.
War mein erster support. Und schon werd ich übersehen.
http://home.arcor.de/klimax/images/smileys/schnief.gif
Bitte warten ..
Mitglied: Biber
04.04.2006 um 19:44 Uhr
Moin hiho,

noch ein Schlusswort (ist ja eigentlich schon alles von yashi und WithNewName erschöpfend beantwortet worden)...

Bis Dein Batch einsetzbar ist, bau Dir vorläufig noch den Parameter "/L" mit ein.
Der zeigt dann die Dateien an, die er kopieren würde, wenn dieser xcopy mit diesen Parametern abgeschickt wird.

Und, wie auch schon geschrieben, die beiden Parameter "/a" und "/m" für Spielereien mit dem Archivbit... das ist Firlefanz. Fang da gar nicht mit an. Die sind nicht sinnvoll nutzbar, wenn Du Deine Daten immer in dasselbe Sicherungsverzeichnis sicherst (das tust Du aber, sonst wäre der "/d"-Paramater Quark).

Aber kannst ja mal Deinen Kollegen bitten, dass er mal eine sinnvolle Skizze machst, wie er denn mit dem Parameter "/a" bzw. mit dem Archivbit seine Sicherungen steuert...
Ich lese dann gerne Korrektur.. *gg

Gruß
Biber
Bitte warten ..
Mitglied: WithOutName
04.04.2006 um 20:04 Uhr
och.
War mein erster support. Und schon werd ich
übersehen.
http://home.arcor.de/klimax/images/smileys/schnief.gif

Als ich die Antwort begonnen habe, war dein Beitrag noch nicht vorhanden.
Bitte warten ..
Mitglied: hiho
06.04.2006 um 14:20 Uhr
Hallo zusammen,

danke für eure Hilfe, jetzt hat es geklappt.

Viele Grüße und schöne Ostern!

hiho
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Xcopy Batch-Datei (3)

Frage von Lauchheimer zum Thema Batch & Shell ...

Batch & Shell
XCopy bash script ungültige laufwerksangabe.? (5)

Frage von f0rml0s zum Thema Batch & Shell ...

Batch & Shell
gelöst Xcopy-script kopiert nur 1 datei? (2)

Frage von f0rml0s zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...