Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehlermeldungen bei der Installation von FAI auf einen Debian-Server

Frage Linux Debian

Mitglied: Phatty

Phatty (Level 1) - Jetzt verbinden

04.06.2008, aktualisiert 05.06.2008, 6143 Aufrufe, 10 Kommentare

Hallo!

Ich habe mit VMware Server einen virtuellen Server erstellt und Debian 4.0r1 installiert. Nun möchte ich zu späteren Testzwecken FAI installieren, aber ich bekomme viele Fehlermeldungen, wie folgt:


aptitude install fai-quickstart
Reading package lists... Done
Building dependency tree... Done
E: Could not get lock /var/lock/aptitude - open (11 Resource temporarily unavail able)
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Building tag database... Done
The following NEW packages will be automatically installed:
apt-move binutils cfengine2 dash debootstrap dhcp3-server fai-client
fai-doc genisoimage libapt-pkg-perl mkisofs nfs-kernel-server rsh-server
syslinux tftpd-hpa
The following packages have been kept back:
klibc-utils libklibc linux-image-2.6-686 linux-image-2.6.18-5-686
The following NEW packages will be installed:
apt-move binutils cfengine2 dash debootstrap dhcp3-server fai-client
fai-doc fai-quickstart fai-server genisoimage libapt-pkg-perl mkisofs
nfs-kernel-server rsh-server syslinux tftpd-hpa
0 packages upgraded, 17 newly installed, 0 to remove and 4 not upgraded.
Need to get 1253kB/5991kB of archives. After unpacking 18.4MB will be used.
Do you want to continue? [Y/n/?] Y
Get:1 http://ftp.de.debian.org etch/main dash 0.5.3-7 [86.0kB]
Get:2 http://ftp.de.debian.org etch/main apt-move 4.2.26-1 [49.7kB]
Get:3 http://ftp.de.debian.org etch/main genisoimage 9:1.1.2-1 [552kB]
Get:4 http://ftp.de.debian.org etch/main mkisofs 9:1.1.2-1 [884B]
Get:5 http://ftp.de.debian.org etch/main fai-doc 3.1.8 [562kB]
Get:6 http://ftp.de.debian.org etch/main fai-quickstart 3.1.8 [1880B]
Fetched 1253kB in 7s (160kB/s)
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
Selecting previously deselected package dash.
(Reading database ... 18458 files and directories currently installed.)
Unpacking dash (from .../archives/dash_0.5.3-7_i386.deb) ...
Selecting previously deselected package apt-move.
Unpacking apt-move (from .../apt-move_4.2.26-1_i386.deb) ...
Selecting previously deselected package binutils.
Unpacking binutils (from .../binutils_2.17-3_i386.deb) ...
Selecting previously deselected package cfengine2.
Unpacking cfengine2 (from .../cfengine2_2.1.20-1_i386.deb) ...
Selecting previously deselected package dhcp3-server.
Unpacking dhcp3-server (from .../dhcp3-server_3.0.4-13_i386.deb) ...
Selecting previously deselected package genisoimage.
Unpacking genisoimage (from .../genisoimage_9%3a1.1.2-1_i386.deb) ...
Selecting previously deselected package libapt-pkg-perl.
Unpacking libapt-pkg-perl (from .../libapt-pkg-perl_0.1.20_i386.deb) ...
Selecting previously deselected package mkisofs.
Unpacking mkisofs (from .../mkisofs_9%3a1.1.2-1_all.deb) ...
Selecting previously deselected package nfs-kernel-server.
Unpacking nfs-kernel-server (from .../nfs-kernel-server_1%3a1.0.10-6+etch.1_i386.deb) ...
Selecting previously deselected package syslinux.
Unpacking syslinux (from .../syslinux_1%3a3.31-4_i386.deb) ...
Selecting previously deselected package debootstrap.
Unpacking debootstrap (from .../debootstrap_0.3.3.2etch1_all.deb) ...
Selecting previously deselected package fai-client.
Unpacking fai-client (from .../fai-client_3.1.8_all.deb) ...
Selecting previously deselected package fai-doc.
Unpacking fai-doc (from .../archives/fai-doc_3.1.8_all.deb) ...
Selecting previously deselected package fai-server.
Unpacking fai-server (from .../fai-server_3.1.8_all.deb) ...
Selecting previously deselected package tftpd-hpa.
Unpacking tftpd-hpa (from .../tftpd-hpa_0.43-1.1_i386.deb) ...
Selecting previously deselected package fai-quickstart.
Unpacking fai-quickstart (from .../fai-quickstart_3.1.8_all.deb) ...
Selecting previously deselected package rsh-server.
Unpacking rsh-server (from .../rsh-server_0.17-13_i386.deb) ...
Setting up dash (0.5.3-7) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing dash (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apt-move:
apt-move depends on dash; however:
Package dash is not configured yet.
dpkg: error processing apt-move (--configure):
dependency problems - leaving unconfigured
Setting up binutils (2.17-3) ...

Setting up cfengine2 (2.1.20-1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing cfengine2 (--configure):
subprocess post-installation script returned error exit status 1
Setting up dhcp3-server (3.0.4-13) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing dhcp3-server (--configure):
subprocess post-installation script returned error exit status 1
Setting up genisoimage (1.1.2-1) ...
Setting up libapt-pkg-perl (0.1.20) ...
Setting up mkisofs (1.1.2-1) ...
Setting up nfs-kernel-server (1.0.10-6+etch.1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing nfs-kernel-server (--configure):
subprocess post-installation script returned error exit status 1
Setting up syslinux (3.31-4) ...
Setting up debootstrap (0.3.3.2etch1) ...
dpkg: dependency problems prevent configuration of fai-client:
fai-client depends on cfengine2 | cfengine; however:
Package cfengine2 is not configured yet.
Package cfengine is not installed.
dpkg: error processing fai-client (--configure):
dependency problems - leaving unconfigured
Setting up fai-doc (3.1.8) ...

dpkg: dependency problems prevent configuration of fai-server:
fai-server depends on fai-client; however:
Package fai-client is not configured yet.
dpkg: error processing fai-server (--configure):
dependency problems - leaving unconfigured
Setting up tftpd-hpa (0.43-1.1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing tftpd-hpa (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of fai-quickstart:
fai-quickstart depends on fai-server; however:
Package fai-server is not configured yet.
fai-quickstart depends on dhcp3-server; however:
Package dhcp3-server is not configured yet.
fai-quickstart depends on nfs-kernel-server | nfs-server; however:
Package nfs-kernel-server is not configured yet.
Package nfs-server is not installed.
Package nfs-kernel-server which provides nfs-server is not configured yet.
fai-quickstart depends on tftpd-hpa; however:
Package tftpd-hpa is not configured yet.
fai-quickstart depends on apt-move; however:
Package apt-move is not configured yet.
dpkg: error processing fai-quickstart (--configure):
dependency problems - leaving unconfigured
Setting up rsh-server (0.17-13) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing rsh-server (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
dash
apt-move
cfengine2
dhcp3-server
nfs-kernel-server
fai-client
fai-server
tftpd-hpa
fai-quickstart
rsh-server
W: Could not lock the cache file. Opening in read-only mode; any changes you make to the states of packages will NOT be preserved!
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up dash (0.5.3-7) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing dash (--configure):
subprocess post-installation script returned error exit status 1
Setting up tftpd-hpa (0.43-1.1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing tftpd-hpa (--configure):
subprocess post-installation script returned error exit status 1
Setting up rsh-server (0.17-13) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing rsh-server (--configure):
subprocess post-installation script returned error exit status 1
Setting up nfs-kernel-server (1.0.10-6+etch.1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing nfs-kernel-server (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apt-move:
apt-move depends on dash; however:
Package dash is not configured yet.
dpkg: error processing apt-move (--configure):
dependency problems - leaving unconfigured
Setting up cfengine2 (2.1.20-1) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing cfengine2 (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of fai-quickstart:
fai-quickstart depends on nfs-kernel-server | nfs-server; however:
Package nfs-kernel-server is not configured yet.
Package nfs-server is not installed.
Package nfs-kernel-server which provides nfs-server is not configured yet.
fai-quickstart depends on tftpd-hpa; however:
Package tftpd-hpa is not configured yet.
fai-quickstart depends on apt-move; however:
Package apt-move is not configured yet.
dpkg: error processing fai-quickstart (--configure):
dependency problems - leaving unconfigured
Setting up dhcp3-server (3.0.4-13) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing dhcp3-server (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of fai-client:
fai-client depends on cfengine2 | cfengine; however:
Package cfengine2 is not configured yet.
Package cfengine is not installed.
dpkg: error processing fai-client (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fai-server:
fai-server depends on fai-client; however:
Package fai-client is not configured yet.
dpkg: error processing fai-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
dash
tftpd-hpa
rsh-server
nfs-kernel-server
apt-move
cfengine2
fai-quickstart
dhcp3-server
fai-client
fai-server



Ich kann damit überhaupt nichts anfangen. Woran liegt es, dass die Installation nicht funktioniert?
Mitglied: theton
04.06.2008 um 14:55 Uhr
'apt-get update' vorher gemacht und schonmal 'apt-get -f install' durchlaufen lassen?
Bitte warten ..
Mitglied: Phatty
04.06.2008 um 15:24 Uhr
Nein, ich kenne ja die ganzen Befehle nicht und stolper eher zufällig im Web drüber.

Was genau bewirkt der letzte deiner beiden Befehle?
Bitte warten ..
Mitglied: theton
04.06.2008 um 15:33 Uhr
Beim 'apt-get update' wird erstmal deine lokale Paketliste mit denen der Repositories abgeglichen. Idealerweile macht man danach auch gleich ein 'apt-get upgrade' und bringt das System auf den aktuellen Stand bevor man was installiert. 'apt-get -f install' installiert alle Pakete, die als "zu installieren" markiert wurden. Gerade nach unvollständigen upgrades usw. behebt man damit erstmal die gröbsten Abhängigkeitsprobleme ('-f' steht hier für 'fix-broken' und kann auch durch '--fix-broken' ersetzt werden). Du solltest dringend einen Blick in die Manpage werfen (einfach mal 'man apt-get' auf der Konsole eingeben).
Bitte warten ..
Mitglied: Phatty
05.06.2008 um 09:12 Uhr
Danke!

Aber schon beim "apt-get update" erhalte ich Fehler:

Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch Release.gpg
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch Release
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch/contrib Packages/DiffIndex
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch/main Packages/DiffIndex
Get:1 http://security.debian.org etch/updates Release.gpg [189B]
Get:2 http://ftp.de.debian.org etch Release.gpg [378B]
Hit http://security.debian.org etch/updates Release
Hit http://ftp.de.debian.org etch Release
Ign http://ftp.de.debian.org etch/main Packages/DiffIndex
Ign http://ftp.de.debian.org etch/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Hit http://ftp.de.debian.org etch/main Packages
Hit http://ftp.de.debian.org etch/main Sources
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/contrib Packages
Hit http://security.debian.org etch/updates/main Sources
Hit http://security.debian.org etch/updates/contrib Sources
Fetched 2B in 1s (1B/s)
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


Und bei Eingabe von "dpkg --configure -a" passierte scheinbar nichts. Hatte dann durch Recherche gemerkt, dass das normal ist. ^^

Bei einen anschließenden "apt-get upgrade" kam dann das:
http://img396.imageshack.us/img396/4669/unbenanntvu8.png

Ich kann dann nichts mehr machen. Es gibt keine Reaktion mehr. Auch bei anderen Befehlen wie "aptitude install fai-quickstart" kommt nach einer Weile immer das selbe blaue Fenster.
Bitte warten ..
Mitglied: theton
05.06.2008 um 12:19 Uhr
Das Fenster besagt lediglich, dass dein Kernel aktualisiert wird. Einmal auf 'TAB' drücken damit der OK-Button ausgewählt wird und dann mit Enter bestätigen.
Bitte warten ..
Mitglied: Phatty
05.06.2008 um 12:54 Uhr
Aha, das hatte ich gerade eben (wenn auch eher zufällig) schon herausgefunden.
Nun hab ich die FAI-Pakete auf den Server und vor der Installation soll ich bestimmte Dateien editieren. Mit welchen Befehlen macht man das?
Bitte warten ..
Mitglied: theton
05.06.2008 um 13:13 Uhr
Die Dateien editierst du natürlich einfach mit deinem Lieblingseditor. Ggf. brauchst du dafür root-Rechte, falls die Dateien nicht deinem Benutzer gehören.
Bitte warten ..
Mitglied: Phatty
05.06.2008 um 13:19 Uhr
Ja, die Frage ist wie mach ich das? Habe ja keine grafische Oberfläche und kenne Debian überhaupt nicht.
Bitte warten ..
Mitglied: theton
05.06.2008 um 13:29 Uhr
Einfach auf der Konsole 'nano /pfad/zur/datei' eingeben. Ausserdem solltest du dir mal ein Grundlagen-Buch zur Arbeit mit Linux zulegen/lesen, z.B. http://debiananwenderhandbuch.de/
Bitte warten ..
Mitglied: Phatty
05.06.2008 um 13:54 Uhr
Aha, danke.

Also ob ich mir jetzt ein Buch zulege, denke ich erstmal nicht. Ich benutze Debian ja jetzt nur im Praktikum. Aber danke für den Link, ist sehr nützlich.
Bitte warten ..
Ähnliche Inhalte
Debian
Debian Wheezy Postgresql installation
gelöst Frage von Thomas91Debian5 Kommentare

Hallo zusammen, ich habe Debian Wheezy installiert um darauf openz zu installieren. Nun möchte ich für die Software openz ...

Windows Installation
Fehlermeldung bei Installation mit Windows XP
gelöst Frage von bestelittWindows Installation7 Kommentare

Hallo nochmal, schon wieder ein Problem bei der Installation unter Windows XP :( Diese Fehlermeldung kommt, nachdem die Dateien ...

Sicherheits-Tools
OfficeScan11 Agent Installation - Fehlermeldung
Frage von Chaser21aSicherheits-Tools2 Kommentare

Hallo Community, Ich habe bei einem Server Probleme mit der Installation des Agents von TrendMicro OfficeScan 11. Der alte ...

Microsoft
Server 2012 nach Installation von Win10 Administrative Templates Fehlermeldung
gelöst Frage von thomasreischerMicrosoft3 Kommentare

Hallo ich habe heute die Windows 10 Templates auf meinem Windows Server 2012 installiert ) und zwar unter diesem ...

Neue Wissensbeiträge
Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 4 StundenInternet2 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 8 StundenDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 8 StundenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 12 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...