Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Frage zu NAT im LAN

Frage Netzwerke Router & Routing

Mitglied: ef8619

ef8619 (Level 1) - Jetzt verbinden

06.02.2015, aktualisiert 07.02.2015, 1095 Aufrufe, 4 Kommentare

Hallo,

ich habe einen Cisco IOS Router. Über eine Public IP greife ich von außerhalb auf einen Webserver im lokalen Netz zu. Hierfür habe ich einen NAT-Befehl im Router eingetragen mit Port 443. Funktioniert wunderbar.

Nun habe ich das Problem, dass ich auch innerhalb des Netzes auf diesen Server von Notebooks aus zugreifen muss. Das Problem ist, dass ich in der entsprechenden Software, von der aus auf den Server zugegriffen wird, nicht jedes Mal die IP ändern kann (d.h. interne IP sobald das Notebook im LAN steckt, Public IP sobald es nicht mehr im Firmennetz ist).

Gibt es denn hier eine Möglichkeit den Router so einzustellen, dass er automatisch auf eine definierte lokale IP routet, sobald ein Gerät aus dem lokalen Netz auf die öffentliche IP mit Port 443 zugreifen möchte?

Bsp.: Gerät aus dem Netz 192.168.1.0 fragt öffentliche IP an -> Router merkt dass Anfrage aus lokalem Netz kommt und leitet von öffentlicher IP auf interne IP 192.168.1.100 weiter.

Gruss
Mitglied: stefaan
LÖSUNG 06.02.2015, aktualisiert 07.02.2015
Servus,

das Stichwort ist Split-DNS: Lege dir einen DNS-Namen an, z.B. server.domain.de, der zeigt von außen auf deine öffentliche IP. Auf deinem internen DNS-Server legst du einen Eintrag mit der internen IP an. Dann klappts von innen und außen ohne Konfigurationsänderung.

Grüße, Stefan
Bitte warten ..
Mitglied: chiefteddy
LÖSUNG 06.02.2015, aktualisiert 07.02.2015
Hallo,

das ist kein NAT-Problem. Schau mal unter dem Stichwort Split-DNS bei "Google" nach.

Greife also nicht direkt über die IP auf den HTTPS-Dienst zu, sondern über den DNS-Namen des Dienstes/ Servers. Sorge dann dafür, das abhängig davon, ob Du von außen oder von innen zugreifst, der jeweilige DNS-Server die "richtige" IP ausliefert.

Jürgen
Bitte warten ..
Mitglied: Lochkartenstanzer
07.02.2015, aktualisiert um 11:01 Uhr
Moin,

das kann man entweder mit Split-DNS lösen, wie die Kollegen schon sagten, oder mit Hairpin-NAT, was die Cisco eigentlich auch können sollte.

lks
Bitte warten ..
Mitglied: ef8619
07.02.2015 um 12:37 Uhr
Die Split DNS Variante hat super funktioniert. Ich danke euch!
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Zugriff auf Webinterface vom Router aus dem LAN hinter doppelten NAT (6)

Frage von StefanKittel zum Thema Router & Routing ...

Netzwerkmanagement
gelöst Frage zum Netzwerksetup (Lan und Wlan) (10)

Frage von NetzNewbie zum Thema Netzwerkmanagement ...

Router & Routing
Lancom Router NAT (7)

Frage von Brian85 zum Thema Router & Routing ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (16)

Frage von Static zum Thema CMS ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Batch & Shell
Skripterstellung Lehrling (22)

Frage von 133119 zum Thema Batch & Shell ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...