Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

FreeNAS 8 und Active Directory

Frage Microsoft Windows Netzwerk

Mitglied: goodbytes

goodbytes (Level 2) - Jetzt verbinden

30.04.2011, aktualisiert 31.05.2011, 10058 Aufrufe, 10 Kommentare

Hallo,
ich habe mir eine Testdomäne aufgebaut: DC ist ein Server 2008 R2 (SP1), zwei Hyper-V Server 2008 R2 (SP1) und zur Ablage ein Storage (FreeNAS 8.2 R5).

Das Storage ist wie die anderen Server ordnungsgemäß in dei Domäne eingebunden (Abfrage mittels "net rpc testjoin" usw. ist alles i.O), auch DNS-mäßig alle Einträge bei allen Beteiligten korrekt gesetzt.

Nun möchte ich gerne, dass die Benutzer auf den Windows-Maschinen sich beim Storage mit ihrem Active Directory Account authentifizieren. Bei früheren Versionen gab es unter den CIFS-Optionen (Samba) offenbar drei Authentifizierungsmethoden: Anonymous, Lokal und Active Directory. Bei meiner Installation stehen aber nur die ersten zwei Optionen zur Verfügung, trotz korrekter Einbinung in die Domäne (die Sicherheits-Log`s auf dem DC zeigen auch die korrekte Identifizierung aller Maschinen an. Im AD angelegt habe ich das Storage auch direkt aus der FreeNAS-Verwaltung, also wurde auch der angegebene Domänen-Account akzeptiert.

Wo kann da das Problem liegen? Ich muss doch nicht unbedingt den umständlicheren Weg über die LDAP-Konfiguration gehen...

Irgendwie muss es ja funktionieren, vielleicht kann man ja irgendwelche Eintrage in irgendwelchen conf-Dateien dafür setzen?

Torsten

Ach ja, hier auch ein Hilfesuchender, auf den ich bei meinen Recherchen im Net gestoßen bin:

Has anyone successfully used AD authentication using the latest version of FreeNAS with Windows 2008 R2 domain controllers? I wanted to use FreeNAS to host files and share them via CIFS but I couldn’t make FreeNAS authenticate with a Windows 2008 R2 domain controller. Ultimately, the new CIFS shares will be referenced in the DFS namespace that we already have running on Windows 2008 R2 servers.

Any tip you can share with me?
Mitglied: KenBugul
30.04.2011 um 13:21 Uhr
Hallo Torsten ich kann dir zwar nich helfen, aber du bist mit diesem Problem nicht alleine. Stehe gerade genau vor dem gleichen Problem.
Ich hänge mich einfach mal mit in diesen Thread. Wenn ich etwas finde gebe ich dir Bescheid.
Bitte warten ..
Mitglied: goodbytes
30.04.2011 um 16:14 Uhr
Hi KenBugul,
naja, ist wenigstens ein schwacher Trost, daß ich nicht alleine dieses Problem habe. Ich hab echt schon an mir gezweifelt...

Vielleicht meldet sich ja irgendwann mal jemand der es geschafft hat.

Es könnte ja auch eventuell ein Problem sein, das erst bei einem 2008-er DC auftritt. Ich hab bloß keine Lust extra eine 2003-er Domäne deswegen aufzusetzen.
Wäre ja auch nicht zeitgemäß zum Testen...

Wenn ich was herausbekomme schreibe ich`s gleich.

Torsten
Bitte warten ..
Mitglied: DarkhaZe
30.05.2011 um 14:48 Uhr
Hallo Zusammen,

ich habe das gleiche Problem und komm an dieser stelle auch nicht mehr weiter. Ich habe einen DC2003 Server somit brauchst du dies nicht testen, weil hier das gleiche Problem ist

lg
Bitte warten ..
Mitglied: goodbytes
30.05.2011 um 18:44 Uhr
Hm, da kann ich das ja ausschließen.
Aber ich bleibe dran - aus Prinzip, ich will's wissen. Bin da halt ein alter Sturkopf...

Naja, mal schauen. Vielen Dank für die 2003-er Info, spart mir da viel Arbeit.

Gruß
Torsten
Bitte warten ..
Mitglied: Tooly1987
31.01.2012 um 15:35 Uhr
Hi

sagt mal habt ihr mittlerweile schon ein Lösung für das Problem gefunden ?

MFG
Tooly
Bitte warten ..
Mitglied: goodbytes
31.01.2012 um 21:54 Uhr
Hi Tooly,
ach, jetzt hat`s mir mittlerweile zu lange gedauert, ich hab es mit FreeNAS sein lassen. Schade eigentlich...

Was solls...

Gruß
Torsten
Bitte warten ..
Mitglied: DarkhaZe
01.02.2012 um 08:11 Uhr
Hi,

also ich habe es auch aufgegeben!!!

lg

DarkhaZe
Bitte warten ..
Mitglied: Tooly1987
02.02.2012 um 12:10 Uhr
Hi,

muss leider sagen das ich mit FreeNas auch nicht weiter gekommen bin.

Ich kann euch OpenFiler aber sehr ans Herz legen.
Dort funktioniert die AD Integration ohne Probleme.


MFG
Tooly
Bitte warten ..
Mitglied: goodbytes
02.02.2012 um 13:23 Uhr
Hi Tooly,
danke für den Tipp, ich werde OpenFiler in den nächsten Tagen mal testen und natürlich auch Feedback geben.

Gruß
Torsten
Bitte warten ..
Mitglied: 48844
22.10.2013 um 15:57 Uhr
Zwar etwas älter das Thema aber nicht als gelöst markiert


unter Freenas 8 ist Active Directory unter Services zu finden dort Konfigurieren und Aktivieren


nach Config kann man mit der Console testen ob die Verbindung da ist

wbinfo –u User Info
wbinfo –g Group Info
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Sticky Notes - Autostart unterbinden

Tipp von Pedant zum Thema Windows 10 ...

Ähnliche Inhalte
Sonstige Systeme
gelöst Active Directory Abfragen konfigurieren oder andere erstllen als vorhanden (3)

Frage von SnvRCalle zum Thema Sonstige Systeme ...

Vmware
ESXi 6 Active Directory (3)

Frage von VerwirrterUser zum Thema Vmware ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Base64 Decode (Batch,VBS) (26)

Frage von clragon zum Thema Batch & Shell ...

Flatrates
DeutschlandLAN der Telekom - welche internen IPs? (19)

Frage von qualidat zum Thema Flatrates ...