Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Freenas abgeschossen, Daten weg?

Frage Hardware SAN, NAS, DAS

Mitglied: cschenk

cschenk (Level 1) - Jetzt verbinden

24.10.2009 um 18:55 Uhr, 8155 Aufrufe, 4 Kommentare

Hallo zusammen,

habe die letzten Tage meine kompletten Daten von meinem Laptop auf mein freenas verschoben, da ich mein Laptop neu formatieren und Windows 7 installieren möchte. Da das Verschieben von Filmen sehr langsam ging, habe ich an den Einstellungen der Netzwerkkarte rumgebastelt mit dem Ergebnis, dass sich mein freenas nicht mehr anpingen lies. Habe dann auf der Konsole die Netzwerkarte neu eingerichtet, aber auch ohne Erfolg.

Und dann kam der Geniestreich des abends: ich dachte, ich setze das Ganze auf die Werkseinstellungen zurück und spiele dann meine gesicherte Konfiguration wieder ein. Nach dem zurücksetzen habe ich dann mit Entsetzen festgestellt, dass meine Konfig- Datei auf dem freenas sind. Ich habe jetzt zwar wieder das freenas am Laufen, aber ohne Festplatten- Konfiguration!

Die Daten sind auf 2 Festplatten verteilt, die als JBOD mit einem Softraid konfiguriert sind. Freenas selber ist auf einem USB- Stick installiert.

Kann ich das Ganze neu aufsetzen und auf meine Daten wieder zugreifen? Oder eventuell die 2 Platten in ein NAS- Gehäuse einbauen und dann darauf zugreifen? Oder komme ich auf einem anderen Weg an die Daten oder zumindest an die Konfig- Datei?

Ich danke euch schonmal für die Hilfe.

Gruß
Stefan
Mitglied: aqui
24.10.2009 um 21:20 Uhr
Ggf FreeBSD ( Das ist das OS von FreeNAS) Boot CD booten und die Platten mit einem Festplatten_Universaladapter oder direkt anschliessen und mounten.
So sollten sich die Daten eigentlich wieder lesen lassen.
Mit Linux gehts auch z.B. Knoppix Live CD und dann die Platten mit dem Dateisystem FFS einhängen.
Normalerweise auch wenn du das FreeNAS neu aufsetzt und die Platten nicht neu formatierst oder partitionierst. Ersteres ist aber sicherer...
Bitte warten ..
Mitglied: cschenk
24.10.2009 um 22:11 Uhr
hallo aqui,

danke für deine Antwort.

Habe mir mal die livefs von FreeBSD gezogen (Knoppix läuft noch, aber bei DSL1000 dauert das). Die 2 Platten habe ich in dem Rechner gelassen und von CD gebootet (ok so, oder?). Nach Auswahl von ein paar Einstellungen komme ich an eine shell und ab da habe ich keine Ahnung mehr wie ich weiter vorgehen muss. Ich muss die Festplatten mounten und dann meine gespeicherte Konfig suchen und finden.

Ist es mit Knoppix einfacher, da eine grafische Oberfläche vorhanden?
Bitte warten ..
Mitglied: aqui
25.10.2009 um 15:17 Uhr
Checken welche Dateisystem benutzt ist und wo deine Platten dranhängen.
Dann z.B. sowas wie
mount -t ffs /dev/sda1 /mnt

Das mountet eine per USB angeschlossene Platte mit ffs Dateisytem ins Verzeichnis /mnt. Mit cd /mnt und dann ls -l kannst du dann den Inhalt der Platte ansehen.
Das /dev/xyz musst du bei dir anpassen je nachdem wo deine Platte physisch dranhängt.
Bei FreeBSD brauchst du den Typ nicht mit angeben, denn da ist FFS natürlich Default.
Da reicht dann ein einfaches mount /dev/xyz /mnt
Ein klein bischen Unix Grundschulwissen sollte man schon mitbringen oder mal bei Dr. Google nachfragen...
Bitte warten ..
Mitglied: cschenk
26.10.2009 um 14:24 Uhr
Habe mir nun einen USB- Adapter besorgt, Ubuntu 9.04 installiert und folgende Befehle in der Konsole eingegeben:

sudo -i
modprobe ufs (FFS kennt mein Ubuntu nicht)

Festplatte mit USB- Port verbunden

dmesg | tail folgende Anzeige:
root@shir-khan:~# dmesg | tail
[ 172.457676] sd 6:0:0:0: [sdb] Write Protect is off
[ 172.457682] sd 6:0:0:0: [sdb] Mode Sense: 00 38 00 00
[ 172.457687] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 172.458447] sd 6:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
[ 172.459067] sd 6:0:0:0: [sdb] Write Protect is off
[ 172.459072] sd 6:0:0:0: [sdb] Mode Sense: 00 38 00 00
[ 172.459076] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 172.459083] sdb: unknown partition table
[ 172.470286] sd 6:0:0:0: [sdb] Attached SCSI disk
[ 172.470417] sd 6:0:0:0: Attached scsi generic sg2 type 0

mkdir /home/laptop/ufs
mount -t ufs -ro ufstype=ufs2 /dev/sdb /home/laptop/ufs
folgende Anzeige:
root@shir-khan:~# mount -t ufs -ro ufstype=ufs2 /dev/sdb /home/laptop/ufs
mount: wrong fs type, bad option, bad superblock on /dev/sdb,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen – versuchen
Sie dmesg | tail oder so

cat /proc/partitions ergibt folgende Ausgabe:
root@shir-khan:~# cat /proc/partitions
major minor #blocks name

8 0 312571224 sda
8 1 10241406 sda1
8 2 46066387 sda2
8 3 1 sda3
8 5 35840983 sda5
8 6 3903763 sda6
8 7 10241406 sda7
8 8 56323858 sda8
8 9 149950678 sda9
8 16 976762584 sdb

eine erneute Eingabe von dsmeg | tail ergibt folgendes:
root@shir-khan:~# dmesg | tail
[ 2425.768636] You didn't specify the type of your ufs filesystem
[ 2425.768639]
[ 2425.768640] mount -t ufs -o ufstype=sun|sunx86|44bsd|ufs2|5xbsd|old|hp|nextstep|nextstep-cd|openstep ...
[ 2425.768643]
[ 2425.768644] >>>WARNING<<< Wrong ufstype may corrupt your filesystem, default is ufstype=old
[ 2425.769484] ufs_read_super: bad magic number
[ 2484.929108] CE: hpet increasing min_delta_ns to 22500 nsec
[ 2560.570543] ufs was compiled with read-only support, can't be mounted as read-write
[ 3674.375536] ufs was compiled with read-only support, can't be mounted as read-write
[ 4383.785074] CE: hpet increasing min_delta_ns to 33750 nsec

Was habe ich falsch gemacht bzw. wie muss ich vorgehen um doch noch auf die Platte zugreifen zu können?
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hyper-V
gelöst HyperV - VMs weg finde nix mehr (7)

Frage von Nemonautilus zum Thema Hyper-V ...

Cloud-Dienste
Amazon: Dieser Lkw transportiert Daten in die Cloud (1)

Link von Kraemer zum Thema Cloud-Dienste ...

VB for Applications
Excel VBA Sortierung von Daten (5)

Frage von easy4breezy zum Thema VB for Applications ...

Backup
gelöst Datensicherung von Daten, auf denen die ganze Zeit gearbeitet wird (8)

Frage von Windows11 zum Thema Backup ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...