Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gbit LAN Performance schlecht - Wo ist der Flachenhals?

Frage Netzwerke Netzwerkmanagement

Mitglied: rassel

rassel (Level 1) - Jetzt verbinden

21.11.2008, aktualisiert 25.11.2008, 5855 Aufrufe, 8 Kommentare

Hallo,
nach Installation eines RAID Systems am Windows Server 2003 erhoffte ich mir im Gbit LAN nun einen sprunghaften Anstieg der Übertragungsraten.

HDD Tests am Server ergeben folgende READ Performance:

AJA System Test: 124 MB/s
Canopus Rextest: 119 MB/s

Das ist für mich absolut zufriedenstellend.

Die Netzwerk Performance habe ich mit iperf gestestet. Ergebnisse schwanken hier zwischen 80 und 95 MB/s. Auch das reicht mir völlig.

Wenn ich allerding Dateien kopiere oder Quicktim-Filme abspiele komme ich nicht annähernd an diese Benchmarkergebnisse ran.

Quicktimes mit 35 MB/s und auch weniger laufen schon nicht mehr richtig. Programme wie DiskSpeed und DiskBench liefern Ergebnisse von ca. 25 MB/s.

Das macht mich wahnsinnig. Ich habe meinem Kunden unter Versprechung von deutlichen Performanceverbesserungen die entsprechende Hardware aus den Rippen geleiert. Die Performance muß ich jetzt auch liefern.

Wer hat einen Ansatzpunkt?

Danke,
rassel
Mitglied: dog
21.11.2008 um 13:42 Uhr
25MB/s ist für tatsächliche Daten schon ein guter Wert

GbE muss ja per Definition 125MB/s schaffen - das klappt mit guten und teuren Karten, die billigen von Realtek schaffen immer um die 60MB/s.

SATA-Festplatten im RAID5 sollten je nach Controller 100-150MB/s schaffen.

Allerdings sind alle aktuellen Netzwerkprotokolle aus der Steinzeit (Oxymoron) und schaffen nichtmal annähernd diese Raten.
Die besten Werte die ich bisher gesehen habe waren bei FTP mit 40-45MB/s.
100Mbit muss übrigens nur 12MB/s schaffen - also ist das doch schon eine Steigerung um 100% ;)

Wenn du wirklich Performance brauchst (z.B. weil du mit RAW-Filmdaten arbeitest) musst du ein RAID-System und Glasfaser-SAN benutzen.

Grüße

Max
Bitte warten ..
Mitglied: aqui
21.11.2008 um 15:07 Uhr
Diese Massnahmen solltest du in jedem Falle auch durchführen !

http://www.psc.edu/networking/projects/tcptune/

bzw. in Ansätzen auch hier:

http://www.heise.de/netze/TCP-IP-Tuning--/artikel/97619
Bitte warten ..
Mitglied: rassel
21.11.2008 um 15:51 Uhr
danke an euch beide.

protokoll (TCP/IP) schließe ich aus - da iperf damit nahezu brutto=nette rausholt.

in der anregung des links von aqui schraube ich gerade an der paketgröße. nach neustart von server und client bin ich schlauer...

bis dann.
rassel
Bitte warten ..
Mitglied: NetWolf
21.11.2008 um 19:21 Uhr
Hallo rassel,

nur so eine Idee/Erfahrung:
welche AV-Programme laufen auf dem Server und Clients?

Teste mal mit ausgeschalteten AV-Programmen. (Bei einigen muss man den Dienst noch manuell anhalten, weil normales Deaktivieren nichts wirklich bewirkt!!)

Grüße aus Schönberg (Lübeck)
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: rassel
24.11.2008 um 21:08 Uhr
hallo,
merkwürdigerweise habe ich keine email aufgrund deiner mail erhalten.

der ansatz ist echt gut und bringt lokal auf dem server einen performancesprung von ca. 15 MB/s - das hätte ich nicht gedacht.

leider stagniert die performance über samba weiterhin.

im übrigen hat das ändern der paketgröße auch nichts gebracht.

da ich schon öfter gelesen habe ftp, anstatt samba zu verwenden:
gibt es eine andere möglichkeit außer novell netdrive die freigaben auf den clients komfortabel zur verfügung zu stellen. wenn ja, würde ich damit auch gerne mail einen test fahren.

danke,
rassel
Bitte warten ..
Mitglied: NetWolf
24.11.2008 um 22:29 Uhr
Hallo rassel,

wieso SAMBA? davon war bisher nicht die Rede!
Novell netdrive als Client-Login? warum dass denn?

Mit einem MS-Server geht die Freigabe ohne das alles. Rechtsklick auf den Ordner/Platte -> Eigenschaften -> Freigabe
Vorausgesetzt die Clients sind im AD aufgeführt und melden sich über die normale Netzwerkanmeldung mit Passwort am Server an.

Mit dem Explorer (des Clients) kannst du dann in der Netzwerkumgebung die Freigaben mappen.

Wenn du dann noch QoS abschaltest, solltest du eine gute Performance bekommen.
Für die Videos empfehle ich den VLC-Player.

Grüße aus Schönberg (Lübeck)
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: rassel
25.11.2008 um 09:44 Uhr
sorry, ich meinte nicht samba sonder genau genommen SMB.

da ich gelesen hatte, das ftp bessere performance als smb bringen soll, dachte ich mir ich könnte ftp server als netzlaufwerk mit netdrive verbinden. ansonsten ist mir keine komforble lösung für das einbinden von ftp servern bekannt.

qos abschalten werde ich nacher beim kunden mal probieren.

danke und gruß,
rassel
Bitte warten ..
Mitglied: rassel
25.11.2008 um 18:24 Uhr
auch deaktivieren von QoS brachte keine besserung...

hat noch jemand ideen?

danke,
rassel
Bitte warten ..
Ähnliche Inhalte
Benchmarks
Sehr schlechte SSD Performance
gelöst Frage von HenereBenchmarks9 Kommentare

Hallo zusammen, Hardware: ASUS Z10PE 16-WS Xeon 2620 v3 64 GB Reg ECC Ram Samsung 950pro SSD NVMe Im ...

RedHat, CentOS, Fedora
Schlechte RAID Performance
gelöst Frage von plex88RedHat, CentOS, Fedora9 Kommentare

Hallo Zusammen, ich habe für die Arbeit einen kleinen Backupserver gebastelt dieser besteht aus: Intel Core Quad Q8200 2GB ...

Datenbanken
MySQL Abfrage schlechte Performance
Frage von TorstenEDatenbanken7 Kommentare

Ich mache folgende Abfrage Suche alle Artikel in welchem der "Suchbegriff" im Name des Artikels vorkommt oder in 2 ...

Netzwerkmanagement
Schlechte Performance im Heimnetz - Optimierungsmöglichkeiten
Frage von Matthias182Netzwerkmanagement39 Kommentare

Hallo zusammen, ich suche aktuell mal wieder nach etwas Unterstützung, um mein Heimnetz zu optimieren. Der Grund ist, dass ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 2 StundenViren und Trojaner

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 6 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server15 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell10 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Windows Server
Administratoren-Gruppe abfragen?
Frage von 1410640014Windows Server6 Kommentare

Hallo, kennt jemand eine einfache (und schnelle) Möglichkeit, von allen Client-Computern im Active Directorey die Administratoren-Gruppe abzufragen, wer da ...