Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum gehen die PATH Variablen von Windows XP verloren?

Frage Microsoft Windows XP

Mitglied: O-Marc

O-Marc (Level 1) - Jetzt verbinden

24.02.2011, aktualisiert 08:12 Uhr, 6050 Aufrufe, 5 Kommentare

Hallo zusammen,

ich habe ein Problem mit einem Windows XP Client in einer Active Directory Umgebung (Server 2003 R2).

Dieser Client hat nach einem Neustart seine PATH-Variablen "vergessen". Sie tauchen zwar unter den Systemvariablen auf, aber ich kann z.B. aus der Kommandozeile heraus keine Befehle wie "ping" benutzen.

Erst wenn ich in der Kommandozeile

"SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem"

eingebe, funktioniert es wie gewohnt. Nur muss ich das leider nach jedem Neustart tun.


Der Client unterscheidet sich sowohl von den GPOs als auch von der installierten Software und den Patches her nicht von anderen Clients in der Umgebung.

Weiß jemand einen Rat?

Viele Grüße
Marco


Nachtrag:
Die Ereignisanzeigen für Anwendung und System sind blitzsauber.
Mitglied: LittleFlame
24.02.2011 um 09:17 Uhr
Hallöchen O-Mark,

wenn du bei frisch gestartetem Rechner in dem Kommandozeile "set" eingibst, was erscheint dann unter "PATH"
Ist PATH einfach leer oder durch einen anderen Wert befüllt?
Betrifft dies nur die PATH Variable oder auch andere Variablen?

Grüße,
LF
Bitte warten ..
Mitglied: O-Marc
24.02.2011 um 09:31 Uhr
Hallo LF,

die mit SET angezeigten Variablen sehen vollständig und korrekt aus. Für PATH wird folgendes ausgegeben:

Path=SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem



Ist das fett markierte der Fehler weil es überflüssig ist?
Bitte warten ..
Mitglied: LittleFlame
24.02.2011 um 10:05 Uhr
Deine Vermutung ist richtig.

Versuch bitte mal folgendes:

Systemsteuerung - System - Reiter "Erweitert"

Scrolle bei Systemvariablen (Unten) bis du die Path Variable siehst.
Steht hier ebenfalls "SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem"?
Dann liegt der Fehler hier.

Die Frage ist dann nur noch, woher das kommt.

Grüße,
LF
Bitte warten ..
Mitglied: 48507
24.02.2011 um 10:08 Uhr
Wenn man es in der Konsole eingibt, gilt Path dann nur in dieser Session, also nicht systemweit. Mach es stattdessen über Eigenschaften - Arbeitsplatz........ Umgebungsvariablen.... SYSTEMvariablen... oder ähnlich.
Bitte warten ..
Mitglied: O-Marc
24.02.2011 um 10:32 Uhr
Habe das bei den Umgebungsvariablen geändert und jetzt funktioniert alles auch nach einem Neustart.
Ich verstehe nur nicht, wie sich da ein Fehler eingeschlichen hat. Der Client wird nur von mir verwendet und mir sind keine Änderungen an Software usw. bewusst.

Vielen Dank für die Hilfe, LittleFlame und spytnik.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
Windows Anmeldeinformationen gehen verloren
Frage von Tuborg85Windows Netzwerk4 Kommentare

Hallo Forengemeinde, wenn Sich mein Nutzer am Laptop mit Eth Kabel an das Netzwerk anmeldet gehen die Netzlaufwerke ja ...

Windows Server
Windows 2012R2 - Webanmeldeinformationen gehen verloren
Frage von Der-PhilWindows Server2 Kommentare

Hallo! Ich habe auf einem Windows 2012 R2 Terminalserver das Problem, dass die gespeicherten Passworte aus dem Internet Explorer ...

Virtualisierung
Vertrauenstellung zu Clients gehen verloren!
gelöst Frage von M.MoertlVirtualisierung8 Kommentare

Hi zusammen! Ich habe mich zu diesen Thema natürlich erst mal eingelesen. Doch leider musste ich festellen, dass kein ...

Windows Server
Windows 2012 Fileserver - Dateirechte gehen verloren
gelöst Frage von Florian86Windows Server11 Kommentare

Hallo, wir haben einen Windows 2012 R2 Fileserver. Auf diesen werden bestimmte Berechtigungen gesetzt. Jetzt gibt es User die ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 12 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 16 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware10 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...