Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum gehen die PATH Variablen von Windows XP verloren?

Frage Microsoft Windows XP

Mitglied: O-Marc

O-Marc (Level 1) - Jetzt verbinden

24.02.2011, aktualisiert 08:12 Uhr, 6026 Aufrufe, 5 Kommentare

Hallo zusammen,

ich habe ein Problem mit einem Windows XP Client in einer Active Directory Umgebung (Server 2003 R2).

Dieser Client hat nach einem Neustart seine PATH-Variablen "vergessen". Sie tauchen zwar unter den Systemvariablen auf, aber ich kann z.B. aus der Kommandozeile heraus keine Befehle wie "ping" benutzen.

Erst wenn ich in der Kommandozeile

"SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem"

eingebe, funktioniert es wie gewohnt. Nur muss ich das leider nach jedem Neustart tun.


Der Client unterscheidet sich sowohl von den GPOs als auch von der installierten Software und den Patches her nicht von anderen Clients in der Umgebung.

Weiß jemand einen Rat?

Viele Grüße
Marco


Nachtrag:
Die Ereignisanzeigen für Anwendung und System sind blitzsauber.
Mitglied: LittleFlame
24.02.2011 um 09:17 Uhr
Hallöchen O-Mark,

wenn du bei frisch gestartetem Rechner in dem Kommandozeile "set" eingibst, was erscheint dann unter "PATH"
Ist PATH einfach leer oder durch einen anderen Wert befüllt?
Betrifft dies nur die PATH Variable oder auch andere Variablen?

Grüße,
LF
Bitte warten ..
Mitglied: O-Marc
24.02.2011 um 09:31 Uhr
Hallo LF,

die mit SET angezeigten Variablen sehen vollständig und korrekt aus. Für PATH wird folgendes ausgegeben:

Path=SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem



Ist das fett markierte der Fehler weil es überflüssig ist?
Bitte warten ..
Mitglied: LittleFlame
24.02.2011 um 10:05 Uhr
Deine Vermutung ist richtig.

Versuch bitte mal folgendes:

Systemsteuerung - System - Reiter "Erweitert"

Scrolle bei Systemvariablen (Unten) bis du die Path Variable siehst.
Steht hier ebenfalls "SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem"?
Dann liegt der Fehler hier.

Die Frage ist dann nur noch, woher das kommt.

Grüße,
LF
Bitte warten ..
Mitglied: 48507
24.02.2011 um 10:08 Uhr
Wenn man es in der Konsole eingibt, gilt Path dann nur in dieser Session, also nicht systemweit. Mach es stattdessen über Eigenschaften - Arbeitsplatz........ Umgebungsvariablen.... SYSTEMvariablen... oder ähnlich.
Bitte warten ..
Mitglied: O-Marc
24.02.2011 um 10:32 Uhr
Habe das bei den Umgebungsvariablen geändert und jetzt funktioniert alles auch nach einem Neustart.
Ich verstehe nur nicht, wie sich da ein Fehler eingeschlichen hat. Der Client wird nur von mir verwendet und mir sind keine Änderungen an Software usw. bewusst.

Vielen Dank für die Hilfe, LittleFlame und spytnik.
Bitte warten ..
Ähnliche Inhalte
Humor (lol)
Bluescreen als Retter: Windows XP zu instabil für WannaCry

Link von hugonatter zum Thema Humor (lol) ...

Windows XP
SP3 für Windows XP Embedded Version 2002 (4)

Frage von Michael-24 zum Thema Windows XP ...

Microsoft
Windows XP Embedded Partition verschwunden (4)

Frage von Tiloklom zum Thema Microsoft ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
gelöst NTFS und die Defragmentierung (28)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

Server-Hardware
Treiber für Server gesucht (15)

Frage von MeisterFuchs zum Thema Server-Hardware ...